summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSalah Coronya <salah.coronya@gmail.com>2020-11-16 17:11:29 -0600
committerJoonas Niilola <juippis@gentoo.org>2020-11-20 13:40:37 +0200
commit910fedcc6c356faf46225df8b01b93f2c4fb65d0 (patch)
tree48a7f15a8bf57eea9e60a60d97cc74d91fe2e381 /app-crypt/tpm2-tools
parentsys-apps/firejail: Cleanup old versions (diff)
downloadgentoo-910fedcc6c356faf46225df8b01b93f2c4fb65d0.tar.gz
gentoo-910fedcc6c356faf46225df8b01b93f2c4fb65d0.tar.bz2
gentoo-910fedcc6c356faf46225df8b01b93f2c4fb65d0.zip
app-crypt/tpm2-tools: Bump to 5.0
Package-Manager: Portage-3.0.8, Repoman-3.0.2 Signed-off-by: Salah Coronya <salah.coronya@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/18291 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-crypt/tpm2-tools')
-rw-r--r--app-crypt/tpm2-tools/Manifest1
-rw-r--r--app-crypt/tpm2-tools/tpm2-tools-5.0.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/app-crypt/tpm2-tools/Manifest b/app-crypt/tpm2-tools/Manifest
index 9f9afbc73bf0..23b297edef55 100644
--- a/app-crypt/tpm2-tools/Manifest
+++ b/app-crypt/tpm2-tools/Manifest
@@ -1 +1,2 @@
DIST tpm2-tools-4.3.0.tar.gz 881544 BLAKE2B 0415f30845658e84e97a964abebc3082e45fb880c10bec405cd89c7bfa373ace10b669c4af78e7e47f2d2bb62fc7cc34b2e54e392a95c8f9b8956b8c92af6aee SHA512 4e622bbc8642ba7fd93a7343900560fe3779cba03e363d16f391fc8929724a11913d238e3986de06982cbced27c3c2ca8c7e73d75796407b8646c101ccf393a8
+DIST tpm2-tools-5.0.tar.gz 990855 BLAKE2B 5d39bbef0bc6f0d84f37c64c697260343a9f9e134bce015a6b529176195adb907672f35b85382b0a4785e40e368030ac347083086c3799bdfe86dced1ac69848 SHA512 ea57a28a61e28b78cae7067ff58facd8754fafab7a2689fd93f8b3374073b6ac30301a75f8ff5c654800ab469ee6604d0b8a86c310631b9545b816ecaa05968e
diff --git a/app-crypt/tpm2-tools/tpm2-tools-5.0.ebuild b/app-crypt/tpm2-tools/tpm2-tools-5.0.ebuild
new file mode 100644
index 000000000000..3252b0db14e7
--- /dev/null
+++ b/app-crypt/tpm2-tools/tpm2-tools-5.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="Tools for the TPM 2.0 TSS"
+HOMEPAGE="https://github.com/tpm2-software/tpm2-tools"
+SRC_URI="https://github.com/tpm2-software/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+fapi libressl"
+
+# Integration test are now run as part of the testing suite, which will fail
+# because none of the supported TPM emulators are in Portage. In a future
+# version of tpm2-tools, swtpm will be supported and the tests can be run.
+RESTRICT="test"
+
+RDEPEND="net-misc/curl:=
+ >=app-crypt/tpm2-tss-3.0.1:=[fapi?]
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+PATCHES=(
+ "${FILESDIR}/${PN}-4.2.1-libressl.patch"
+ "${FILESDIR}/${PN}-4.3.0-Remove-WError.patch"
+)
+
+src_prepare() {
+ eautoreconf
+ default
+}
+
+src_configure() {
+ econf \
+ $(use_enable fapi) \
+ $(use_enable !libressl hardening)
+}