summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSalah Coronya <salah.coronya@gmail.com>2020-02-19 20:06:06 -0600
committerJoonas Niilola <juippis@gentoo.org>2020-02-26 18:17:24 +0200
commita55183cb36173cc4fcd29ba29e4d12ff15e08d47 (patch)
tree4df0fdb8cb2bc6e82afebc747cae0407cac24cb1 /app-crypt/tpm2-tss-engine
parentapp-crypt/tpm2-tss-engine: Add salah.coronya@gmail.com as proxy maintainer (diff)
downloadgentoo-a55183cb36173cc4fcd29ba29e4d12ff15e08d47.tar.gz
gentoo-a55183cb36173cc4fcd29ba29e4d12ff15e08d47.tar.bz2
gentoo-a55183cb36173cc4fcd29ba29e4d12ff15e08d47.zip
app-crypt/tpm2-tss-engine: Bump version to 1.0.1
Package-Manager: Portage-2.3.79, Repoman-2.3.16 Signed-off-by: Salah Coronya <salah.coronya@gmail.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-crypt/tpm2-tss-engine')
-rw-r--r--app-crypt/tpm2-tss-engine/Manifest1
-rw-r--r--app-crypt/tpm2-tss-engine/files/tpm2-tss-engine-1.0.1-build.patch70
-rw-r--r--app-crypt/tpm2-tss-engine/files/tpm2-tss-engine-1.0.1-libressl.patch35
-rw-r--r--app-crypt/tpm2-tss-engine/tpm2-tss-engine-1.0.1.ebuild40
4 files changed, 146 insertions, 0 deletions
diff --git a/app-crypt/tpm2-tss-engine/Manifest b/app-crypt/tpm2-tss-engine/Manifest
index 97d8452f2e52..6e9ede75088d 100644
--- a/app-crypt/tpm2-tss-engine/Manifest
+++ b/app-crypt/tpm2-tss-engine/Manifest
@@ -1 +1,2 @@
DIST tpm2-tss-engine-1.0.0.tar.gz 382277 BLAKE2B 6580eb83f4e9391a12df2fb9cb86ace385a9e29004a64f6ca9378d9b8f60572a7761f4f486e1010d435487fed28858737d2bb71b08e400e9551a7b83c198bbe7 SHA512 b06722c82c9cefd5184125b26fb46bd7b20d62631c21c51a028348833c4786b41ff64f2c1cb7d53f749a6cf35b8fae02ae02285fc43d1d044e2d2b6e2e7048a3
+DIST tpm2-tss-engine-1.0.1.tar.gz 382715 BLAKE2B b33b91bf892509f8ed88bea1ba9611f06c9342726932baebbe918fcd4208f6c4b07710db666261b7676b90feb796746552804553e79ef817c02587504d266f44 SHA512 106fc6aadf0b4b27c3b38be596356aa59b4b76ec1602e8c5564aec6b4be7e2b5d6077006ee13d41e58402255b879aadaa966c758b5b326ae32742007ce2ef238
diff --git a/app-crypt/tpm2-tss-engine/files/tpm2-tss-engine-1.0.1-build.patch b/app-crypt/tpm2-tss-engine/files/tpm2-tss-engine-1.0.1-build.patch
new file mode 100644
index 000000000000..aa2b2e4e4fd3
--- /dev/null
+++ b/app-crypt/tpm2-tss-engine/files/tpm2-tss-engine-1.0.1-build.patch
@@ -0,0 +1,70 @@
+From 92aee12fbd246461a22925dd054c4d6394c4fdf5 Mon Sep 17 00:00:00 2001
+From: Alon Bar-Lev <alon.barlev@gmail.com>
+Date: Fri, 31 May 2019 02:30:37 +0300
+Subject: [PATCH] build: add --disable-defaultflags
+
+Align with tpm2-tss to allow downstream to provide flags.
+
+Signed-off-by: Alon Bar-Lev <alon.barlev@gmail.com>
+---
+ configure.ac | 42 +++++++++++++++++++++++++-----------------
+ 1 file changed, 25 insertions(+), 17 deletions(-)
+
+https://github.com/tpm2-software/tpm2-tss-engine/pull/117
+
+diff --git a/configure.ac b/configure.ac
+index f3a399c..f59cfaf 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -80,23 +80,31 @@ AS_IF([test "x$enable_tctienvvar" = xyes], [AC_DEFINE([ENABLE_TCTIENVVAR], [1])]
+
+ AC_CONFIG_FILES([Makefile])
+
+-AX_ADD_COMPILER_FLAG([-std=c99])
+-AX_ADD_COMPILER_FLAG([-Wall])
+-AX_ADD_COMPILER_FLAG([-Wextra])
+-AX_ADD_COMPILER_FLAG([-Wformat-security])
+-AX_ADD_COMPILER_FLAG([-Werror])
+-AX_ADD_COMPILER_FLAG([-fstack-protector-all])
+-AX_ADD_COMPILER_FLAG([-fpic])
+-AX_ADD_COMPILER_FLAG([-fPIC])
+-
+-# work around GCC bug #53119
+-# https://gcc.gnu.org/bugzilla/show_bug.cgi?id=53119
+-AX_ADD_COMPILER_FLAG([-Wno-missing-braces])
+-
+-AX_ADD_LINK_FLAG([-Wl,--no-undefined])
+-AX_ADD_LINK_FLAG([-Wl,-z,noexecstack])
+-AX_ADD_LINK_FLAG([-Wl,-z,now])
+-AX_ADD_LINK_FLAG([-Wl,-z,relro])
++AC_ARG_ENABLE([defaultflags],
++ [AS_HELP_STRING([--disable-defaultflags],
++ [Disable default preprocessor, compiler, and linker flags.])],
++ [enable_defaultflags=$enableval],
++ [enable_defaultflags=yes])
++AS_IF([test "x$enable_defaultflags" = "xyes"],
++ [
++ AX_ADD_COMPILER_FLAG([-std=c99])
++ AX_ADD_COMPILER_FLAG([-Wall])
++ AX_ADD_COMPILER_FLAG([-Wextra])
++ AX_ADD_COMPILER_FLAG([-Wformat-security])
++ AX_ADD_COMPILER_FLAG([-Werror])
++ AX_ADD_COMPILER_FLAG([-fstack-protector-all])
++ AX_ADD_COMPILER_FLAG([-fpic])
++ AX_ADD_COMPILER_FLAG([-fPIC])
++
++ # work around GCC bug #53119
++ # https://gcc.gnu.org/bugzilla/show_bug.cgi?id=53119
++ AX_ADD_COMPILER_FLAG([-Wno-missing-braces])
++
++ AX_ADD_LINK_FLAG([-Wl,--no-undefined])
++ AX_ADD_LINK_FLAG([-Wl,-z,noexecstack])
++ AX_ADD_LINK_FLAG([-Wl,-z,now])
++ AX_ADD_LINK_FLAG([-Wl,-z,relro])
++ ])
+
+ AX_CODE_COVERAGE
+ m4_ifdef([_AX_CODE_COVERAGE_RULES],
+--
+2.21.0
+
diff --git a/app-crypt/tpm2-tss-engine/files/tpm2-tss-engine-1.0.1-libressl.patch b/app-crypt/tpm2-tss-engine/files/tpm2-tss-engine-1.0.1-libressl.patch
new file mode 100644
index 000000000000..66bb68e76940
--- /dev/null
+++ b/app-crypt/tpm2-tss-engine/files/tpm2-tss-engine-1.0.1-libressl.patch
@@ -0,0 +1,35 @@
+From deb2b6697babf99aaf3f64b342ce414b48638ea3 Mon Sep 17 00:00:00 2001
+From: Alon Bar-Lev <alon.barlev@gmail.com>
+Date: Fri, 31 May 2019 20:36:47 +0300
+Subject: [PATCH] build: libressl fix incomplete type
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+src/tpm2-tss-engine-rand.c:90:1: error: variable ‘rand_methods’ has initializer but incomplete type
+ 90 | static RAND_METHOD rand_methods = {
+ | ^~~~~~
+src/tpm2-tss-engine-rand.c:91:5: warning: excess elements in struct initializer
+
+Signed-off-by: Alon Bar-Lev <alon.barlev@gmail.com>
+---
+ src/tpm2-tss-engine-rand.c | 1 +
+ 1 file changed, 1 insertion(+)
+
+https://github.com/tpm2-software/tpm2-tss-engine/pull/120
+
+diff --git a/src/tpm2-tss-engine-rand.c b/src/tpm2-tss-engine-rand.c
+index 50d5661..86980a5 100644
+--- a/src/tpm2-tss-engine-rand.c
++++ b/src/tpm2-tss-engine-rand.c
+@@ -32,6 +32,7 @@
+ #include <string.h>
+
+ #include <openssl/engine.h>
++#include <openssl/rand.h>
+
+ #include <tss2/tss2_mu.h>
+ #include <tss2/tss2_esys.h>
+--
+2.21.0
+
diff --git a/app-crypt/tpm2-tss-engine/tpm2-tss-engine-1.0.1.ebuild b/app-crypt/tpm2-tss-engine/tpm2-tss-engine-1.0.1.ebuild
new file mode 100644
index 000000000000..f1b1b5c2ca02
--- /dev/null
+++ b/app-crypt/tpm2-tss-engine/tpm2-tss-engine-1.0.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="OpenSSL Engine for TPM2 devices"
+HOMEPAGE="https://github.com/tpm2-software/tpm2-tools"
+SRC_URI="https://github.com/tpm2-software/${PN}/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="libressl test"
+RESTRICT="!test? ( test )"
+
+RDEPEND=">=app-crypt/tpm2-tss-2.2.2:=
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )"
+DEPEND="${RDEPEND}
+ test? ( dev-util/cmocka )"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}/${P}-build.patch"
+ "${FILESDIR}/${P}-libressl.patch"
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable test unit) \
+ --disable-defaultflags \
+ --disable-static
+}