summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2019-01-09 22:11:19 +0200
committerAlon Bar-Lev <alonbl@gentoo.org>2019-01-09 22:12:20 +0200
commit846d47e8c5426578048aa6e41354d5e20c984fdb (patch)
tree57f996d4306f5c9ed561321c0d3237c5f7a8f247 /app-crypt/tpm2-tss
parentwww-client/firefox-bin: bump to v64.0.2 (diff)
downloadgentoo-846d47e8c5426578048aa6e41354d5e20c984fdb.tar.gz
gentoo-846d47e8c5426578048aa6e41354d5e20c984fdb.tar.bz2
gentoo-846d47e8c5426578048aa6e41354d5e20c984fdb.zip
app-crypt/tpm2-tss: add missing sys-devel/autoconf-archive dependency
Bug: https://bugs.gentoo.org/show_bug.cgi?id=675016 Signed-off-by: Alon Bar-Lev <alonbl@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'app-crypt/tpm2-tss')
-rw-r--r--app-crypt/tpm2-tss/files/tpm2-tss-2.1.0-build.patch39
-rw-r--r--app-crypt/tpm2-tss/tpm2-tss-2.1.0.ebuild3
2 files changed, 41 insertions, 1 deletions
diff --git a/app-crypt/tpm2-tss/files/tpm2-tss-2.1.0-build.patch b/app-crypt/tpm2-tss/files/tpm2-tss-2.1.0-build.patch
index 930c173239ed..85f84c38e1f1 100644
--- a/app-crypt/tpm2-tss/files/tpm2-tss-2.1.0-build.patch
+++ b/app-crypt/tpm2-tss/files/tpm2-tss-2.1.0-build.patch
@@ -47,3 +47,42 @@ index c42b487f..f9118642 100644
dnl --------- Physical TPM device -----------------------
AC_ARG_WITH([ptpm],
+From 74037d3c15b9f9d98f9b50ca4f1c1a99d239d751 Mon Sep 17 00:00:00 2001
+From: Philip Tricca <flihp@twobit.org>
+Date: Sun, 4 Nov 2018 16:17:19 -0800
+Subject: [PATCH] build: Fix breakage in generated configure script when CFLAGS
+ is set.
+
+This fixes a bug introduced in 3980bad87fe18ad9d32914e9d21dba145eba973f.
+That patch references the documentation for AC_PROG_CC but it misread
+the recommended workaround. The leading colon (aka `:`) in the
+documentation is significant.
+
+The `:` is a shell 'builtin' command that is equivalent to invoking the
+'true' command. By placing the conditional substitution of the CFLAGS
+after this, the result of the substitution will be ignored and the
+script won't fail. Without this the contents of the CFLAGS variable set
+in the environment will be interpreted as a command and since they're
+not commands the configure script will abort.
+
+Signed-off-by: Philip Tricca <flihp@twobit.org>
+---
+ configure.ac | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/configure.ac b/configure.ac
+index c4e4592e..f88fe38b 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -31,7 +31,7 @@ AC_INIT([tpm2-tss],
+ [],
+ [https://github.com/tpm2-software/tpm2-tss])
+ AC_CONFIG_MACRO_DIR([m4])
+-${CFLAGS=""}
++: ${CFLAGS=""}
+ AC_PROG_CC
+ LT_INIT()
+ AM_INIT_AUTOMAKE([foreign
+--
+2.19.2
+
diff --git a/app-crypt/tpm2-tss/tpm2-tss-2.1.0.ebuild b/app-crypt/tpm2-tss/tpm2-tss-2.1.0.ebuild
index fc172e0e91cd..e986cc524b4e 100644
--- a/app-crypt/tpm2-tss/tpm2-tss-2.1.0.ebuild
+++ b/app-crypt/tpm2-tss/tpm2-tss-2.1.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -24,6 +24,7 @@ RDEPEND="gcrypt? ( dev-libs/libgcrypt:0= )
DEPEND="${DEPEND}
test? ( dev-util/cmocka )"
BDEPEND="virtual/pkgconfig
+ sys-devel/autoconf-archive
doc? ( app-doc/doxygen )"
PATCHES=(