summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2018-07-29 20:09:03 +0300
committerAlon Bar-Lev <alonbl@gentoo.org>2018-07-29 20:09:03 +0300
commit9e8050a14793162f53e74786511a1173cba05fe8 (patch)
tree51b7a659bef8b2ac7dbbd212f6dc71563a8eca3f /app-crypt/xca
parentdev-python/cryptography: Readd python 3.7 #662404 (diff)
downloadgentoo-9e8050a14793162f53e74786511a1173cba05fe8.tar.gz
gentoo-9e8050a14793162f53e74786511a1173cba05fe8.tar.bz2
gentoo-9e8050a14793162f53e74786511a1173cba05fe8.zip
app-crypt/xca: version bump
Closes: https://bugs.gentoo.org/show_bug.cgi?id=662096 Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'app-crypt/xca')
-rw-r--r--app-crypt/xca/Manifest1
-rw-r--r--app-crypt/xca/xca-2.1.0.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/app-crypt/xca/Manifest b/app-crypt/xca/Manifest
index 5cbb5a8bd5d5..8b327ebee8dc 100644
--- a/app-crypt/xca/Manifest
+++ b/app-crypt/xca/Manifest
@@ -1 +1,2 @@
DIST xca-1.4.1.tar.gz 959107 BLAKE2B 7437cdbaa5277998de200e9a5ad3a7d44aed9ae8af8fd926d7ed1917d49bec79562455ca2e82557149d748840f299ffd66edfc7f265be7d5bdcd6e4fe8dbaf9b SHA512 8294669c4887ba7a9060c3c2c06014b8a1807898569842ed61c066e8a864de014fba51a2ff867b579048083fdd4934cc7f97c92268de4944bf4aafea9c2e7b42
+DIST xca-2.1.0.tar.gz 1055745 BLAKE2B c3ea2953be7cacb8c4c6fb6911f2e51806d40f294d8c9daef1d47da4f3e6ffa4933d199b8b92cab828286ececab2ea7195d5a46455e4d4703f0a67d0d7861db9 SHA512 ad46b290067b0a22bb6baeb0d065879bea74cd2c853f67c2be3d0c2bdaa5ca4ebef606c0f08bd0b130df4ec13418d470062b708ab479800eab7c18dffa46af03
diff --git a/app-crypt/xca/xca-2.1.0.ebuild b/app-crypt/xca/xca-2.1.0.ebuild
new file mode 100644
index 000000000000..bda63f6d6832
--- /dev/null
+++ b/app-crypt/xca/xca-2.1.0.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit xdg-utils
+
+DESCRIPTION="A GUI to OpenSSL, RSA public keys, certificates, signing requests etc"
+HOMEPAGE="http://hohnstaedt.de/xca/"
+SRC_URI="https://github.com/chris2511/${PN}/releases/download/RELEASE.${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="bindist doc libressl"
+
+RDEPEND="
+ dev-libs/libltdl:0=
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ !libressl? ( dev-libs/openssl:0=[bindist=] )
+ libressl? ( dev-libs/libressl:0= )
+ doc? ( app-text/linuxdoc-tools )"
+DEPEND="${RDEPEND}
+ dev-qt/linguist-tools:5"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.0.0-desktop.patch"
+)
+
+src_configure() {
+ econf \
+ --with-qt-version=5 \
+ $(use_enable doc) \
+ STRIP=true
+}
+
+src_compile() {
+ # enforce all to avoid the automatic silent rules
+ emake all
+}
+
+src_install() {
+ # non standard destdir
+ emake install destdir="${ED}"
+ einstalldocs
+
+ insinto /etc/xca
+ doins misc/*.txt
+
+ ewarn "Make a backup copy of your database!"
+ ewarn "This version completely changes the database format to SQL(ite)"
+ ewarn "Don't try to open it with older versions of XCA (< 1.4.0). They will corrupt the database."
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+}