summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2021-08-04 22:28:41 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2021-08-04 22:29:08 -0500
commit00c629e364c9581ff03855cb56de956fec8c6f16 (patch)
tree503dceab13d2bcc689484c0ceb1db03c4d7c2047 /app-crypt
parentapp-crypt/certbot-apache: 1.18.0 bump (diff)
downloadgentoo-00c629e364c9581ff03855cb56de956fec8c6f16.tar.gz
gentoo-00c629e364c9581ff03855cb56de956fec8c6f16.tar.bz2
gentoo-00c629e364c9581ff03855cb56de956fec8c6f16.zip
app-crypt/certbot-nginx: 1.18.0 bump
Package-Manager: Portage-3.0.20, Repoman-3.0.2 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/certbot-nginx/Manifest1
-rw-r--r--app-crypt/certbot-nginx/certbot-nginx-1.18.0.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/app-crypt/certbot-nginx/Manifest b/app-crypt/certbot-nginx/Manifest
index 75ec98d13ed0..3279f488bd1d 100644
--- a/app-crypt/certbot-nginx/Manifest
+++ b/app-crypt/certbot-nginx/Manifest
@@ -1,2 +1,3 @@
DIST certbot-1.16.0.tar.gz 1384177 BLAKE2B 4e46e7d7b9db2f6ef19fab60c2d904f84b502d2911ed496967bbe272db5352c1e9bdb65b8f45358f222214bce4721ceecc12c018b875148bc897f83c5eb63933 SHA512 c2a0c4ea52ab241e387d686a9e5ed67aa5e8b4b7d34ad8996e34562e036c25ab8b397bf482a856758ca787b97bbd78c890189250c0c3d948f03fbf91aa25ece0
DIST certbot-1.17.0.tar.gz 1386471 BLAKE2B 26cf23c481cc67e1fa0f698dee83dd42b1d382814f10bdb4d2a459f1274f3d661d2a58815c30110701d46362c3fbaee9f57089a7eda1221c9b9dadb2c48dc79d SHA512 104deb8e6e804a3a3f50c730f00307aa39d9d42756f24be009fedc27c889c1575b456455ee11441e341025db6f528359e927a347554ebd57b64c39e789576eda
+DIST certbot-1.18.0.tar.gz 1332615 BLAKE2B eb086710b943893025d6e1091470ca02de074232372f4c9fa21fa83a347fe54df988b9553c8cf6afd6e166b8c464d595171984c984008a872e16c0179bb774b2 SHA512 94b16ba0586e0f5d3036280c68f9976c25889ca48fbbe7aded41f0d9feba2300a3f0ff8fe321b39d8642bcdd874c7332cf2acb3187b5869fe415831f58a75a7b
diff --git a/app-crypt/certbot-nginx/certbot-nginx-1.18.0.ebuild b/app-crypt/certbot-nginx/certbot-nginx-1.18.0.ebuild
new file mode 100644
index 000000000000..b4f61386b477
--- /dev/null
+++ b/app-crypt/certbot-nginx/certbot-nginx-1.18.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=(python{3_7,3_8,3_9})
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+if [[ ${PV} == 9999* ]]; then
+ EGIT_REPO_URI="https://github.com/certbot/certbot.git"
+ inherit git-r3
+ S=${WORKDIR}/${P}/${PN}
+else
+ SRC_URI="https://github.com/${PN%-nginx}/${PN%-nginx}/archive/v${PV}.tar.gz -> ${PN%-nginx}-${PV}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+ S=${WORKDIR}/${PN%-nginx}-${PV}/${PN}
+fi
+
+inherit distutils-r1
+
+DESCRIPTION="Nginx plugin for certbot (Let's Encrypt Client)"
+HOMEPAGE="https://github.com/certbot/certbot https://letsencrypt.org/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ >=app-crypt/acme-${PV}[${PYTHON_USEDEP}]
+ >=app-crypt/certbot-${PV}[${PYTHON_USEDEP}]
+ >=dev-python/pyopenssl-17.3.0[${PYTHON_USEDEP}]
+ >=dev-python/pyparsing-2.2.0[${PYTHON_USEDEP}]
+ dev-python/zope-interface[${PYTHON_USEDEP}]"