summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Bock <nicolasbock@gentoo.org>2018-06-13 11:52:46 +0200
committerNicolas Bock <nicolasbock@gentoo.org>2018-06-13 11:52:57 +0200
commit0a0631cd61d1e2b05b2c939efd7345abb0396cd8 (patch)
tree4c0db184c761ac139906957bfa42ad25e6658560 /app-crypt
parentsci-visualization/veusz: bump to 3.0 (diff)
downloadgentoo-0a0631cd61d1e2b05b2c939efd7345abb0396cd8.tar.gz
gentoo-0a0631cd61d1e2b05b2c939efd7345abb0396cd8.tar.bz2
gentoo-0a0631cd61d1e2b05b2c939efd7345abb0396cd8.zip
app-crypt/kbfs: Add keybase-redirector
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/kbfs/kbfs-2.0.0-r1.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/app-crypt/kbfs/kbfs-2.0.0-r1.ebuild b/app-crypt/kbfs/kbfs-2.0.0-r1.ebuild
new file mode 100644
index 000000000000..c6b4d2bbe676
--- /dev/null
+++ b/app-crypt/kbfs/kbfs-2.0.0-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit golang-build systemd
+
+DESCRIPTION="Keybase Filesystem (KBFS)"
+HOMEPAGE="https://keybase.io/docs/kbfs"
+SRC_URI="https://github.com/keybase/kbfs/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="
+ app-crypt/gnupg
+ sys-fs/fuse
+ "
+
+src_unpack() {
+ unpack "${P}.tar.gz"
+ mkdir -vp "${S}/src/github.com/keybase" || die
+ ln -vs "${S}" "${S}/src/github.com/keybase/kbfs" || die
+}
+
+src_compile() {
+ EGO_PN="github.com/keybase/kbfs/kbfsfuse" \
+ EGO_BUILD_FLAGS="-tags production -o ${T}/kbfsfuse" \
+ golang-build_src_compile
+ EGO_PN="github.com/keybase/kbfs/kbfsgit/git-remote-keybase" \
+ EGO_BUILD_FLAGS="-tags production -o ${T}/git-remote-keybase" \
+ golang-build_src_compile
+ EGO_PN="github.com/keybase/kbfs/redirector" \
+ EGO_BUILD_FLAGS="-tags production -o ${T}/keybase-redirector" \
+ golang-build_src_compile
+}
+
+src_install() {
+ dobin "${T}/kbfsfuse"
+ dobin "${T}/git-remote-keybase"
+ dobin "${T}/keybase-redirector"
+ systemd_douserunit "${S}/packaging/linux/systemd/kbfs.service"
+}