summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2016-01-12 23:35:49 +0100
committerManuel Rüger <mrueg@gentoo.org>2016-01-12 23:36:05 +0100
commit13870da65ab9f262ab26aed74a9cf443aad73ef1 (patch)
treee175639fbd1dd96ca0ab4035117d9805bd5d4984 /app-crypt
parentgames-util/atlas: Version bump (scm snapshot), remove old (diff)
downloadgentoo-13870da65ab9f262ab26aed74a9cf443aad73ef1.tar.gz
gentoo-13870da65ab9f262ab26aed74a9cf443aad73ef1.tar.bz2
gentoo-13870da65ab9f262ab26aed74a9cf443aad73ef1.zip
app-crypt/letsencrypt-apache: Initial version
Package-Manager: portage-2.2.26
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/letsencrypt-apache/letsencrypt-apache-9999.ebuild34
-rw-r--r--app-crypt/letsencrypt-apache/metadata.xml8
2 files changed, 42 insertions, 0 deletions
diff --git a/app-crypt/letsencrypt-apache/letsencrypt-apache-9999.ebuild b/app-crypt/letsencrypt-apache/letsencrypt-apache-9999.ebuild
new file mode 100644
index 000000000000..dcd0d070be9a
--- /dev/null
+++ b/app-crypt/letsencrypt-apache/letsencrypt-apache-9999.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=(python2_7)
+
+EGIT_REPO_URI="https://github.com/letsencrypt/letsencrypt.git"
+
+inherit git-r3 distutils-r1
+
+DESCRIPTION="Apache plugin for letsencrypt"
+HOMEPAGE="https://github.com/letsencrypt/letsencrypt https://letsencrypt.org/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS=""
+IUSE="test"
+
+RDEPEND="app-crypt/letsencrypt[${PYTHON_USEDEP}]
+ app-crypt/acme[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/python-augeas[${PYTHON_USEDEP}]
+ dev-python/zope-component[${PYTHON_USEDEP}]
+ dev-python/zope-interface[${PYTHON_USEDEP}]"
+DEPEND="test? ( ${RDEPEND}
+ dev-python/nose[${PYTHON_USEDEP}] )
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+S=${WORKDIR}/${P}/${PN}
+
+python_test() {
+ nosetests -w ${PN/-/_}/tests || die
+}
diff --git a/app-crypt/letsencrypt-apache/metadata.xml b/app-crypt/letsencrypt-apache/metadata.xml
new file mode 100644
index 000000000000..bfcb6974f1c4
--- /dev/null
+++ b/app-crypt/letsencrypt-apache/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>mrueg@gentoo.org</email>
+ <name>Manuel Rüger</name>
+ </maintainer>
+</pkgmetadata>