summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2020-04-26 13:41:07 +0200
committerFabian Groffen <grobian@gentoo.org>2020-04-26 13:41:07 +0200
commit24ab505ec2d8c0a322d6ed6e60687cb095940e9d (patch)
treed97cf85fcd2411be958a4942e49d78bbcbaa08fc /app-crypt
parentprofiles/arch/arm64/package.use.mask: Remove dead virtual/ffmpeg entry (diff)
downloadgentoo-24ab505ec2d8c0a322d6ed6e60687cb095940e9d.tar.gz
gentoo-24ab505ec2d8c0a322d6ed6e60687cb095940e9d.tar.bz2
gentoo-24ab505ec2d8c0a322d6ed6e60687cb095940e9d.zip
app-crypt/libb2: revbump to fix compile with distcc, bug #704044
Closes: https://bugs.gentoo.org/704044 Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Fabian Groffen <grobian@gentoo.org>
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/libb2/files/libb2-0.98.1-distcc.patch16
-rw-r--r--app-crypt/libb2/libb2-0.98.1-r3.ebuild (renamed from app-crypt/libb2/libb2-0.98.1-r1.ebuild)21
2 files changed, 28 insertions, 9 deletions
diff --git a/app-crypt/libb2/files/libb2-0.98.1-distcc.patch b/app-crypt/libb2/files/libb2-0.98.1-distcc.patch
new file mode 100644
index 000000000000..2e6a1671781b
--- /dev/null
+++ b/app-crypt/libb2/files/libb2-0.98.1-distcc.patch
@@ -0,0 +1,16 @@
+https://bugs.gentoo.org/704044#c8
+
+Patch by Alexey
+
+--- a/src/Makefile.am 2020-04-26 11:16:22.354103351 +0100
++++ b/src/Makefile.am 2020-04-26 11:16:31.584080899 +0100
+@@ -18,8 +18,7 @@ LDFLAGS += -version-info $(B2_LIBRARY_VE
+ lib_LTLIBRARIES = libb2.la
+ libb2_la_LIBADD = # -lgomp -lpthread
+ libb2_la_CPPFLAGS = -DSUFFIX= \
+- $(LTDLINCL) \
+- ${top_builddir}/src/
++ $(LTDLINCL)
+
+ include_HEADERS = blake2.h
+
diff --git a/app-crypt/libb2/libb2-0.98.1-r1.ebuild b/app-crypt/libb2/libb2-0.98.1-r3.ebuild
index a27fb95fcee3..930713363bac 100644
--- a/app-crypt/libb2/libb2-0.98.1-r1.ebuild
+++ b/app-crypt/libb2/libb2-0.98.1-r3.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit autotools toolchain-funcs
+inherit autotools multilib-minimal toolchain-funcs
DESCRIPTION="C library providing BLAKE2b, BLAKE2s, BLAKE2bp, BLAKE2sp"
HOMEPAGE="https://github.com/BLAKE2/libb2"
@@ -12,7 +12,7 @@ SRC_URI="https://github.com/BLAKE2/libb2/archive/${GITHASH}.tar.gz -> ${P}.tar.g
LICENSE="CC0-1.0"
SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv s390 sparc x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE="static-libs native-cflags openmp"
DEPEND="
@@ -24,6 +24,8 @@ RDEPEND="${DEPEND}"
S=${WORKDIR}/${PN}-${GITHASH}
+PATCHES=( "${FILESDIR}"/${P}-distcc.patch )
+
pkg_setup() {
if [[ ${MERGE_TYPE} != "binary" ]] && use openmp && ! tc-has-openmp; then
ewarn "You are using a compiler without OpenMP support"
@@ -40,7 +42,8 @@ src_prepare() {
eautoreconf # upstream doesn't make releases
}
-src_configure() {
+multilib_src_configure() {
+ ECONF_SOURCE=${S} \
econf \
$(use_enable static-libs static) \
$(use_enable native-cflags native) \
@@ -53,15 +56,15 @@ do_make() {
emake $(use native-cflags && echo no)CFLAGS="${CFLAGS} ${openmp}" "$@"
}
-src_compile() {
+multilib_src_compile() {
do_make
}
-src_test() {
+multilib_src_test() {
do_make check
}
-src_install() {
- default
- use static-libs || find "${ED}" -name '*.la' -type f -delete || die
+multilib_src_install_all() {
+ einstalldocs
+ find "${ED}" -name '*.la' -type f -delete || die
}