summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2019-03-20 23:13:19 +0200
committerAlon Bar-Lev <alonbl@gentoo.org>2019-03-21 00:00:23 +0200
commit2523251b4d2988fd461a3e4dd44bc8d5242adf68 (patch)
treead0a17c72f7731e64ce06d9edc113b1b7b137b4d /app-crypt
parentapp-crypt/rainbowcrack: cleanup old (diff)
downloadgentoo-2523251b4d2988fd461a3e4dd44bc8d5242adf68.tar.gz
gentoo-2523251b4d2988fd461a3e4dd44bc8d5242adf68.tar.bz2
gentoo-2523251b4d2988fd461a3e4dd44bc8d5242adf68.zip
app-crypt/tpm-emulator: cleanup old
Signed-off-by: Alon Bar-Lev <alonbl@gentoo.org> Package-Manager: Portage-2.3.62, Repoman-2.3.11
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/tpm-emulator/tpm-emulator-0.7.5.ebuild82
1 files changed, 0 insertions, 82 deletions
diff --git a/app-crypt/tpm-emulator/tpm-emulator-0.7.5.ebuild b/app-crypt/tpm-emulator/tpm-emulator-0.7.5.ebuild
deleted file mode 100644
index 97b70a4785f0..000000000000
--- a/app-crypt/tpm-emulator/tpm-emulator-0.7.5.ebuild
+++ /dev/null
@@ -1,82 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-MODULES_OPTIONAL_USE="modules"
-inherit user linux-mod cmake-utils udev
-
-MY_P=${P/-/_}
-DESCRIPTION="Emulator driver for tpm"
-HOMEPAGE="https://github.com/PeterHuewe/tpm-emulator"
-SRC_URI="https://github.com/PeterHuewe/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-LICENSE="GPL-2"
-
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-IUSE="libressl mtm-emulator ssl"
-RDEPEND="ssl? (
- !libressl? ( dev-libs/openssl:0= )
- libressl? ( dev-libs/libressl:0= )
- )"
-DEPEND="${RDEPEND}
- !ssl? ( dev-libs/gmp )"
-
-PATCHES=(
- "${FILESDIR}/${P}-build.patch"
-)
-
-pkg_setup() {
- enewgroup tss
- enewuser tss -1 -1 /var/lib/tpm tss
- if use modules; then
- CONFIG_CHECK="MODULES"
- MODULE_NAMES="tpmd_dev(extra:tpmd_dev/linux:)"
- BUILD_TARGETS="all tpmd_dev.rules"
- BUILD_PARAMS="KERNEL_BUILD=${KERNEL_DIR}"
- linux-mod_pkg_setup
- fi
-}
-
-src_configure() {
- local mycmakeargs=(
- -DUSE_OPENSSL=$(usex ssl ON OFF)
- -DMTM_EMULATOR=$(usex mtm-emulator ON OFF)
- -DBUILD_DEV=OFF
- )
- cmake-utils_src_configure
-
- use modules && ln -s "${BUILD_DIR}/config.h" tpmd_dev/linux
-}
-
-src_compile() {
- cmake-utils_src_compile
- use modules && linux-mod_src_compile
-}
-
-src_install() {
- cmake-utils_src_install
- if use modules; then
- linux-mod_src_install
- udev_newrules "tpmd_dev/linux/tpmd_dev.rules" 60-tpmd_dev.rules
- fi
-
- newinitd "${FILESDIR}/${PN}.initd" "${PN}"
- newconfd "${FILESDIR}/${PN}.confd" "${PN}"
-
- keepdir /var/log/tpm
- fowners tss:tss /var/log/tpm
-}
-
-pkg_postinst() {
- if use modules; then
- linux-mod_pkg_postinst
-
- ewarn ""
- ewarn "The new init.d script does not load the tpmd_dev any more as it is optional."
- ewarn "If you use the tpmd_dev, please load it explicitly in /etc/conf.d/modules"
- ewarn ""
- fi
-
- einfo "tpmd socket is located at /var/run/tpm/tpmd_socket:0"
-}