summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2016-12-05 20:45:23 +0200
committerAlon Bar-Lev <alonbl@gentoo.org>2016-12-05 20:45:42 +0200
commit2d3830eedbe2d38207d02c355f7d90feaf0ce25b (patch)
tree576e8c15bbbde5aff2479c89f27da68703c578fb /app-crypt
parentapp-crypt/trousers: version bump (diff)
downloadgentoo-2d3830eedbe2d38207d02c355f7d90feaf0ce25b.tar.gz
gentoo-2d3830eedbe2d38207d02c355f7d90feaf0ce25b.tar.bz2
gentoo-2d3830eedbe2d38207d02c355f7d90feaf0ce25b.zip
app-crypt/tpm-tools: version bump
Bug: 601538 Thanks: Conrad Kostecki Package-Manager: portage-2.3.0
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/tpm-tools/Manifest1
-rw-r--r--app-crypt/tpm-tools/files/tpm-tools-1.3.9-gold.patch10
-rw-r--r--app-crypt/tpm-tools/tpm-tools-1.3.9.ebuild56
3 files changed, 67 insertions, 0 deletions
diff --git a/app-crypt/tpm-tools/Manifest b/app-crypt/tpm-tools/Manifest
index 91d8e0f0a252..7218765a3ab2 100644
--- a/app-crypt/tpm-tools/Manifest
+++ b/app-crypt/tpm-tools/Manifest
@@ -1 +1,2 @@
DIST tpm-tools-1.3.8.tar.gz 473339 SHA256 66eb4ff095542403db6b4bd4b574e8a5c08084fe4e9e5aa9a829ee84e20bea83 SHA512 727113625645b01f8e77817d7f1cc6a8bf814f96061754fdfefceb125da4eebbea54804d1fec9e36559ffd61801b318bbc327907a3bdd661f872c32f811c7e74 WHIRLPOOL 201677976c97961a20578f7ca1b4dd0a8a9b105a718c0c67c34b9f1de0c75332532c62389711f732c99edda8fe45639dd3c8293df0a62a11f88ed4c9dc987270
+DIST tpm-tools-1.3.9.tar.gz 484023 SHA256 ea126c5cd2ada56beb5118a141a498053f2d85f56263d215784f0ed86fff4213 SHA512 460e56031aa65ede6b7aebf0c594d4093d870fb46f7c453c429e53cca442d4c7797ac29b519bca28d42133bc6d7701cdf938adbdf11f8be841157d4f4a3e17ca WHIRLPOOL 96760809fb5f2029f51a4051621cb4dd3a39af08d2ecb091619f848d541b2bd1d6f5e9cbd2606fcde2fb55c554cb3baf74c8b58ec29660d95c42bfad178bd96c
diff --git a/app-crypt/tpm-tools/files/tpm-tools-1.3.9-gold.patch b/app-crypt/tpm-tools/files/tpm-tools-1.3.9-gold.patch
new file mode 100644
index 000000000000..1745c690e570
--- /dev/null
+++ b/app-crypt/tpm-tools/files/tpm-tools-1.3.9-gold.patch
@@ -0,0 +1,10 @@
+diff --git a/lib/Makefile.am b/lib/Makefile.am
+index cef6a2f..d7092a7 100644
+--- a/lib/Makefile.am
++++ b/lib/Makefile.am
+@@ -80,4 +80,4 @@ endif
+ # Unseal library - for addition to existing apps, counter part of seal cmd
+ libtpm_unseal_la_SOURCES = tpm_unseal.c
+ libtpm_unseal_la_LDFLAGS = -shared -version-info 1:0:0
+-libtpm_unseal_la_LIBADD = -ltspi libtpm_tspi.la @INTLLIBS@
++libtpm_unseal_la_LIBADD = -ltspi libtpm_tspi.la -lcrypto @INTLLIBS@
diff --git a/app-crypt/tpm-tools/tpm-tools-1.3.9.ebuild b/app-crypt/tpm-tools/tpm-tools-1.3.9.ebuild
new file mode 100644
index 000000000000..22944bd2f463
--- /dev/null
+++ b/app-crypt/tpm-tools/tpm-tools-1.3.9.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit autotools eutils flag-o-matic
+
+DESCRIPTION="TrouSerS' support tools for the Trusted Platform Modules"
+HOMEPAGE="http://trousers.sourceforge.net"
+SRC_URI="mirror://sourceforge/trousers/${PN}/${P}.tar.gz"
+
+LICENSE="CPL-1.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~m68k ~s390 ~sh ~x86"
+IUSE="libressl nls pkcs11 debug"
+
+COMMON_DEPEND="
+ >=app-crypt/trousers-0.3.0
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ pkcs11? ( dev-libs/opencryptoki )
+ "
+RDEPEND="${COMMON_DEPEND}
+ nls? ( virtual/libintl )"
+DEPEND="${COMMON_DEPEND}
+ nls? ( sys-devel/gettext )"
+
+PATCHES=(
+ "${FILESDIR}/${P}-gold.patch"
+)
+
+S="${WORKDIR}"
+
+src_prepare() {
+ default
+
+ sed -i -r \
+ -e '/CFLAGS/s/ -m64//' \
+ configure.ac || die
+
+ eautoreconf
+}
+
+src_configure() {
+ append-cppflags $(usex debug -DDEBUG -DNDEBUG)
+
+ econf \
+ $(use_enable nls) \
+ $(use pkcs11 || echo --disable-pkcs11-support)
+}
+
+src_install() {
+ default
+ prune_libtool_files
+}