summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2020-05-06 15:23:42 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2020-05-06 15:27:28 -0500
commit35e99e27cb033d8561513f296fda2efdbbfbe859 (patch)
tree203f93392d5242d8cfc55bca1810cd2af12db813 /app-crypt
parentdev-python/zstandard: Remove sparc keyword (the package is broken) (diff)
downloadgentoo-35e99e27cb033d8561513f296fda2efdbbfbe859.tar.gz
gentoo-35e99e27cb033d8561513f296fda2efdbbfbe859.tar.bz2
gentoo-35e99e27cb033d8561513f296fda2efdbbfbe859.zip
app-crypt/acme: 1.4.0 bump
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/acme/Manifest1
-rw-r--r--app-crypt/acme/acme-1.4.0.ebuild69
-rw-r--r--app-crypt/acme/acme-9999.ebuild1
3 files changed, 70 insertions, 1 deletions
diff --git a/app-crypt/acme/Manifest b/app-crypt/acme/Manifest
index c6644fcb5db8..24824d6ddbee 100644
--- a/app-crypt/acme/Manifest
+++ b/app-crypt/acme/Manifest
@@ -1 +1,2 @@
DIST certbot-1.3.0.tar.gz 1362945 BLAKE2B bb36a7737275332f018d7f2283286e07e041892cc366f79e68df9eee7e57ca2186d36895d1923b032068a365878d09e49e17c1399a7418dbd8607c9a7efc1c26 SHA512 4205cdd1f3ddf500b9b952744db234636c086a856df80acd2d776305f4501eed07995e453e5c9b2c711fb0d1f1987d2bb8baaa13fccce8e000a38f486cfdc5d3
+DIST certbot-1.4.0.tar.gz 1381435 BLAKE2B 57d70a12ee38e1ba96f4c8c594c1940403e33d4cdf5111472a9c0c7d41061b2201792c38d9bb4ec516358f5592d2f689eeab31e1e686a534418b20eba2df4b4b SHA512 8926f724c47c0249e2e420cd8944f0b106682efaa2d9b211491ea4524fe4e64bb3ff4f21fd756996049d781a68294ab8307bd077b6d96fa00e09cbbdf4e59261
diff --git a/app-crypt/acme/acme-1.4.0.ebuild b/app-crypt/acme/acme-1.4.0.ebuild
new file mode 100644
index 000000000000..1d83c8b8d408
--- /dev/null
+++ b/app-crypt/acme/acme-1.4.0.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=(python{3_6,3_7,3_8})
+
+if [[ ${PV} == 9999* ]]; then
+ EGIT_REPO_URI="https://github.com/certbot/certbot.git"
+ inherit git-r3
+ S=${WORKDIR}/${P}/${PN}
+else
+ SRC_URI="https://github.com/certbot/certbot/archive/v${PV}.tar.gz -> certbot-${PV}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+ S=${WORKDIR}/certbot-${PV}/acme
+fi
+
+inherit distutils-r1
+
+DESCRIPTION="An implementation of the ACME protocol"
+HOMEPAGE="https://github.com/certbot/certbot https://letsencrypt.org/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="doc test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/cryptography-1.3.4[${PYTHON_USEDEP}]
+ >=dev-python/idna-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/josepy-1.1.0[${PYTHON_USEDEP}]
+ >=dev-python/pyopenssl-0.13.1[${PYTHON_USEDEP}]
+ dev-python/pyrfc3339[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.10[${PYTHON_USEDEP}]
+ >=dev-python/requests-toolbelt-0.3.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+"
+DEPEND="
+ doc? (
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]
+ )
+ test? (
+ ${RDEPEND}
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+ >=dev-python/setuptools-1.0[${PYTHON_USEDEP}]
+"
+
+src_compile() {
+ python_foreach_impl run_in_build_dir default
+ distutils-r1_src_compile
+ if use doc ; then
+ cd docs || die
+ sphinx-build -b html -d _build/doctrees . _build/html
+ fi
+}
+
+python_test() {
+ nosetests -w ${PN} || die
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+
+ distutils-r1_python_install_all
+}
diff --git a/app-crypt/acme/acme-9999.ebuild b/app-crypt/acme/acme-9999.ebuild
index baec59de4e1e..1d83c8b8d408 100644
--- a/app-crypt/acme/acme-9999.ebuild
+++ b/app-crypt/acme/acme-9999.ebuild
@@ -28,7 +28,6 @@ RDEPEND="
>=dev-python/cryptography-1.3.4[${PYTHON_USEDEP}]
>=dev-python/idna-2.0.0[${PYTHON_USEDEP}]
>=dev-python/josepy-1.1.0[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
>=dev-python/pyopenssl-0.13.1[${PYTHON_USEDEP}]
dev-python/pyrfc3339[${PYTHON_USEDEP}]
dev-python/pytz[${PYTHON_USEDEP}]