summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2022-03-21 00:27:43 -0500
committerMatthias Maier <tamiko@gentoo.org>2022-03-21 00:27:43 -0500
commit4aefdf748e76459c11045761b24760a98940a9c1 (patch)
tree33214ae4e2fffcee5e81189617c399a65ecda2f2 /app-crypt
parentdev-python/setuptools: Keyword 60.10.0 riscv, #832036 (diff)
downloadgentoo-4aefdf748e76459c11045761b24760a98940a9c1.tar.gz
gentoo-4aefdf748e76459c11045761b24760a98940a9c1.tar.bz2
gentoo-4aefdf748e76459c11045761b24760a98940a9c1.zip
app-crypt/jitterentropy-rngd: add 1.2.7
Signed-off-by: Matthias Maier <tamiko@gentoo.org>
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/jitterentropy-rngd/Manifest1
-rw-r--r--app-crypt/jitterentropy-rngd/jitterentropy-rngd-1.2.7.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/app-crypt/jitterentropy-rngd/Manifest b/app-crypt/jitterentropy-rngd/Manifest
index c933aceadc60..f3618b9e43af 100644
--- a/app-crypt/jitterentropy-rngd/Manifest
+++ b/app-crypt/jitterentropy-rngd/Manifest
@@ -1,2 +1,3 @@
DIST jitterentropy-rngd-1.2.5.tar.gz 45262 BLAKE2B 0fdbd513f0dd2fa216c079d55790ea2848fac26ca17846cfce06d0d338e8e88a13f2e9a7a7d55c938f0366f7cb010d22fc35d63921e4bb1408a5bda73ac9e96c SHA512 23079ff64e1145efa22960dfa772f77dd27f45f1cd950fe7b3a45d56cb75920902a7136da92a7202c686f33db0895115624ac3d809627378056ca13250e5b07b
DIST jitterentropy-rngd-1.2.6.tar.gz 45213 BLAKE2B f193aef0d2a39792c0fac9b5a949f493377d98a282b921d9f4d01ddac5a4f423002e9d61b8e920d35e9f6a608ae2f1341f7255084ec9d501e64ebd1a1d72a9cf SHA512 fc59f84a24b2a2078c6bb4524b9feddfb2033c97390b20a9654294211208ef50399968ad8a19f7b82079eb987841e703fdb5aee98b60f1159244bd28ee43db75
+DIST jitterentropy-rngd-1.2.7.tar.gz 46546 BLAKE2B 82f0610ab5e2dd4ac42b5c2a72a59cc9c78dd65f82327302d4699b129280d45bf61a7197d44d3d141b6ccd3b512b984b0f95f1594c97a8c54f10c0d58906089c SHA512 4d89110cb7456b360f4c268121b61c2141b9d592877728eb94de0c8679928689b3b039a99579af4ee1299a1eb538c9a2d4527d9a4e98f85022c590a0d01f4811
diff --git a/app-crypt/jitterentropy-rngd/jitterentropy-rngd-1.2.7.ebuild b/app-crypt/jitterentropy-rngd/jitterentropy-rngd-1.2.7.ebuild
new file mode 100644
index 000000000000..1d082547ec2f
--- /dev/null
+++ b/app-crypt/jitterentropy-rngd/jitterentropy-rngd-1.2.7.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic linux-info systemd
+
+DESCRIPTION="Jitter RNG daemon"
+HOMEPAGE="https://www.chronox.de/jent.html"
+SRC_URI="https://github.com/smuellerDD/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~x86"
+IUSE=""
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.1.0-do-not-strip-and-compress.patch
+)
+
+src_configure() {
+ filter-flags '*'
+ append-cflags '-O0'
+ default
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" \
+ UNITDIR="$(systemd_get_systemunitdir)" install
+ newinitd "${FILESDIR}"/jitterentropy-rngd-initd jitterentropy-rngd
+}