summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGöktürk Yüksek <gokturk@gentoo.org>2018-07-17 18:34:43 -0400
committerGöktürk Yüksek <gokturk@gentoo.org>2018-07-17 18:35:28 -0400
commit54a02cb18f981b52049c38db606ca35dd5986787 (patch)
treef4b7a82d4f2a06228be7220589d2e016ad22a82e /app-crypt
parentapp-crypt/yubikey-manager: bump to 0.7.1 (diff)
downloadgentoo-54a02cb18f981b52049c38db606ca35dd5986787.tar.gz
gentoo-54a02cb18f981b52049c38db606ca35dd5986787.tar.bz2
gentoo-54a02cb18f981b52049c38db606ca35dd5986787.zip
app-crypt/yubikey-manager-qt: bump to 0.5.2
Package-Manager: Portage-2.3.41, Repoman-2.3.9
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/yubikey-manager-qt/Manifest1
-rw-r--r--app-crypt/yubikey-manager-qt/yubikey-manager-qt-0.5.2.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/app-crypt/yubikey-manager-qt/Manifest b/app-crypt/yubikey-manager-qt/Manifest
index 5a6a6b8388d9..55b851d5443b 100644
--- a/app-crypt/yubikey-manager-qt/Manifest
+++ b/app-crypt/yubikey-manager-qt/Manifest
@@ -1,2 +1,3 @@
DIST yubikey-manager-qt-0.4.0.tar.gz 183566 BLAKE2B 2364d0d257ab5c05d0555aba4bb01ee1639a2c3a42b47173ae905945a6265b123985ad7d8fe50b0cfd38a1a0a588f3e1424aa46585ddbf50337ce2456899067e SHA512 12cef9636f06a92fdb3fce7cea5b97af3255b9cdd1b4feb4e184999eb77c17e465db927f56cd0e443a8ce8afc27b7e4be19ed07da7c41259f909ac4e98971de2
DIST yubikey-manager-qt-0.5.1.tar 655360 BLAKE2B 6b109190750bd9675e32c836831a7e0ea286021303deffc64a351f2a127f5a5ee0190e3ca99abf0407bbb34a1a1c454f453fab464de2726f6cae539d5f865da1 SHA512 a8ceab5fd8d20eca2424d3f9a92ad12066e8fc26a7640df478965e5d9e2896fbc64885b26f599fcb2588f5b64d2f046af373f87e23ef266178ddf877e422ed36
+DIST yubikey-manager-qt-0.5.2.tar.gz 337194 BLAKE2B d6020116b9082671c039b521bbeebe7c1f0be022e233abbf8d6d788ea94e69e5f88aa3d6ec26a7b2edffa698327bb049e83ce54db2e0ba2ed1ad1dd536ab0961 SHA512 29265a10ae1dfe14dfdf4f1ba225516bf3bcbeb0115ca81696a4c5c506e957d6a99b0bb11a608e3175df99b8c04e8ae9250d5d42aab2b44b633d18fd2fc4c227
diff --git a/app-crypt/yubikey-manager-qt/yubikey-manager-qt-0.5.2.ebuild b/app-crypt/yubikey-manager-qt/yubikey-manager-qt-0.5.2.ebuild
new file mode 100644
index 000000000000..5ef5ff7b2493
--- /dev/null
+++ b/app-crypt/yubikey-manager-qt/yubikey-manager-qt-0.5.2.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{4,5,6} )
+
+inherit eutils qmake-utils python-single-r1
+
+DESCRIPTION="Cross-platform application for configuring any YubiKey over all USB transports"
+HOMEPAGE="https://developers.yubico.com/yubikey-manager-qt https://github.com/Yubico/yubikey-manager-qt"
+SRC_URI="https://github.com/Yubico/yubikey-manager-qt/releases/download/${P}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="
+ >=app-crypt/yubikey-manager-0.7.0[${PYTHON_USEDEP}]
+ <app-crypt/yubikey-manager-0.8
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/pyotherside[${PYTHON_USEDEP}]
+ dev-qt/qtsingleapplication[qt5(+),X]
+ dev-qt/qtdeclarative:5
+ dev-qt/qtsvg:5
+ dev-qt/qtquickcontrols:5[widgets]
+ dev-qt/qtwidgets:5"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/"
+
+src_prepare() {
+ default
+
+ sed -i -e "s/ykman-cli//" ${PN}.pro || die
+ sed -e "/qtsingleapplication.pri/d" \
+ -e "/CONFIG += c++11/a CONFIG += qtsingleapplication" \
+ -i ykman-gui/ykman-gui.pro || die
+
+ # See: https://github.com/Yubico/yubikey-manager-qt/issues/54
+ echo "${PV}" > "${S}"/VERSION || die
+}
+
+src_configure() {
+ eqmake5
+}
+
+src_install() {
+ emake install INSTALL_ROOT="${D}"
+
+ domenu resources/ykman-gui.desktop
+ doicon -s 128 resources/icons/ykman.png
+ doicon -s scalable resources/icons/ykman.svg
+
+ einstalldocs
+}