summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJory Pratt <anarchy@gentoo.org>2021-12-23 08:53:11 -0600
committerJory Pratt <anarchy@gentoo.org>2021-12-23 08:53:33 -0600
commit72e46251ccb5cc11fc27c25d5dd534c5c025c3d4 (patch)
tree628f4894a3693814689e3d1d41fd5b4672127fc2 /app-crypt
parentmedia-libs/shaderc: add python 3.10 (diff)
downloadgentoo-72e46251ccb5cc11fc27c25d5dd534c5c025c3d4.tar.gz
gentoo-72e46251ccb5cc11fc27c25d5dd534c5c025c3d4.tar.bz2
gentoo-72e46251ccb5cc11fc27c25d5dd534c5c025c3d4.zip
app-crypt/chntpw: fix missing include stdint.h
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Jory Pratt <anarchy@gentoo.org>
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/chntpw/chntpw-140201.ebuild10
-rw-r--r--app-crypt/chntpw/files/chntpw-140201-missing-stdint.patch26
-rw-r--r--app-crypt/chntpw/metadata.xml8
3 files changed, 37 insertions, 7 deletions
diff --git a/app-crypt/chntpw/chntpw-140201.ebuild b/app-crypt/chntpw/chntpw-140201.ebuild
index 9e452d567995..1daf1b00e051 100644
--- a/app-crypt/chntpw/chntpw-140201.ebuild
+++ b/app-crypt/chntpw/chntpw-140201.ebuild
@@ -6,12 +6,12 @@ EAPI=7
inherit toolchain-funcs
DESCRIPTION="Offline Windows NT Password & Registry Editor"
-HOMEPAGE="https://pogostick.net/~pnh/ntpasswd/"
-SRC_URI="https://pogostick.net/~pnh/ntpasswd/${PN}-source-${PV}.zip"
+HOMEPAGE="http://pogostick.net/~pnh/ntpasswd/"
+SRC_URI="http://pogostick.net/~pnh/ntpasswd/${PN}-source-${PV}.zip"
LICENSE="GPL-2 LGPL-2.1"
SLOT="0"
-KEYWORDS="amd64 ppc x86"
+KEYWORDS="~amd64 ~ppc ~x86"
IUSE="static"
RDEPEND="dev-libs/openssl:0="
@@ -26,6 +26,10 @@ DOCS=(
regedit.txt
)
+PATCHES=(
+ "${FILESDIR}"/${P}-missing-stdint.patch
+)
+
src_prepare() {
default
sed -i -e '/-o/s:$(CC):$(CC) $(LDFLAGS):' Makefile || die
diff --git a/app-crypt/chntpw/files/chntpw-140201-missing-stdint.patch b/app-crypt/chntpw/files/chntpw-140201-missing-stdint.patch
new file mode 100644
index 000000000000..de33ebff0659
--- /dev/null
+++ b/app-crypt/chntpw/files/chntpw-140201-missing-stdint.patch
@@ -0,0 +1,26 @@
+From c72bedece14b5797b1826e779c7fcb3e3024f820 Mon Sep 17 00:00:00 2001
+From: Jory Pratt <anarchy@gentoo.org>
+Date: Thu, 11 Jul 2019 14:19:30 -0500
+Subject: [PATCH] include missing stdint header
+
+Signed-off-by: Jory Pratt <anarchy@gentoo.org>
+Upstream-Status: Submitted
+---
+ ntreg.h | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/ntreg.h b/ntreg.h
+index 4b46106..d6fc7cf 100644
+--- a/ntreg.h
++++ b/ntreg.h
+@@ -24,6 +24,7 @@
+
+ #ifndef _INCLUDE_NTREG_H
+ #define _INCLUDE_NTREG_H 1
++#include <stdint.h>
+
+ #define SZ_MAX 4096 /* Max unicode strlen before we truncate */
+
+--
+2.22.0
+
diff --git a/app-crypt/chntpw/metadata.xml b/app-crypt/chntpw/metadata.xml
index beac02a9af14..040cba5f7c5b 100644
--- a/app-crypt/chntpw/metadata.xml
+++ b/app-crypt/chntpw/metadata.xml
@@ -1,8 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer type="person">
- <email>marecki@gentoo.org</email>
- <name>Marek Szuba</name>
+ <maintainer type="project">
+ <email>crypto@gentoo.org</email>
+ <name>Crypto</name>
</maintainer>
</pkgmetadata>