summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPierre-Olivier Mercier <nemunaire@nemunai.re>2020-04-16 12:22:25 +0200
committerJoonas Niilola <juippis@gentoo.org>2020-04-17 10:35:55 +0300
commit917566571faa314db9499df4a7af98ce5ab8878e (patch)
tree203eaaf756406a7c90e7bdecca96075f331ec851 /app-crypt
parentgames-util/pyfa: version bump to 2.20.1 (diff)
downloadgentoo-917566571faa314db9499df4a7af98ce5ab8878e.tar.gz
gentoo-917566571faa314db9499df4a7af98ce5ab8878e.tar.bz2
gentoo-917566571faa314db9499df4a7af98ce5ab8878e.zip
app-crypt/moolticute: bump to 0.43.3
Closes: https://bugs.gentoo.org/717546 Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Pierre-Olivier Mercier <nemunaire@nemunai.re> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/moolticute/Manifest1
-rw-r--r--app-crypt/moolticute/moolticute-0.43.3.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/app-crypt/moolticute/Manifest b/app-crypt/moolticute/Manifest
index 4a7104481aa6..df8395c18f02 100644
--- a/app-crypt/moolticute/Manifest
+++ b/app-crypt/moolticute/Manifest
@@ -1 +1,2 @@
DIST moolticute-0.42.1.tar.gz 5647992 BLAKE2B 0e99e16d7c09320ca5a97cc7ed16f348245efccf9c1e4755f7e6ccfb66c293b878e200ffe5148c203fae300d41e9b44d9489d8e067cd39b475215393a991d6d5 SHA512 a5a9ade4d09711030c299fcb7ba42eb351d711a351caeb663d765e394860a45179a3f3852db4f2315082e759762f7bf66c888cba90cb520169dc869ce60b8a68
+DIST moolticute-0.43.3.tar.gz 5667511 BLAKE2B 7509a7e84979a4bd4d36728f67b9d4cdf5df74255f4f8091a647d2d7c9a3e6dc2ef1c72fe1cadcdab47ac99a7a682287c629e0e077c031ad27acde66c53ceb6d SHA512 4ea61da5068079e01ba6e6adacc87714f3fb28a2f231fad3359d88c8697b0a804005bf73b5ca9c3e48acb9cf72b21a3791752c8d747869b48b02c1b651a92f19
diff --git a/app-crypt/moolticute/moolticute-0.43.3.ebuild b/app-crypt/moolticute/moolticute-0.43.3.ebuild
new file mode 100644
index 000000000000..b4fd0cdb9d53
--- /dev/null
+++ b/app-crypt/moolticute/moolticute-0.43.3.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+if [[ ${PV} == 9999* ]]; then
+ EGIT_REPO_URI="https://github.com/mooltipass/moolticute.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/mooltipass/moolticute/archive/v${PV/_/-}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm"
+fi
+
+inherit xdg-utils qmake-utils udev
+
+DESCRIPTION="Mooltipass crossplatform daemon/tools"
+HOMEPAGE="https://github.com/mooltipass/moolticute"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ >=dev-libs/libusb-1.0.20
+ dev-qt/qtdbus:5
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qttest:5
+ dev-qt/qtwebsockets:5
+ dev-qt/qtwidgets:5
+"
+BDEPEND="${RDEPEND}
+ dev-qt/linguist-tools:5
+"
+
+S="${WORKDIR}/${P/_/-}"
+
+src_prepare() {
+ default
+
+ # Fill version.h with package version
+ if [[ ${PV} != 9999* ]]; then
+ sed -i "s/\"git\"/\"v${PV/_/-}\"/" src/version.h || die
+ fi
+}
+
+src_configure() {
+ eqmake5 PREFIX="/usr" Moolticute.pro
+}
+
+src_install() {
+ emake install INSTALL_ROOT="${D}"
+
+ udev_dorules "${FILESDIR}/50-mooltipass.rule"
+ newinitd "${FILESDIR}/moolticuted.init" moolticuted
+}
+
+pkg_postinst() {
+ udev_reload
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}