summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2020-04-22 10:24:27 +0200
committerJeroen Roovers <jer@gentoo.org>2020-04-22 10:29:44 +0200
commit931194767f5aeea434a4e2bb14f365e00307e6ae (patch)
treefb66c9c5924373d09bba6b2af74ea1d10c2be8d8 /app-crypt
parentwww-client/opera: Version 68.0.3618.46 (diff)
downloadgentoo-931194767f5aeea434a4e2bb14f365e00307e6ae.tar.gz
gentoo-931194767f5aeea434a4e2bb14f365e00307e6ae.tar.bz2
gentoo-931194767f5aeea434a4e2bb14f365e00307e6ae.zip
app-crypt/md6sum: Set CFLAGS+=-fcommon
This code is particularly evil in that it expressly omits a declaration of the compression_hook function and apparently fully intended to rely on the -fcommon mechanism to toggle debugging functions. See md6.h for the rationale. Package-Manager: Portage-2.3.99, Repoman-2.3.22 Closes: https://bugs.gentoo.org/706780 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/md6sum/md6sum-1.0-r2.ebuild8
1 files changed, 7 insertions, 1 deletions
diff --git a/app-crypt/md6sum/md6sum-1.0-r2.ebuild b/app-crypt/md6sum/md6sum-1.0-r2.ebuild
index 631b65b9a6e8..5859b5ca9af3 100644
--- a/app-crypt/md6sum/md6sum-1.0-r2.ebuild
+++ b/app-crypt/md6sum/md6sum-1.0-r2.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+inherit flag-o-matic
DESCRIPTION="A C implementation of MD6"
HOMEPAGE="https://groups.csail.mit.edu/cis/md6"
@@ -16,3 +17,8 @@ PATCHES=(
"${FILESDIR}/${P}-cflags.patch"
"${FILESDIR}/${P}-format-security.patch"
)
+
+src_configure() {
+ append-cflags -fcommon # bug #706780
+ default
+}