summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Byrne <salah.coronya@gmail.com>2022-03-08 17:24:50 -0600
committerIonen Wolkens <ionen@gentoo.org>2022-03-10 19:03:05 -0500
commita692c6ab16d77c8fde5723e3d8487a5bbb1e918a (patch)
tree957d3b3fdf0a19c668a1389cedeac66ead53c5ca /app-crypt
parentdev-libs/libtpms: Remove old (diff)
downloadgentoo-a692c6ab16d77c8fde5723e3d8487a5bbb1e918a.tar.gz
gentoo-a692c6ab16d77c8fde5723e3d8487a5bbb1e918a.tar.bz2
gentoo-a692c6ab16d77c8fde5723e3d8487a5bbb1e918a.zip
app-crypt/swtpm: Bump to 0.7.2
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Christopher Byrne <salah.coronya@gmail.com> Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/swtpm/Manifest1
-rw-r--r--app-crypt/swtpm/swtpm-0.7.2.ebuild70
2 files changed, 71 insertions, 0 deletions
diff --git a/app-crypt/swtpm/Manifest b/app-crypt/swtpm/Manifest
index 1e26b60bc42f..8307ae94af41 100644
--- a/app-crypt/swtpm/Manifest
+++ b/app-crypt/swtpm/Manifest
@@ -1 +1,2 @@
DIST swtpm-0.7.1.tar.gz 353819 BLAKE2B dcabe72fc93c9e8099b879457d7698bf16a3c1b72ff3df9c040b1b0f3a72b3a3c453405626ade745e62d0aea4449f743c8039680accc496709915f689a69395b SHA512 c6eeb79f85550f2a184fa4a1e0d2e5b110f988b6153489001b356c2c16ee332fd462abeb77ca31268e71c3dd1680596f46dcea5031fdce185314cadb6a354c2b
+DIST swtpm-0.7.2.tar.gz 353941 BLAKE2B e4d69919b5d255cff5eb9cda4c98e84e9fd53290360312742f95d63444ad5279fc7808e7f2e040cc2c87475c409b3c0f22e54ca301e8cb18bee71290f661ecc8 SHA512 91a8f9371a13f5f6bb329ef4bd7638fb9abe5ec84631b1d22e7eb9abcb91b7f3cccfdf147f65d54c03bf4d8a141b6b5fb6385d90f78d35096bd3b8ce140d39cb
diff --git a/app-crypt/swtpm/swtpm-0.7.2.ebuild b/app-crypt/swtpm/swtpm-0.7.2.ebuild
new file mode 100644
index 000000000000..445bd551d578
--- /dev/null
+++ b/app-crypt/swtpm/swtpm-0.7.2.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8,9,10} )
+
+inherit autotools python-single-r1
+
+DESCRIPTION="Libtpms-based TPM emulator"
+HOMEPAGE="https://github.com/stefanberger/swtpm"
+SRC_URI="https://github.com/stefanberger/swtpm/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="fuse +gnutls seccomp test"
+RESTRICT="!test? ( test )"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="fuse? (
+ dev-libs/glib:2
+ sys-fs/fuse:0
+ )
+ gnutls? (
+ dev-libs/libtasn1:=
+ >=net-libs/gnutls-3.1.0:=[tools,pkcs11]
+ )
+ seccomp? ( sys-libs/libseccomp )
+ acct-group/tss
+ acct-user/tss
+ dev-libs/openssl:0=
+ dev-libs/json-glib
+ dev-libs/libtpms
+ ${PYTHON_DEPS}"
+
+DEPEND="${RDEPEND}
+ test? (
+ net-misc/socat
+ dev-tcltk/expect
+ )"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-0.6.0-fix-localca-path.patch"
+ "${FILESDIR}/${PN}-0.5.0-build-sys-Remove-WError.patch"
+)
+
+src_prepare() {
+ use test || eapply "${FILESDIR}/${PN}-0.5.0-disable-test-dependencies.patch"
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --with-openssl \
+ --without-selinux \
+ $(use_with fuse cuse) \
+ $(use_with gnutls) \
+ $(use_with seccomp)
+}
+
+src_install() {
+ default
+ fowners -R tss:root /var/lib/swtpm-localca
+ fperms 750 /var/lib/swtpm-localca
+ keepdir /var/lib/swtpm-localca
+ find "${D}" -name '*.la' -delete || die
+}