summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Auty <ikelos@gentoo.org>2020-05-04 23:39:30 +0100
committerMike Auty <ikelos@gentoo.org>2020-05-04 23:39:30 +0100
commitb3a8a8689be238dedfe32d176b8c7e2cdac13d31 (patch)
tree451e01d6bc65a69ba0e0ed5e79d01b383f6e7e1f /app-crypt
parentx11-misc/wmname: QA fix SRC_URI (diff)
downloadgentoo-b3a8a8689be238dedfe32d176b8c7e2cdac13d31.tar.gz
gentoo-b3a8a8689be238dedfe32d176b8c7e2cdac13d31.tar.bz2
gentoo-b3a8a8689be238dedfe32d176b8c7e2cdac13d31.zip
app-crypt/xca: Bump to 2.3.0 (thanks to polynomial-c!)
This has been bumped (as mentioned by polynomial-c) and additionally removes hard-coded CFLAGS of O2 and ggdb (also courtesy of polynomial-c). Thanks! 5:) Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Mike Auty <ikelos@gentoo.org>
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/xca/Manifest1
-rw-r--r--app-crypt/xca/xca-2.3.0.ebuild70
2 files changed, 71 insertions, 0 deletions
diff --git a/app-crypt/xca/Manifest b/app-crypt/xca/Manifest
index 84a6b9d851e8..7771e5c89ed7 100644
--- a/app-crypt/xca/Manifest
+++ b/app-crypt/xca/Manifest
@@ -1,2 +1,3 @@
DIST xca-2.1.2.tar.gz 1086563 BLAKE2B d48727fffad16d840633af6e0ee38a279978a5b865eb6f391a3d852a0105817254ea0a4780875f2956e1f7e9931e6930c6ffbe82b117dbf8ad0058ec9d6f5c88 SHA512 1f104a22b83b802576b4820b7139971da50f9b3dd70aca8e1199e996bad4379b8681bb31b197b84a3dfa49cef4ae093f6622d15fac9667547ff47af43c1e5f07
DIST xca-2.2.1.tar.gz 1339412 BLAKE2B 5d3e33a711919d85bc3457ddd596f2272f0136d96290aeb31e6d03ea86faff00be3590862e4c96d9214542db1bd536d0d22c6c04cd5071b253bbefe3ab3f4f56 SHA512 90eaf4a859779d57a4c0201dc403d67e005bd540145b9f543e13b8d5c42199f2ea05543de24b071d19a0db8e5b1e9f3bef2aea4bfe9f71f81007a5f5bb3ba406
+DIST xca-2.3.0.tar.gz 1354154 BLAKE2B 31a4ac96819e8d2f7e5f623cc343f0cbff18c931ed0699dbe093dcb963c3431a3943c4dcd8f3d727896104c05a565d062b9678169bf2a8d3f7cf7748c311b53b SHA512 35522aa308e1022a739f3255f13fcf63f481000f9b7411027a009a185e33ddceeb5cf9b55406a4899d2393c7e5ace10354ff24b3b2b0c3045d110f679756b0b8
diff --git a/app-crypt/xca/xca-2.3.0.ebuild b/app-crypt/xca/xca-2.3.0.ebuild
new file mode 100644
index 000000000000..0473f9f3358c
--- /dev/null
+++ b/app-crypt/xca/xca-2.3.0.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit xdg-utils
+
+DESCRIPTION="A GUI to OpenSSL, RSA public keys, certificates, signing requests etc"
+HOMEPAGE="https://hohnstaedt.de/xca/"
+SRC_URI="https://github.com/chris2511/${PN}/releases/download/RELEASE.${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="bindist doc libressl"
+
+RDEPEND="
+ dev-libs/libltdl:0=
+ dev-qt/qtgui:5
+ dev-qt/qtsql:5[sqlite]
+ dev-qt/qtwidgets:5
+ !libressl? ( dev-libs/openssl:0=[bindist=] )
+ libressl? ( >=dev-libs/libressl-2.7.0:0= )
+ doc? ( app-text/linuxdoc-tools )"
+DEPEND="${RDEPEND}
+ dev-qt/linguist-tools:5"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.0.0-desktop.patch"
+)
+
+src_configure() {
+ econf \
+ --with-qt-version=5 \
+ $(use_enable doc) \
+ STRIP=true
+}
+
+src_prepare() {
+ sed '/^CFLAGS/s@-O2 -ggdb@@' -i Local.mak.in || die
+ default
+}
+
+src_compile() {
+ # enforce all to avoid the automatic silent rules
+ emake all
+}
+
+src_install() {
+ default
+
+ insinto /etc/xca
+ doins misc/*.txt
+
+ ewarn "Make a backup copy of your database!"
+ ewarn "Version 2 completely changes the database format to SQL(ite)"
+ ewarn "Don't try to open it with older versions of XCA (< 1.4.0). They will corrupt the database."
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+}