summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2020-02-05 11:13:31 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2020-02-05 11:22:56 -0600
commitc6e60dd1eafe934a9daa1fcc94833b39b0212a05 (patch)
tree577aebc13195bdc57c45442c1f9a6601a2429aeb /app-crypt
parentapp-crypt/acme: 0.39.0 and 0.40.1 cleanup (diff)
downloadgentoo-c6e60dd1eafe934a9daa1fcc94833b39b0212a05.tar.gz
gentoo-c6e60dd1eafe934a9daa1fcc94833b39b0212a05.tar.bz2
gentoo-c6e60dd1eafe934a9daa1fcc94833b39b0212a05.zip
app-crypt/certbot: 1.2.0 bump
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/certbot/Manifest1
-rw-r--r--app-crypt/certbot/certbot-1.2.0.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/app-crypt/certbot/Manifest b/app-crypt/certbot/Manifest
index 67e69bb7f4fb..0177f131f910 100644
--- a/app-crypt/certbot/Manifest
+++ b/app-crypt/certbot/Manifest
@@ -2,3 +2,4 @@ DIST certbot-0.39.0.tar.gz 1350312 BLAKE2B 5f21c45d25754cb1ed0ad92e8d03637928a27
DIST certbot-0.40.1.tar.gz 1353347 BLAKE2B 86b3df4047101d00d5f17cf3a1a11e5800e850f5a9f736507ad373e552c27e9e4a3a17695f5a817d191cad383fc17336214fc1d8de7a99354ce4d2f5c6e728c1 SHA512 e5517a20cf26efba850728b3f81db5d6c3c5570b0a1c8eeeec9d4a4401ac04bcf44c6a2f1c248bf6e0b1be4a21b54f6168ccd11dc766304805f13b4cb16336b3
DIST certbot-1.0.0.tar.gz 1336032 BLAKE2B ca26cfd3d9f802b09eaf387225f24fbb01385f81dfa661dfb5acbd97982a6fc773c56abf6b3f99db7f2b0cdc8c5a7175d264714592858b38217e444d4e1d2b4b SHA512 649ddd3d9305e166ef36de4e4e48b1171d5f369d9d60c026ab37a03e7b221cd815e93e69460662e6436b56cec076005582457e9d45499114306ad808a2497912
DIST certbot-1.1.0.tar.gz 1346768 BLAKE2B 5c86edec3102ce0eb822465458ec86cbc98eb5e76c3c582d8a72ecab91e709f16e7a1576c684bc04bfd0c70918f34e84e0b3b264f949a1fb9bf9503fa9d6b179 SHA512 905b21a8a50b4df4eb92b464d10dec094ba4e7f5eaf3ad3dae1704a794952df6b51873ca919246a9b6698fd652a7c264efc742617ba0a25757ab99397759c343
+DIST certbot-1.2.0.tar.gz 1354262 BLAKE2B 1abdf4cb99ecdac6b9b8d2ebdd6897a3182a147f0175e2db4c6b0feaa3f6c615ee3146dd63627a83266c223456c5aba44b018be4059574d0209aec89065d9925 SHA512 ed52a31a71b3762b8cd217ea2784d9cb01f7c1a50cef3b7e0d99483ca3ab623b90ab7d4896674e0d1c06e2e8370c02162418d934de7d3048b0471416616146fe
diff --git a/app-crypt/certbot/certbot-1.2.0.ebuild b/app-crypt/certbot/certbot-1.2.0.ebuild
new file mode 100644
index 000000000000..ec673774775d
--- /dev/null
+++ b/app-crypt/certbot/certbot-1.2.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=(python{3_6,3_7})
+
+if [[ ${PV} == 9999* ]]; then
+ EGIT_REPO_URI="https://github.com/certbot/certbot.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+fi
+S=${WORKDIR}/${P}/${PN}
+
+inherit distutils-r1
+
+DESCRIPTION="Let's encrypt client to automate deployment of X.509 certificates"
+HOMEPAGE="https://github.com/certbot/certbot https://letsencrypt.org/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+CDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="
+ ${CDEPEND}
+ >=app-crypt/acme-0.40.0[${PYTHON_USEDEP}]
+ >=dev-python/configargparse-0.9.3[${PYTHON_USEDEP}]
+ dev-python/configobj[${PYTHON_USEDEP}]
+ >=dev-python/cryptography-2.8[${PYTHON_USEDEP}]
+ >=dev-python/distro-1.0.1[${PYTHON_USEDEP}]
+ >=dev-python/josepy-1.1.0[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ >=dev-python/parsedatetime-1.3[${PYTHON_USEDEP}]
+ dev-python/pyrfc3339[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/zope-component[${PYTHON_USEDEP}]
+ dev-python/zope-interface[${PYTHON_USEDEP}]"
+DEPEND="
+ ${CDEPEND}
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ # acme is not installed, removing it here is fine, the dir just confuses tests
+ rm -R ../acme
+ pytest -vv ${PN} || die
+}