summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2020-07-17 23:43:35 +0300
committerMart Raudsepp <leio@gentoo.org>2020-07-17 23:44:03 +0300
commitd556dbd3f16534a51dbe08cf8a3943eae8d26928 (patch)
treefa982ed79c5364f4494704862c6b4c12f85330fa /app-crypt
parentmedia-gfx/simple-scan: bump to 3.36.4 (diff)
downloadgentoo-d556dbd3f16534a51dbe08cf8a3943eae8d26928.tar.gz
gentoo-d556dbd3f16534a51dbe08cf8a3943eae8d26928.tar.bz2
gentoo-d556dbd3f16534a51dbe08cf8a3943eae8d26928.zip
app-crypt/seahorse: bump to 3.36.2
Closes: https://bugs.gentoo.org/730194 Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/seahorse/Manifest1
-rw-r--r--app-crypt/seahorse/seahorse-3.36.2.ebuild73
2 files changed, 74 insertions, 0 deletions
diff --git a/app-crypt/seahorse/Manifest b/app-crypt/seahorse/Manifest
index 87b110101466..fe49a00fe0d2 100644
--- a/app-crypt/seahorse/Manifest
+++ b/app-crypt/seahorse/Manifest
@@ -1 +1,2 @@
DIST seahorse-3.34.1.tar.xz 1271616 BLAKE2B 64956d0ee4f15bc048f42cefd827aad91927b34eecf4a2e53d988c379b3eae1ce0ae29ef469c2ff80ec9cceeaf77a271c57e28cb98dd24ae55c048faff487c1d SHA512 d2dff7d73a0968c1a5a8d39460f08b67f6794f22812200f564ef719354ab5cc2dac2213cba0d4bc10a455aecb9f55de8ff39943db4482beaac9cfdc2ca1012b8
+DIST seahorse-3.36.2.tar.xz 1695824 BLAKE2B e4efb20f952e879b0ff17a9c8664ba61d10c69e377a2fdda52904a8bf5c026d147f9feb9b55c07982f256b366f756dd1567a522d89969c8c5c461f653a130676 SHA512 6a0cb7847fe9917d6d6da31f9b81a4737e425d451fc80604d8e3deb9fa57798f04aa577dae68bc156a15743975f74fbde5ff06a0b05b34228bdc9ef2539b6451
diff --git a/app-crypt/seahorse/seahorse-3.36.2.ebuild b/app-crypt/seahorse/seahorse-3.36.2.ebuild
new file mode 100644
index 000000000000..e76835d6eeea
--- /dev/null
+++ b/app-crypt/seahorse/seahorse-3.36.2.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit gnome.org gnome2-utils meson xdg vala
+
+DESCRIPTION="Manage your passwords and encryption keys"
+HOMEPAGE="https://wiki.gnome.org/Apps/Seahorse"
+
+LICENSE="GPL-2+ FDL-1.1+"
+SLOT="0"
+IUSE="ldap zeroconf"
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-libs/glib-2.44:2
+ >=app-crypt/gcr-3.11.91:=
+ >=app-crypt/gpgme-1.7.0
+ >=x11-libs/gtk+-3.22.0:3
+ >=app-crypt/gnupg-2.0.12
+ >=gui-libs/libhandy-0.0.12:0.0=
+ >=app-crypt/libsecret-0.16
+ dev-libs/libpwquality
+ net-misc/openssh
+ ldap? ( net-nds/openldap:= )
+ >=net-libs/libsoup-2.33.92:2.4
+ zeroconf? ( >=net-dns/avahi-0.6:=[dbus] )
+"
+DEPEND="${RDEPEND}
+ $(vala_depend)
+ dev-libs/appstream-glib
+ dev-libs/libxml2:2
+ dev-libs/libxslt
+ app-text/docbook-xml-dtd:4.2
+ app-text/docbook-xsl-stylesheets
+ dev-util/gdbus-codegen
+ dev-util/glib-utils
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ app-crypt/gcr[vala]
+ app-crypt/libsecret[vala]
+"
+
+src_prepare() {
+ xdg_src_prepare
+ vala_src_prepare
+}
+
+src_configure() {
+ local emesonargs=(
+ -Dhelp=true
+ -Dpgp-support=true
+ -Dcheck-compatible-gpg=false # keep lowest version listed as compatible as min dep for gnupg RDEPEND
+ -Dpkcs11-support=true
+ -Dkeyservers-support=true
+ -Dhkp-support=true
+ $(meson_use ldap ldap-support)
+ $(meson_use zeroconf key-sharing)
+ -Dmanpage=true
+ )
+ meson_src_configure
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}