summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2016-02-24 00:06:31 +0100
committerManuel Rüger <mrueg@gentoo.org>2016-02-24 00:06:31 +0100
commitdd57c2b5821911b1491b7bcf880cb87d24a594ae (patch)
treefb647cfddee1ca0016198cfa7133729218c2f672 /app-crypt
parentx11-apps/xrandr: Remove old (diff)
downloadgentoo-dd57c2b5821911b1491b7bcf880cb87d24a594ae.tar.gz
gentoo-dd57c2b5821911b1491b7bcf880cb87d24a594ae.tar.bz2
gentoo-dd57c2b5821911b1491b7bcf880cb87d24a594ae.zip
app-crypt/easy-rsa: Add missed -r option on doins. Thanks to Matt Whitlock.
Gentoo-Bug: 575440 Package-Manager: portage-2.2.27
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/easy-rsa/easy-rsa-3.0.1-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/app-crypt/easy-rsa/easy-rsa-3.0.1-r1.ebuild b/app-crypt/easy-rsa/easy-rsa-3.0.1-r1.ebuild
new file mode 100644
index 000000000000..1ff21245107c
--- /dev/null
+++ b/app-crypt/easy-rsa/easy-rsa-3.0.1-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils
+
+MY_P="EasyRSA-${PV}"
+
+DESCRIPTION="Small RSA key management package, based on OpenSSL"
+HOMEPAGE="http://openvpn.net/"
+SRC_URI="https://github.com/OpenVPN/easy-rsa/releases/download/${PV}/${MY_P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="libressl"
+
+DEPEND="!libressl? ( >=dev-libs/openssl-0.9.6:0 )
+ libressl? ( dev-libs/libressl )"
+RDEPEND="${DEPEND}
+ !<net-misc/openvpn-2.3"
+
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ exeinto /usr/share/easy-rsa
+ doexe easyrsa
+ insinto /usr/share/easy-rsa
+ doins -r vars.example openssl-1.0.cnf x509-types
+ dodoc README.quickstart.md ChangeLog
+ dodoc -r doc
+ doenvd "${FILESDIR}/65easy-rsa" # config-protect easy-rsa
+}