summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSalah Coronya <salah.coronya@gmail.com>2020-05-31 15:48:19 -0500
committerConrad Kostecki <conikost@gentoo.org>2020-06-20 01:47:12 +0200
commitdf6979f97a2c9440834e02118716b0d1b523f808 (patch)
tree6e90ed521c2b71e963c635a306536257ed2ebf4d /app-crypt
parentdev-perl/Class-Std-Fast: -r bump for EAPI7 (diff)
downloadgentoo-df6979f97a2c9440834e02118716b0d1b523f808.tar.gz
gentoo-df6979f97a2c9440834e02118716b0d1b523f808.tar.bz2
gentoo-df6979f97a2c9440834e02118716b0d1b523f808.zip
app-crypt/tpm2-totp: Don't install static libs
Closes: https://bugs.gentoo.org/726494 Closes: https://github.com/gentoo/gentoo/pull/16037 Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Salah Coronya <salah.coronya@gmail.com> Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/tpm2-totp/tpm2-totp-0.2.1-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/app-crypt/tpm2-totp/tpm2-totp-0.2.1-r1.ebuild b/app-crypt/tpm2-totp/tpm2-totp-0.2.1-r1.ebuild
new file mode 100644
index 000000000000..bafbd71fdc7d
--- /dev/null
+++ b/app-crypt/tpm2-totp/tpm2-totp-0.2.1-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="Attest the trustworthiness of a device against a human using time-based OTP"
+HOMEPAGE="https://github.com/tpm2-software/tpm2-totp"
+SRC_URI="https://github.com/tpm2-software/${PN}/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND=">=app-crypt/tpm2-tss-2.0
+ media-gfx/qrencode:="
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-static
+ --disable-defaultflags
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}