summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2016-02-20 10:47:26 +0100
committerJeroen Roovers <jer@gentoo.org>2016-02-20 10:47:54 +0100
commit5ecd5a525cbb9a4b38cc4a4c9ef8694d3105145c (patch)
tree6a45f2591e181b677e622bece2d6f3a62fe33000 /app-dicts/dictd-vera
parentdev-ruby/sawyer: fix bug 575202 (diff)
downloadgentoo-5ecd5a525cbb9a4b38cc4a4c9ef8694d3105145c.tar.gz
gentoo-5ecd5a525cbb9a4b38cc4a4c9ef8694d3105145c.tar.bz2
gentoo-5ecd5a525cbb9a4b38cc4a4c9ef8694d3105145c.zip
app-dicts/dictd-vera: Version bump.
Package-Manager: portage-2.2.27
Diffstat (limited to 'app-dicts/dictd-vera')
-rw-r--r--app-dicts/dictd-vera/Manifest1
-rw-r--r--app-dicts/dictd-vera/dictd-vera-1.23.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/app-dicts/dictd-vera/Manifest b/app-dicts/dictd-vera/Manifest
index b32139dcd00f..7169119150be 100644
--- a/app-dicts/dictd-vera/Manifest
+++ b/app-dicts/dictd-vera/Manifest
@@ -1 +1,2 @@
DIST vera-1.22.tar.gz 229397 SHA256 271688e1b2305c27ecc276335bfb7370af316eee1da9c2865de74dca6734ddaa SHA512 3fe10ae52d8aa593bc4ce23eaffbf8d1cbc0127fcce3538508389335a9e1bc2964d1ca8915616b0711cc9da36f8ea231e050dbeddf75bef799f21e538731234a WHIRLPOOL c162090c27efb9d80b0209d09285090ca7046a7c280c56688ca9049d5e5f854bd68a84be7133845bfb2a16ca9831ff6c082676fc0854aac0f106437a35d067fd
+DIST vera-1.23.tar.gz 236439 SHA256 ffd7f0283b7b9ca5ef69723a8f99faa9c9b33dca5e9a84c8ea4849394cd9e0ab SHA512 f16f2d24715131f60238c49f43d79bcd02b47c8e999de381c2139289f05859659a9f3ae79e3ed8d4b3dae447666cb8391ad7a072dff91275857b901fd0748c78 WHIRLPOOL 2d7e2fe1577bf4b6b430cb6c3d24e5a2055a213c607af36535e5f331a52cf29ad527727d11a9e612c6f9baa1a4bd713ef59f81b398aefcd4e94b7d2a1e157c9c
diff --git a/app-dicts/dictd-vera/dictd-vera-1.23.ebuild b/app-dicts/dictd-vera/dictd-vera-1.23.ebuild
new file mode 100644
index 000000000000..849fff47d050
--- /dev/null
+++ b/app-dicts/dictd-vera/dictd-vera-1.23.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="V.E.R.A. -- Virtual Entity of Relevant Acronyms for dict"
+HOMEPAGE="http://home.snafu.de/ohei/vera/vueber-e.html"
+SRC_URI="mirror://gnu/vera/vera-${PV}.tar.gz"
+
+SLOT="0"
+LICENSE="FDL-1.3"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+
+DEPEND=">=app-text/dictd-1.5.5"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/vera-${PV}
+
+src_compile () {
+# sed -f debian/dict-vera/sedfile vera.? >vera1 || die
+# sed '1,2!s/^/ /' vera. > vera || die
+# cat vera1>>vera || die
+ cat vera.[0-9a-z] | /usr/bin/dictfmt -f -u http://home.snafu.de/ohei \
+ -s "V.E.R.A. -- Virtual Entity of Relevant Acronyms" \
+ vera || die
+ /usr/bin/dictzip -v vera.dict || die
+}
+
+src_install () {
+ dodir /usr/lib/dict
+ insinto /usr/lib/dict
+ doins vera.dict.dz
+ doins vera.index
+ dodoc changelog README
+}