summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGino <onigino@protonmail.com>2019-01-06 14:25:59 -0800
committerPatrice Clement <monsieurp@gentoo.org>2019-01-16 00:42:51 +0100
commit8cdefb2442584d64ed5513c84bb88e4472ee9c15 (patch)
treec70761b3648c0792cf455f21cd45d802c9b397fa /app-dicts/myspell-en
parentmedia-plugins/gst-plugins-libav: remove old (diff)
downloadgentoo-8cdefb2442584d64ed5513c84bb88e4472ee9c15.tar.gz
gentoo-8cdefb2442584d64ed5513c84bb88e4472ee9c15.tar.bz2
gentoo-8cdefb2442584d64ed5513c84bb88e4472ee9c15.zip
app-dict/myspell-en-20190101: version bump.
Signed-off-by: Gino <onigino@protonmail.com> Closes: https://github.com/gentoo/gentoo/pull/10760 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'app-dicts/myspell-en')
-rw-r--r--app-dicts/myspell-en/Manifest1
-rw-r--r--app-dicts/myspell-en/myspell-en-20190101.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/app-dicts/myspell-en/Manifest b/app-dicts/myspell-en/Manifest
index cf0fe159b8fd..e36ade664428 100644
--- a/app-dicts/myspell-en/Manifest
+++ b/app-dicts/myspell-en/Manifest
@@ -1,2 +1,3 @@
DIST dict-en-20170101.oxt 5960816 BLAKE2B 65505ed6e8323f28377728ac29e550cf151688517b83209b055966be4e7e14465aacc1d1677d22bc005089d7623e78e63bf91dcdffcde3a790532dba87b54615 SHA512 fae05d3e4bdc9bbd5dda6eb2c0de2f5d0860973e75fe0931bcb0d0e0a5015fb6042beec7f811bee0011f519d13d0f3b52b09fbd906a75340bf311177885ccc1d
DIST dict-en-20181101.oxt 6052772 BLAKE2B 46825cb406406a3d64e8495f047ae81d6b693e6ff5cd89152a9c829a80d7be1920dfb3572a84aedb2e8f8e5c767aa49ed7e71ab330aca83b3936133699f1098a SHA512 1f351b97c4fc907c5751a35b6665b6d91b1157b6a952a378f565989249b1900395f08f0204407a21b0bcb999fe695c14707c4744f5da32d521ee8d75f73c89f9
+DIST dict-en-20190101.oxt 6058651 BLAKE2B 617ded8d7df6e62767083be7b0651e1bd1e039f78ebb67e8371228805519195dd5acd4ca7d415a29b68697a369d070eafa5545d1b8bbcbab58774db61f03e8e5 SHA512 06e6a21b524c378041655cc44e04f26a35b16e1606a478c0702b96fcbeb86180593fc02d00cae8e05700ead0bd6568239434e8d3d733937587e7b009245dfe4c
diff --git a/app-dicts/myspell-en/myspell-en-20190101.ebuild b/app-dicts/myspell-en/myspell-en-20190101.ebuild
new file mode 100644
index 000000000000..932b93b49c69
--- /dev/null
+++ b/app-dicts/myspell-en/myspell-en-20190101.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+MY_PV="${PV:0:4}-${PV:4:2}.${PV:6:2}"
+
+inherit myspell-r2
+
+DESCRIPTION="English dictionaries for myspell/hunspell"
+HOMEPAGE="https://extensions.libreoffice.org/extensions/english-dictionaries"
+SRC_URI="https://extensions.libreoffice.org/extensions/english-dictionaries/${MY_PV}/@@download/file/dict-en-${PV}.oxt"
+
+LICENSE="BSD MIT LGPL-3+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE=""
+
+PLOCALES=( "en" "en-AU" "en-CA" "en-GB" "en-US" "en-ZA" )
+IUSE+="${PLOCALES[@]/#/l10n_}"
+REQUIRED_USE="|| ( ${IUSE[@]} )"
+
+src_prepare() {
+ if use l10n_en-GB || use l10n_en; then
+ MYSPELL_HYPH=( "hyph_en_GB.dic" )
+ fi
+ if use l10n_en-US || use l10n_en; then
+ MYSPELL_THES=(
+ "th_en_US_v2.dat"
+ "th_en_US_v2.idx"
+ )
+ fi
+
+ MYSPELL_DICT=( )
+ for lang in "${PLOCALES[@]}"; do
+ if [[ "${lang}" == "en" ]]; then
+ continue
+ fi
+ local mylinguas="${lang//-/_}"
+ if use "l10n_${lang}" || use l10n_en; then
+ MYSPELL_DICT+=( "${mylinguas}.aff" "${mylinguas}.dic" )
+ else
+ rm "README_${mylinguas}.txt" || die
+ if [[ ${lang} == "en-US" ]]; then
+ rm "README_hyph_en_US.txt" || die
+ fi
+ if [[ ${lang} == "en-GB" ]]; then
+ rm "README_hyph_en_GB.txt" || die
+ rm "README_en_GB_thes.txt" || die
+ fi
+ fi
+ done
+
+ default
+}