summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBoris Carvajal <boris2.9@gmail.com>2018-05-01 02:13:35 -0300
committerMichał Górny <mgorny@gentoo.org>2018-05-09 19:43:58 +0200
commita27503b595963817ffe2a07d37340ca7a1c234b9 (patch)
tree9cf07c8b0dc64b40e4e08a93eace6bb11a226004 /app-dicts/myspell-es/myspell-es-2.3.ebuild
parentwww-client/chromium: widevine rehabilitation (diff)
downloadgentoo-a27503b595963817ffe2a07d37340ca7a1c234b9.tar.gz
gentoo-a27503b595963817ffe2a07d37340ca7a1c234b9.tar.bz2
gentoo-a27503b595963817ffe2a07d37340ca7a1c234b9.zip
app-dicts/myspell-es: version bump to 2.3, update HOMEPAGE/SRC_URI
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'app-dicts/myspell-es/myspell-es-2.3.ebuild')
-rw-r--r--app-dicts/myspell-es/myspell-es-2.3.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/app-dicts/myspell-es/myspell-es-2.3.ebuild b/app-dicts/myspell-es/myspell-es-2.3.ebuild
new file mode 100644
index 000000000000..93987efe68b5
--- /dev/null
+++ b/app-dicts/myspell-es/myspell-es-2.3.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MUTATIONS=(
+ "es_ANY" "es_AR" "es_BO" "es_CL" "es_CO" "es_CR" "es_CU" "es_DO" "es_EC"
+ "es_ES" "es_GT" "es_HN" "es_MX" "es_NI" "es_PA" "es_PE" "es_PH" "es_PR"
+ "es_PY" "es_SV" "es_US" "es_UY" "es_VE"
+)
+
+MYSPELL_DICT=( )
+MYSPELL_HYPH=(
+ "hyph_es_ANY.dic"
+)
+MYSPELL_THES=(
+ "th_es_ES_v2.dat"
+ "th_es_ES_v2.idx"
+)
+
+SRC_URI=""
+for i in "${MUTATIONS[@]}"; do
+ MYSPELL_DICT+=(
+ "${i}.dic"
+ "${i}.aff"
+ )
+ SRC_URI+=" https://github.com/sbosio/rla-es/releases/download/v${PV}/${i}.oxt -> ${i}-${PV}.oxt"
+done
+unset i MUTATIONS
+
+inherit myspell-r2
+
+DESCRIPTION="Spanish dictionaries for myspell/hunspell"
+HOMEPAGE="https://github.com/sbosio/rla-es"
+LICENSE="GPL-3 LGPL-3 MPL-1.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE=""
+
+src_prepare() {
+ # remove license files
+ rm {GPL,LGPL,MPL}* || die
+ default
+}