summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoonas Niilola <juippis@gentoo.org>2021-06-03 17:34:12 +0300
committerJoonas Niilola <juippis@gentoo.org>2021-06-03 17:35:47 +0300
commit63d030ebb23d1fbea239af1637799a3dcd0d2abb (patch)
tree0533f6bb516033928158220af0c3bd6bbf2ecbcc /app-dicts/myspell-ru/myspell-ru-20180627.ebuild
parentRevert "app-dicts/myspell-he: bump to EAPI 7" (diff)
downloadgentoo-63d030ebb23d1fbea239af1637799a3dcd0d2abb.tar.gz
gentoo-63d030ebb23d1fbea239af1637799a3dcd0d2abb.tar.bz2
gentoo-63d030ebb23d1fbea239af1637799a3dcd0d2abb.zip
Revert "app-dicts/myspell-ru: drop older unstable version"
This reverts commit c21cd6886a7194c99e21677a4bc1ccc2cc14ddad. - under stabilization currently. Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-dicts/myspell-ru/myspell-ru-20180627.ebuild')
-rw-r--r--app-dicts/myspell-ru/myspell-ru-20180627.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/app-dicts/myspell-ru/myspell-ru-20180627.ebuild b/app-dicts/myspell-ru/myspell-ru-20180627.ebuild
new file mode 100644
index 000000000000..c5b3a4ca275b
--- /dev/null
+++ b/app-dicts/myspell-ru/myspell-ru-20180627.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MYSPELL_DICT=( ru_RU.{dic,aff} )
+MYSPELL_HYPH=( hyph_ru_RU.dic )
+MYSPELL_THES=( ru_th_aot.{dat,idx} )
+
+inherit myspell-r2
+
+EXT="extensions"
+DICT="russian-dictionary-pack"
+MY_PN="dict_pack_ru-aot"
+MY_PV="0.4.3"
+
+DESCRIPTION="Russian spellcheck dictionary based on works of AOT group for myspell/hunspell"
+HOMEPAGE="https://extensions.libreoffice.org/extensions/russian-dictionary-pack"
+SRC_URI="https://extensions.libreoffice.org/${EXT}/${DICT}/0-4.3/@@download/file/${MY_PN}-${MY_PV//./-}.oxt"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux"
+
+src_prepare() {
+ default
+ mv russian-aot.dic ru_RU.dic || die
+ mv russian-aot.aff ru_RU.aff || die
+}