summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2016-05-10 14:17:52 +0800
committerIan Delaney <idella4@gentoo.org>2016-05-10 14:19:01 +0800
commita8e973340c4fe1469790b7bdd156cff893872290 (patch)
treeb93464f226cf15d98257f5966d4bf858cec001c3 /app-dicts/myspell-ru
parentapp-i18n/sunpinyin: fix pod2man and install directory. (diff)
downloadgentoo-a8e973340c4fe1469790b7bdd156cff893872290.tar.gz
gentoo-a8e973340c4fe1469790b7bdd156cff893872290.tar.bz2
gentoo-a8e973340c4fe1469790b7bdd156cff893872290.zip
app-dicts/myspell-ru: rebump -> myspell-ru-20150711-r1.ebuild
upgrade src_install, add symlinks to the dictionary files patch supplied by proxied maintianer via the gentoo bug Gentoo-bug: #579054 Package-Manager: portage-2.2.28
Diffstat (limited to 'app-dicts/myspell-ru')
-rw-r--r--app-dicts/myspell-ru/myspell-ru-20150711-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-dicts/myspell-ru/myspell-ru-20150711-r1.ebuild b/app-dicts/myspell-ru/myspell-ru-20150711-r1.ebuild
new file mode 100644
index 000000000000..a72273eb97cc
--- /dev/null
+++ b/app-dicts/myspell-ru/myspell-ru-20150711-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MYSPELL_DICT=( russian-aot.{dic,aff} )
+
+MYSPELL_HYPH=( hyph_ru_RU.dic )
+
+MYSPELL_THES=( ru_th_aot.{dat,idx} )
+
+inherit myspell-r2
+
+EXT="extension-center"
+DICT="russian-dictionary-pack"
+MY_PN="dict_pack_ru-aot"
+MY_PV="0.4.0"
+
+DESCRIPTION="Russian spellcheck dictionary based on works of AOT group for myspell/hunspell"
+HOMEPAGE="http://extensions.libreoffice.org/extension-center/russian-dictionary-pack"
+SRC_URI="http://extensions.libreoffice.org/${EXT}/${DICT}/releases/${MY_PV}/${MY_PN}-0-4-0.oxt"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~amd64-linux ~x86-fbsd"
+
+src_install() {
+ myspell-r2_src_install
+ dosym /usr/share/hunspell/russian-aot.dic /usr/share/myspell/ru_RU.dic
+ dosym /usr/share/hunspell/russian-aot.aff /usr/share/myspell/ru_RU.aff
+}