summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-dicts/ydpdict
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-dicts/ydpdict')
-rw-r--r--app-dicts/ydpdict/Manifest1
-rw-r--r--app-dicts/ydpdict/metadata.xml8
-rw-r--r--app-dicts/ydpdict/ydpdict-1.0.2.ebuild43
3 files changed, 52 insertions, 0 deletions
diff --git a/app-dicts/ydpdict/Manifest b/app-dicts/ydpdict/Manifest
new file mode 100644
index 000000000000..8b1ebe0955fb
--- /dev/null
+++ b/app-dicts/ydpdict/Manifest
@@ -0,0 +1 @@
+DIST ydpdict-1.0.2.tar.gz 363774 SHA256 cbdcf1bba29a1eaf8c9fc782a1c15b80596e9debe7a56f169e1724960a415822 SHA512 b2395d88e289171daae3aa47d9c70a2ca1c7b3a3998c1a9751c56e1dc8d17138bc38a172581edcad02c35d5252041c6942a3c416a632def6121072650bcb7e61 WHIRLPOOL 0d8007b80501a2709fe7bc9343d7f494716dbcb53a28c4a12bbbd1b1bc3896bc16584d7265eef752dc00de00c8d88ee7c6322a4737030d782ee6d411564f606c
diff --git a/app-dicts/ydpdict/metadata.xml b/app-dicts/ydpdict/metadata.xml
new file mode 100644
index 000000000000..e96e35b1a37c
--- /dev/null
+++ b/app-dicts/ydpdict/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>
+
diff --git a/app-dicts/ydpdict/ydpdict-1.0.2.ebuild b/app-dicts/ydpdict/ydpdict-1.0.2.ebuild
new file mode 100644
index 000000000000..2558a0438edd
--- /dev/null
+++ b/app-dicts/ydpdict/ydpdict-1.0.2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="Interface for the Collins Dictionary"
+HOMEPAGE="http://toxygen.net/ydpdict/"
+SRC_URI="http://toxygen.net/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="ao"
+
+RDEPEND=">=app-dicts/libydpdict-${PV}
+ sys-libs/ncurses[unicode]
+ ao? ( media-libs/libao )"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_configure() {
+ econf \
+ $(use_with ao libao)
+}
+
+src_install() {
+ dodir "/etc"
+ emake DESTDIR="${D}" install
+ dodoc README
+}
+
+pkg_postinst() {
+ echo
+ elog "Note that to use this program you'll need the original Collins Dictionary"
+ elog "datafiles (dict100.*, dict101.*). These can be found in the Dabasase/"
+ elog "directory of the Windows version of the Collins dictionary. Once you obtain"
+ elog "the files, put them into /usr/share/ydpdict"
+ elog
+ elog "Some configuration options can be set in /etc/ydpdict.conf"
+ echo
+}