summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Kurakin <kuraga333@mail.ru>2023-08-12 14:45:30 +0300
committerViorel Munteanu <ceamac@gentoo.org>2023-08-18 11:44:15 +0300
commit341995f3cdbd5d18c31d146416f372f5bf9d15d7 (patch)
tree5af329bf7a27ee4b2fb1f589ee976e3686fb3fca /app-dicts
parentprofiles: license_groups: fix CMake removal (diff)
downloadgentoo-341995f3cdbd5d18c31d146416f372f5bf9d15d7.tar.gz
gentoo-341995f3cdbd5d18c31d146416f372f5bf9d15d7.tar.bz2
gentoo-341995f3cdbd5d18c31d146416f372f5bf9d15d7.zip
app-dicts/myspell-en: add 20230801
Closes: https://bugs.gentoo.org/912180 Signed-off-by: Alexander Kurakin <kuraga333@mail.ru> Closes: https://github.com/gentoo/gentoo/pull/32270 Signed-off-by: Viorel Munteanu <ceamac@gentoo.org>
Diffstat (limited to 'app-dicts')
-rw-r--r--app-dicts/myspell-en/Manifest1
-rw-r--r--app-dicts/myspell-en/myspell-en-20230801.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/app-dicts/myspell-en/Manifest b/app-dicts/myspell-en/Manifest
index 60fe6ec31437..47cdf63e1b0e 100644
--- a/app-dicts/myspell-en/Manifest
+++ b/app-dicts/myspell-en/Manifest
@@ -2,3 +2,4 @@ DIST dict-en-20230401_lo.oxt 6100359 BLAKE2B 4a1b8bfa8e7987d0ba957d483ec55d3e1d7
DIST dict-en-20230501_lo.oxt 6101115 BLAKE2B f0acdeccf1c4b58b7becabfd61167eb3f4767c5ae3da7ad752645cce49f3f3262219cfb08d373d02b49b67ddaff184102683c2981f4c28eb6b97d92961b07219 SHA512 bc8172f61cf3d18c0ac519f800b39ed69736e085d51251c60c527677552eefd4fe08e5b5e9fdba3a5856605ea44d3831901b00745f00f16146136d6e8376e4ee
DIST dict-en-20230601_lo.oxt 6101573 BLAKE2B 22949c952b1545016b298056a46e08f09f5e2865fd7b626df125c055553e72f1ba27d6adcbb22cb9340803989ced44158d4e8ceb2344820b3cd8058864568e66 SHA512 d8f2ad124cea03888856e6b845d94f5df5002852025b28a7217a4d5809069b0c59bb3432766be4b82641e55f17cf76addb5def4669bc41eac4a22ad209453e71
DIST dict-en-20230701_lo.oxt 6102145 BLAKE2B ecf95d76415317fb3dbe4c8e2d30fa37f9d798ae979d83d7e3eaab566264a7db12ed3133e8ed5d1580225171143056edd5189b1685064dab201fadbf59466b7e SHA512 3e495fb7c130d2767d88c4ff21f556c4c64f3739d7b1974355f252329fa526b8ac647a6121f1341396ec9170dda96346463a51b2df06d15e1dcccec4f800593e
+DIST dict-en-20230801_lo.oxt 6101620 BLAKE2B 1f7d1f223e40179ffd844fef48f3994e5be6d4015098b6cd639f8a9dcfb21a43c1da72683b973bb7f1eb4b1bdf1e68392d672dcd82e6a360b1cec3dcb5fecaaa SHA512 9716c6579d8c1121e24896d69d82ececd794f3c9161b82a7fa6405e8f4d5259bbd67ec6f026d95ee5927638b34876f63708e9315a2dbed0089ffb9310c7defd0
diff --git a/app-dicts/myspell-en/myspell-en-20230801.ebuild b/app-dicts/myspell-en/myspell-en-20230801.ebuild
new file mode 100644
index 000000000000..0d2c4d1ef04d
--- /dev/null
+++ b/app-dicts/myspell-en/myspell-en-20230801.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit myspell-r2
+
+DESCRIPTION="English dictionaries for myspell/hunspell"
+HOMEPAGE="
+ https://extensions.libreoffice.org/extensions/english-dictionaries
+ https://proofingtoolgui.org
+ https://github.com/marcoagpinto/aoo-mozilla-en-dict
+"
+SRC_URI="https://extensions.libreoffice.org/assets/downloads/41/1690875969/dict-en-20230801_lo.oxt"
+
+LICENSE="BSD MIT LGPL-3+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+
+PLOCALES=( "en-AU" "en-CA" "en-GB" "en-US" "en-ZA" )
+IUSE+="+l10n_en ${PLOCALES[@]/#/l10n_}"
+REQUIRED_USE="|| ( l10n_en ${PLOCALES[@]/#/l10n_} )"
+
+src_prepare() {
+ if use l10n_en-GB || use l10n_en; then
+ MYSPELL_HYPH+=( "hyph_en_GB.dic" )
+ fi
+ if use l10n_en-US || use l10n_en; then
+ MYSPELL_THES+=(
+ "th_en_US_v2.dat"
+ "th_en_US_v2.idx"
+ )
+ MYSPELL_HYPH+=( "hyph_en_US.dic" )
+ fi
+
+ MYSPELL_DICT=( )
+ for lang in "${PLOCALES[@]}"; do
+ if [[ "${lang}" == "en" ]]; then
+ continue
+ fi
+ local mylinguas="${lang//-/_}"
+ if use "l10n_${lang}" || use l10n_en; then
+ MYSPELL_DICT+=( "${mylinguas}.aff" "${mylinguas}.dic" )
+ else
+ rm "README_${mylinguas}.txt" || die
+ if [[ ${lang} == "en-US" ]]; then
+ rm "README_hyph_en_US.txt" || die
+ fi
+ if [[ ${lang} == "en-GB" ]]; then
+ rm "README_hyph_en_GB.txt" || die
+ rm "README_en_GB_thes.txt" || die
+ fi
+ fi
+ done
+
+ default
+}