summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2020-09-16 13:40:36 +0200
committerDavid Seifert <soap@gentoo.org>2020-09-16 13:40:36 +0200
commit63c56614e14aa344ef0423afa7d7423eee29b87e (patch)
tree14631dd0e38d5683f5e485e95bdabb2e76172ed7 /app-dicts
parentapp-i18n/xcin: Port to EAPI 7 (diff)
downloadgentoo-63c56614e14aa344ef0423afa7d7423eee29b87e.tar.gz
gentoo-63c56614e14aa344ef0423afa7d7423eee29b87e.tar.bz2
gentoo-63c56614e14aa344ef0423afa7d7423eee29b87e.zip
app-dicts/ipadic: Port to EAPI 7
Closes: https://bugs.gentoo.org/742053 Package-Manager: Portage-3.0.7, Repoman-3.0.1 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'app-dicts')
-rw-r--r--app-dicts/ipadic/ipadic-2.7.0-r2.ebuild17
1 files changed, 9 insertions, 8 deletions
diff --git a/app-dicts/ipadic/ipadic-2.7.0-r2.ebuild b/app-dicts/ipadic/ipadic-2.7.0-r2.ebuild
index fba0b8b37b2d..54a6d1d4850d 100644
--- a/app-dicts/ipadic/ipadic-2.7.0-r2.ebuild
+++ b/app-dicts/ipadic/ipadic-2.7.0-r2.ebuild
@@ -1,23 +1,25 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="4"
-inherit autotools eutils
+EAPI=7
+
+inherit autotools
DESCRIPTION="Japanese dictionary for ChaSen"
HOMEPAGE="http://sourceforge.jp/projects/ipadic/"
SRC_URI="mirror://sourceforge.jp/${PN}/24435/${P}.tar.gz"
LICENSE="ipadic"
-KEYWORDS="amd64 ppc ~ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos"
SLOT="0"
-IUSE=""
+KEYWORDS="amd64 ppc ~ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos"
-DEPEND=">=app-text/chasen-2.3.1"
-RDEPEND=""
+BDEPEND=">=app-text/chasen-2.3.1"
+
+PATCHES=( "${FILESDIR}"/${PF}-gentoo.patch )
src_prepare() {
- epatch "${FILESDIR}/${PF}-gentoo.patch"
+ default
+ mv configure.{in,ac} || die
eautoreconf
}
@@ -26,5 +28,4 @@ src_install() {
insinto /etc
doins chasenrc
- dodoc AUTHORS ChangeLog NEWS README
}