summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarco Scardovi <marco@scardovi.com>2021-05-02 23:34:31 +0200
committerJoonas Niilola <juippis@gentoo.org>2021-06-03 17:20:36 +0300
commit7794ad2aeb61291c4b1561f5b9b064c3244009f6 (patch)
tree58c7496c65f2eec1e93688206bc8640b4b5453af /app-dicts
parentapp-dicts/myspell-ga: fixed date release (diff)
downloadgentoo-7794ad2aeb61291c4b1561f5b9b064c3244009f6.tar.gz
gentoo-7794ad2aeb61291c4b1561f5b9b064c3244009f6.tar.bz2
gentoo-7794ad2aeb61291c4b1561f5b9b064c3244009f6.zip
app-dicts/myspell-gl: bump to EAPI 7 + verbump to 20180710
+ move to libreoffice server Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Marco Scardovi <marco@scardovi.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-dicts')
-rw-r--r--app-dicts/myspell-gl/Manifest1
-rw-r--r--app-dicts/myspell-gl/myspell-gl-20180710.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/app-dicts/myspell-gl/Manifest b/app-dicts/myspell-gl/Manifest
index 44c6c05076b5..f2dfc86d4e75 100644
--- a/app-dicts/myspell-gl/Manifest
+++ b/app-dicts/myspell-gl/Manifest
@@ -1 +1,2 @@
DIST myspell-gl-20131013.oxt 771221 BLAKE2B cee0815ae69d00334cca4341ed5c694c3d8f97a3904f5427b7deb94d706947e536adc890b2bfbff41c666b8ae6c5c277edc4843f4c4ef4131548145a42b2313d SHA512 ae13d7137e6b8e51570bcbeba00f73d9887a24556c2409249a39858d385168a03aff3ec2cf3222cad50686a4169debbe310a05ce3bd40aaab408de3ed01885ee
+DIST myspell-gl-20180710.oxt 1929371 BLAKE2B f5ffbcd9417935828db5e951b1b37deb6a72c22f19afd48cc9e03f167bbc3285b3ae3141c2393aeff50be48752cd8620167e2539f6d2eb28f29c72ca56f88c84 SHA512 ea19a917a3f4a7d6a144a9219e30f1a8cdd4865c98c1a3f901dd2ffb8a20143c2e80c4b458ea71ce97684042a4209852c9d21861710c52658fa7391eb221c7a4
diff --git a/app-dicts/myspell-gl/myspell-gl-20180710.ebuild b/app-dicts/myspell-gl/myspell-gl-20180710.ebuild
new file mode 100644
index 000000000000..1d5e545c3378
--- /dev/null
+++ b/app-dicts/myspell-gl/myspell-gl-20180710.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MYSPELL_DICT=(
+ "gl_ES.aff"
+ "gl_ES.dic"
+)
+
+MYSPELL_HYPH=(
+ "hyph_gl_ES.dic"
+)
+
+MYSPELL_THES=(
+ "thes_gl_ES.dat"
+ "thes_gl_ES.idx"
+)
+
+inherit myspell-r2
+
+DESCRIPTION="Galician dictionaries for myspell/hunspell"
+LICENSE="GPL-2 LGPL-2.1"
+HOMEPAGE="https://extensions.libreoffice.org/en/extensions/show/corrector-ortografico-para-galego"
+SRC_URI="https://extensions.libreoffice.org/assets/downloads/z/corrector-18-07-para-galego.oxt -> ${P}.oxt"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+DOCS=( changelog.txt package-description.txt readme.txt readme-gl.txt readme_hyph-gl.txt readme_th_gl.txt )
+
+src_prepare() {
+ default
+ # Naming correctly
+ mv gl.aff gl_ES.aff || die
+ mv gl.dic gl_ES.dic || die
+ mv hyph_gl.dic hyph_gl_ES.dic || die
+ mv thesaurus_gl.dat thes_gl_ES.dat || die
+ mv thesaurus_gl.idx thes_gl_ES.idx || die
+}