summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2015-12-27 18:10:10 +0100
committerGilles Dartiguelongue <eva@gentoo.org>2015-12-27 18:14:25 +0100
commita8bcb20d3246eda710c11a1c8371641799370693 (patch)
tree47dd48a6f13b77fda4d09f8980845ccbabdc8a99 /app-dicts
parentmedia-radio/grig: Version bump. Fixes bug #561544. Thanks Toralf (diff)
downloadgentoo-a8bcb20d3246eda710c11a1c8371641799370693.tar.gz
gentoo-a8bcb20d3246eda710c11a1c8371641799370693.tar.bz2
gentoo-a8bcb20d3246eda710c11a1c8371641799370693.zip
app-dicts/verbiste: version bump to 0.1.41
Package-Manager: portage-2.2.26
Diffstat (limited to 'app-dicts')
-rw-r--r--app-dicts/verbiste/Manifest1
-rw-r--r--app-dicts/verbiste/verbiste-0.1.41.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/app-dicts/verbiste/Manifest b/app-dicts/verbiste/Manifest
index a2cf3d63bb64..2895fdf89893 100644
--- a/app-dicts/verbiste/Manifest
+++ b/app-dicts/verbiste/Manifest
@@ -1 +1,2 @@
DIST verbiste-0.1.38.tar.gz 706222 SHA256 7be13f0cc5c415ea5382ed2ee4391c21c700910eef2771086a28e44ff32817ff SHA512 b5d99d08a9d1a7c91c1dbb86e0d4465a46403db881cd28d2abaf8d376adef6b4d4f5ac93e528d45beb639b77aff7e1730dbb436624674ff21c1f5781173db787 WHIRLPOOL 9e7558e36c33eb7cd89f0cb888c01fb6040292ff7cdaeecd6f9ee51c7354939d5b9d23f769c67462be613abf0e275ab5580539a10fb5d0d8e8eca3489f16b027
+DIST verbiste-0.1.41.tar.gz 751059 SHA256 b4490d99dc768c8947536c01a5fbbecf71d067f472c0bd4d79b828df45d79f9f SHA512 f89bb1074cd8c65f8516004c89aae50c65b5bd426d78a01b5e6b7418d86b5c348d2c554ab202c9f34cc9c5586a54518160fc225afa237cdb140ff99f78563702 WHIRLPOOL 8a3d6a29f0bf428f2ec5f9852bf4381abb02eb4aac16153cd95fda367e1227cca3035a00de02f3d00757b254fba9dcc2d19a0f91454f82097ce4026d84ab83aa
diff --git a/app-dicts/verbiste/verbiste-0.1.41.ebuild b/app-dicts/verbiste/verbiste-0.1.41.ebuild
new file mode 100644
index 000000000000..4155f6484872
--- /dev/null
+++ b/app-dicts/verbiste/verbiste-0.1.41.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit eutils gnome2-utils xdg-utils
+
+DESCRIPTION="French conjugation system"
+HOMEPAGE="http://sarrazip.com/dev/verbiste.html"
+SRC_URI="http://sarrazip.com/dev/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+IUSE="gtk"
+
+RDEPEND="
+ >=dev-libs/libxml2-2.4.0:2
+ gtk? ( >=x11-libs/gtk+-2.6:2 )
+"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_configure() {
+ econf \
+ --with-console-app \
+ --without-gnome-app \
+ --without-gnome-applet \
+ $(use_with gtk gtk-app)
+}
+
+src_install() {
+ default
+ prune_libtool_files
+ dodoc HACKING LISEZMOI
+ # file is only installed with USE=gnome
+ if use gtk; then
+ sed -e 's/Exec=.*/Exec=verbiste-gtk/' \
+ -i src/gnome/verbiste.desktop || die
+ insinto usr/share/applications
+ doins src/gnome/verbiste.desktop
+ fi
+}
+
+pkg_preinst() {
+ if use gtk; then
+ gnome2_icon_savelist
+ fi
+}
+
+pkg_postinst() {
+ if use gtk; then
+ xdg_desktop_database_update
+ gnome2_icon_cache_update
+ fi
+}
+
+pkg_postrm() {
+ if use gtk; then
+ xdg_desktop_database_update
+ gnome2_icon_cache_update
+ fi
+}