summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarco Scardovi <marco@scardovi.com>2021-05-02 22:38:20 +0200
committerJoonas Niilola <juippis@gentoo.org>2021-06-03 17:20:35 +0300
commitf8d3e086c6ec65bd3ada79097509ead340a9fffe (patch)
treebb77b834065ac1e1097269029b3a9699ed29e3b5 /app-dicts
parentapp-dicts/myspell-el: bump to EAPI 7 (diff)
downloadgentoo-f8d3e086c6ec65bd3ada79097509ead340a9fffe.tar.gz
gentoo-f8d3e086c6ec65bd3ada79097509ead340a9fffe.tar.bz2
gentoo-f8d3e086c6ec65bd3ada79097509ead340a9fffe.zip
app-dicts/myspell-en: verbump to 20210401
Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Marco Scardovi <marco@scardovi.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-dicts')
-rw-r--r--app-dicts/myspell-en/Manifest1
-rw-r--r--app-dicts/myspell-en/myspell-en-20210601.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/app-dicts/myspell-en/Manifest b/app-dicts/myspell-en/Manifest
index e36ade664428..4d68180e559e 100644
--- a/app-dicts/myspell-en/Manifest
+++ b/app-dicts/myspell-en/Manifest
@@ -1,3 +1,4 @@
DIST dict-en-20170101.oxt 5960816 BLAKE2B 65505ed6e8323f28377728ac29e550cf151688517b83209b055966be4e7e14465aacc1d1677d22bc005089d7623e78e63bf91dcdffcde3a790532dba87b54615 SHA512 fae05d3e4bdc9bbd5dda6eb2c0de2f5d0860973e75fe0931bcb0d0e0a5015fb6042beec7f811bee0011f519d13d0f3b52b09fbd906a75340bf311177885ccc1d
DIST dict-en-20181101.oxt 6052772 BLAKE2B 46825cb406406a3d64e8495f047ae81d6b693e6ff5cd89152a9c829a80d7be1920dfb3572a84aedb2e8f8e5c767aa49ed7e71ab330aca83b3936133699f1098a SHA512 1f351b97c4fc907c5751a35b6665b6d91b1157b6a952a378f565989249b1900395f08f0204407a21b0bcb999fe695c14707c4744f5da32d521ee8d75f73c89f9
DIST dict-en-20190101.oxt 6058651 BLAKE2B 617ded8d7df6e62767083be7b0651e1bd1e039f78ebb67e8371228805519195dd5acd4ca7d415a29b68697a369d070eafa5545d1b8bbcbab58774db61f03e8e5 SHA512 06e6a21b524c378041655cc44e04f26a35b16e1606a478c0702b96fcbeb86180593fc02d00cae8e05700ead0bd6568239434e8d3d733937587e7b009245dfe4c
+DIST dict-en-20210601.oxt 6104083 BLAKE2B 192252e85918d3d47167ff9243f70178bc548de3e93152c4139e64ffb013e147fda1fa9c7741ce7bf74b149ec0ab6e001760990cd1ee33dad06fd5e3813ef591 SHA512 c9d791a12aa97d6c2a0928f9f500b22492208b415f877d6b5bd192b5da4c243c32b8d0b7af6b3f5cbfefe6b1c695626db204fc29a922dc4b083538ed144cb472
diff --git a/app-dicts/myspell-en/myspell-en-20210601.ebuild b/app-dicts/myspell-en/myspell-en-20210601.ebuild
new file mode 100644
index 000000000000..c7def649d4c0
--- /dev/null
+++ b/app-dicts/myspell-en/myspell-en-20210601.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit myspell-r2
+
+DESCRIPTION="English dictionaries for myspell/hunspell"
+HOMEPAGE="https://extensions.libreoffice.org/extensions/english-dictionaries"
+SRC_URI="https://extensions.libreoffice.org/assets/downloads/41/dict-en-20210601.oxt"
+
+LICENSE="BSD MIT LGPL-3+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~x86-solaris"
+
+PLOCALES=( "en" "en-AU" "en-CA" "en-GB" "en-US" "en-ZA" )
+IUSE+="${PLOCALES[@]/#/l10n_}"
+REQUIRED_USE="|| ( ${IUSE[@]} )"
+
+src_prepare() {
+ if use l10n_en-GB || use l10n_en; then
+ MYSPELL_HYPH=( "hyph_en_GB.dic" )
+ fi
+ if use l10n_en-US || use l10n_en; then
+ MYSPELL_THES=(
+ "th_en_US_v2.dat"
+ "th_en_US_v2.idx"
+ )
+ fi
+
+ MYSPELL_DICT=( )
+ for lang in "${PLOCALES[@]}"; do
+ if [[ "${lang}" == "en" ]]; then
+ continue
+ fi
+ local mylinguas="${lang//-/_}"
+ if use "l10n_${lang}" || use l10n_en; then
+ MYSPELL_DICT+=( "${mylinguas}.aff" "${mylinguas}.dic" )
+ else
+ rm "README_${mylinguas}.txt" || die
+ if [[ ${lang} == "en-US" ]]; then
+ rm "README_hyph_en_US.txt" || die
+ fi
+ if [[ ${lang} == "en-GB" ]]; then
+ rm "README_hyph_en_GB.txt" || die
+ rm "README_en_GB_thes.txt" || die
+ fi
+ fi
+ done
+
+ default
+}