summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Savchenko <bircoph@gentoo.org>2016-09-30 14:16:51 +0300
committerAndrew Savchenko <bircoph@gentoo.org>2016-09-30 15:03:50 +0300
commit0b015be7e2b6060477b0edf36ee941fe837f4ef1 (patch)
tree553dc1cccd96a33c5e11f1336d04c647ab01896f /app-doc/clsync-docs
parentwww-apps/tt-rss: remove old (diff)
downloadgentoo-0b015be7e2b6060477b0edf36ee941fe837f4ef1.tar.gz
gentoo-0b015be7e2b6060477b0edf36ee941fe837f4ef1.tar.bz2
gentoo-0b015be7e2b6060477b0edf36ee941fe837f4ef1.zip
app-doc/clsync-docs: version bump
Bump to 0.4.2, update ebuild to EAPI 6. Package-Manager: portage-2.3.1 Signed-off-by: Andrew Savchenko <bircoph@gentoo.org>
Diffstat (limited to 'app-doc/clsync-docs')
-rw-r--r--app-doc/clsync-docs/Manifest1
-rw-r--r--app-doc/clsync-docs/clsync-docs-0.4.2.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/app-doc/clsync-docs/Manifest b/app-doc/clsync-docs/Manifest
index 22e7548b65c7..994df4e67530 100644
--- a/app-doc/clsync-docs/Manifest
+++ b/app-doc/clsync-docs/Manifest
@@ -1 +1,2 @@
DIST clsync-0.4.1.tar.gz 253890 SHA256 3f14a72d7c3c1747ea908e373f25bd1918ce00450492fbb7094549db6bf21e27 SHA512 875280f706026d44806b92c22fa58d016136b2792f67a6b7e77f932465081da7a1ebaf22c25e538e4b58bfe04cd1cd5450ecab99c3df53ddd2a0fa966442d444 WHIRLPOOL 10ab11821766f7d16d03993069ac4da5fe362a1e5977ea6721e49ada7044d3659e59b507b03be4de09609b0a0ca9d7878407d7b6e1f40df5dbe1d041dac373cb
+DIST clsync-0.4.2.tar.gz 256042 SHA256 1af63b86c1d0bd663311f2129792446dc8fc4def5559f76658b51b69a8d0c3bd SHA512 d14a2efc4bf58d9d5c7a3fe5634cacdd182cd7cd814b0e9ebd99024a7282b056d1f7ceeec6903666391c3572d599a18e205af818b098ed7768d5c0e0f4cd1200 WHIRLPOOL a59446337282cb63455b43bbbf17ad1213e39713d9c267ca5ee8785d863bc90e7b99e5938e4d5be02f3103a98b1bb5d5a628580160952d821e6caaad72fa2679
diff --git a/app-doc/clsync-docs/clsync-docs-0.4.2.ebuild b/app-doc/clsync-docs/clsync-docs-0.4.2.ebuild
new file mode 100644
index 000000000000..7693440026da
--- /dev/null
+++ b/app-doc/clsync-docs/clsync-docs-0.4.2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+MY_PN="${PN%-docs}"
+MY_P="${MY_PN}-${PV}"
+
+SRC_URI="https://github.com/xaionaro/${MY_PN}/archive/v${PV}.tar.gz -> ${MY_P}.tar.gz"
+KEYWORDS="~amd64 ~x86"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="Clsync and libclsync API documentation"
+HOMEPAGE="http://ut.mephi.ru/oss/clsync https://github.com/xaionaro/clsync"
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE="api +examples"
+
+DEPEND="
+ virtual/pkgconfig
+ api? ( app-doc/doxygen )
+"
+
+src_configure() {
+ : # doxygen doesn't depend on configuration
+}
+
+src_compile() {
+ if use api; then
+ doxygen .doxygen || die "doxygen failed"
+ fi
+}
+
+src_install() {
+ dodoc CONTRIB DEVELOPING NOTES PROTOCOL README.md SHORTHANDS TODO
+ if use api; then
+ dodoc -r doc/doxygen/html doc/devel/*
+ fi
+ if use examples; then
+ docinto examples
+ dodoc -r examples/{production,clsync*}
+ fi
+}