summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-01-11 17:04:37 +0100
committerMichał Górny <mgorny@gentoo.org>2024-01-12 15:36:00 +0100
commitf7fdfdaeec3764929686064a6054c38a6b2d7788 (patch)
treea420a7aa231f9c43b9911a90b4cfa99ba60b3a24 /app-doc/doxygen/files
parentMove {app-doc → app-text}/NaturalDocs (diff)
downloadgentoo-f7fdfdaeec3764929686064a6054c38a6b2d7788.tar.gz
gentoo-f7fdfdaeec3764929686064a6054c38a6b2d7788.tar.bz2
gentoo-f7fdfdaeec3764929686064a6054c38a6b2d7788.zip
Move {app-doc → app-text}/doxygen
Per the category metadata, app-doc/ is reserved for documentation *files* and not software. Move it to app-text/ where it seems a better fit. Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-doc/doxygen/files')
-rw-r--r--app-doc/doxygen/files/doxygen-1.9.1-do_not_force_libcxx.patch13
-rw-r--r--app-doc/doxygen/files/doxygen-1.9.1-ignore-bad-encoding.patch23
-rw-r--r--app-doc/doxygen/files/doxygen-1.9.4-link_with_pthread.patch24
-rw-r--r--app-doc/doxygen/files/doxygen-1.9.7-musl-1.2.4.patch26
-rw-r--r--app-doc/doxygen/files/doxygen-1.9.8-spdlog-link.patch51
-rw-r--r--app-doc/doxygen/files/doxygen-1.9.8-suppress-unused-option-libcxx.patch16
-rw-r--r--app-doc/doxygen/files/doxygen-1.9.8-unbundle-sqlite.patch119
7 files changed, 0 insertions, 272 deletions
diff --git a/app-doc/doxygen/files/doxygen-1.9.1-do_not_force_libcxx.patch b/app-doc/doxygen/files/doxygen-1.9.1-do_not_force_libcxx.patch
deleted file mode 100644
index f33f619e62ed..000000000000
--- a/app-doc/doxygen/files/doxygen-1.9.1-do_not_force_libcxx.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 3775ed1..b3a1af6 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -23,7 +23,7 @@ option(build_doc "Build user manual (HTML and PDF)" OFF)
- option(build_doc_chm "Build user manual (CHM)" OFF)
- option(use_sqlite3 "Add support for sqlite3 output [experimental]." OFF)
- if (CMAKE_CXX_COMPILER_ID STREQUAL "Clang")
-- option(use_libc++ "Use libc++ as C++ standard library." ON)
-+ option(use_libc++ "Use libc++ as C++ standard library." OFF)
- endif()
- option(use_libclang "Add support for libclang parsing." OFF)
- option(static_libclang "Link to a statically compiled version of LLVM/libclang." OFF)
diff --git a/app-doc/doxygen/files/doxygen-1.9.1-ignore-bad-encoding.patch b/app-doc/doxygen/files/doxygen-1.9.1-ignore-bad-encoding.patch
deleted file mode 100644
index 5dd7578f24ec..000000000000
--- a/app-doc/doxygen/files/doxygen-1.9.1-ignore-bad-encoding.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-Hack to avoid "UnicodeDecodeError: 'utf-8' codec can't decode byte 0xb0 in position 45: invalid start byte"
-in src/._xmlgen.cpp which is binary. This doesn't seem like it should be present at the time the docs
-are generated, but this is simpler for now.
---- a/doc/translator.py
-+++ b/doc/translator.py
-@@ -1454,10 +1454,13 @@ class TrManager:
-
- # Read content of the file as one string.
- assert os.path.isfile(fname)
-- f = xopen(fname)
-- cont = f.read()
-- cont = ''.join(cont.split('\n')) # otherwise the 'match' function won't work.
-- f.close()
-+ try:
-+ with xopen(fname) as f:
-+ cont = f.read()
-+ cont = ''.join(cont.split('\n')) # otherwise the 'match' function won't work.
-+ except UnicodeDecodeError:
-+ print("Skipping {0} because of decoding errors".format(fname))
-+ return
-
- # Remove the items for identifiers that were found in the file.
- while lst_in:
diff --git a/app-doc/doxygen/files/doxygen-1.9.4-link_with_pthread.patch b/app-doc/doxygen/files/doxygen-1.9.4-link_with_pthread.patch
deleted file mode 100644
index 66093eb7deb9..000000000000
--- a/app-doc/doxygen/files/doxygen-1.9.4-link_with_pthread.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-diff --git a/addon/doxywizard/.CMakeLists.txt.swp b/addon/doxywizard/.CMakeLists.txt.swp
-deleted file mode 100644
-index fc379d2..0000000
-Binary files a/addon/doxywizard/.CMakeLists.txt.swp and /dev/null differ
-diff --git a/addon/doxywizard/CMakeLists.txt b/addon/doxywizard/CMakeLists.txt
-index bb0e0eb..b6135bd 100644
---- a/addon/doxywizard/CMakeLists.txt
-+++ b/addon/doxywizard/CMakeLists.txt
-@@ -132,12 +132,12 @@ apply_editbin(doxywizard windows)
- endif()
-
- if(Qt5Core_FOUND)
-- target_link_libraries(doxywizard Qt5::Core Qt5::Gui Qt5::Widgets Qt5::Xml doxygen_version)
-+ target_link_libraries(doxywizard Qt5::Core Qt5::Gui Qt5::Widgets Qt5::Xml doxygen_version pthread)
- else()
- if(Qt6Core_FOUND)
-- target_link_libraries(doxywizard Qt6::Core Qt6::Gui Qt6::Widgets Qt6::Xml doxygen_version)
-+ target_link_libraries(doxywizard Qt6::Core Qt6::Gui Qt6::Widgets Qt6::Xml doxygen_version pthread)
- else()
-- target_link_libraries(doxywizard ${QT_LIBRARIES} ${QT_QTMAIN_LIBRARY} doxygen_version)
-+ target_link_libraries(doxywizard ${QT_LIBRARIES} ${QT_QTMAIN_LIBRARY} doxygen_version pthread)
- endif()
- endif()
-
diff --git a/app-doc/doxygen/files/doxygen-1.9.7-musl-1.2.4.patch b/app-doc/doxygen/files/doxygen-1.9.7-musl-1.2.4.patch
deleted file mode 100644
index 2c71a0af9ae8..000000000000
--- a/app-doc/doxygen/files/doxygen-1.9.7-musl-1.2.4.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-https://bugs.gentoo.org/906920
-https://gitlab.exherbo.org/exherbo/arbor/-/commit/7b517ba0068adc471fe7b2ed8cfbb191a197ca17
-
-From 6d713aa98b36ee8219294515142c0225fbd09dfc Mon Sep 17 00:00:00 2001
-From: Heiko Becker <heirecka@exherbo.org>
-Date: Thu, 25 May 2023 10:52:29 +0200
-Subject: [PATCH] Apply upstream fix for spdlog
-
-Fixes the build with musl >= 1.2.4, see
-https://github.com/gabime/spdlog/commit/287a00d364990edbb621fe5e392aeb550135fb96
-for details.
---- a/deps/spdlog/include/spdlog/details/os-inl.h
-+++ b/deps/spdlog/include/spdlog/details/os-inl.h
-@@ -236,8 +236,8 @@ SPDLOG_INLINE size_t filesize(FILE *f)
- # else
- int fd = ::fileno(f);
- # endif
--// 64 bits(but not in osx or cygwin, where fstat64 is deprecated)
--# if (defined(__linux__) || defined(__sun) || defined(_AIX)) && (defined(__LP64__) || defined(_LP64))
-+// 64 bits(but not in osx, linux/musl or cygwin, where fstat64 is deprecated)
-+# if ((defined(__linux__) && defined(__GLIBC__)) || defined(__sun) || defined(_AIX)) && (defined(__LP64__) || defined(_LP64))
- struct stat64 st;
- if (::fstat64(fd, &st) == 0)
- {
---
-2.41.0.rc2
diff --git a/app-doc/doxygen/files/doxygen-1.9.8-spdlog-link.patch b/app-doc/doxygen/files/doxygen-1.9.8-spdlog-link.patch
deleted file mode 100644
index e73385dec3b2..000000000000
--- a/app-doc/doxygen/files/doxygen-1.9.8-spdlog-link.patch
+++ /dev/null
@@ -1,51 +0,0 @@
-https://github.com/doxygen/doxygen/issues/10265
-https://github.com/doxygen/doxygen/pull/10284
-
-From 70bb112352ae7f3130647dcc009d8de5d4134e6d Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?=D9=85=D9=87=D8=AF=D9=8A=20=D8=B4=D9=8A=D9=86=D9=88=D9=86?=
- =?UTF-8?q?=20=28Mehdi=20Chinoune=29?= <mehdi.chinoune@hotmail.com>
-Date: Mon, 4 Sep 2023 18:49:27 +0100
-Subject: [PATCH 1/2] doxyapp: Fix linking to spdlog
-
----
- addon/doxyapp/CMakeLists.txt | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/addon/doxyapp/CMakeLists.txt b/addon/doxyapp/CMakeLists.txt
-index 4f3c31feacd..6097a3cca69 100644
---- a/addon/doxyapp/CMakeLists.txt
-+++ b/addon/doxyapp/CMakeLists.txt
-@@ -46,7 +46,7 @@ mscgen
- doxygen_version
- doxycfg
- vhdlparser
--spdlog
-+spdlog::spdlog
- ${ICONV_LIBRARIES}
- ${CMAKE_THREAD_LIBS_INIT}
- ${SQLITE3_LIBRARIES}
-
-From 71f2ed171a6d14a67f1905802714add974c31789 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?=D9=85=D9=87=D8=AF=D9=8A=20=D8=B4=D9=8A=D9=86=D9=88=D9=86?=
- =?UTF-8?q?=20=28Mehdi=20Chinoune=29?= <mehdi.chinoune@hotmail.com>
-Date: Mon, 4 Sep 2023 18:50:25 +0100
-Subject: [PATCH 2/2] doxyparse: Fix linking to spdlog
-
----
- addon/doxyparse/CMakeLists.txt | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/addon/doxyparse/CMakeLists.txt b/addon/doxyparse/CMakeLists.txt
-index 24881e3ef12..0157afb45e2 100644
---- a/addon/doxyparse/CMakeLists.txt
-+++ b/addon/doxyparse/CMakeLists.txt
-@@ -35,7 +35,7 @@ mscgen
- doxygen_version
- doxycfg
- vhdlparser
--spdlog
-+spdlog::spdlog
- ${ICONV_LIBRARIES}
- ${CMAKE_THREAD_LIBS_INIT}
- ${SQLITE3_LIBRARIES}
-
diff --git a/app-doc/doxygen/files/doxygen-1.9.8-suppress-unused-option-libcxx.patch b/app-doc/doxygen/files/doxygen-1.9.8-suppress-unused-option-libcxx.patch
deleted file mode 100644
index 1da9a2da6459..000000000000
--- a/app-doc/doxygen/files/doxygen-1.9.8-suppress-unused-option-libcxx.patch
+++ /dev/null
@@ -1,16 +0,0 @@
-Always expose the use_libc++ option. It's only useful for Clang but cmake.class
-tries to find when we've used CMake options which are unused/unknown and this
-triggers it for GCC builds if we set -Duse_libc++=OFF.
-
-So, always expose the option so we can turn it off without a warning.
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -21,7 +21,7 @@ option(build_xmlparser "Automatically update the XML parser modules when updatin
- option(build_search "Build external search tools (doxysearch and doxyindexer)" OFF)
- option(build_doc "Build user manual (HTML and PDF)" OFF)
- option(build_doc_chm "Build user manual (CHM)" OFF)
--if (CMAKE_CXX_COMPILER_ID STREQUAL "Clang")
-+if (TRUE)
- option(use_libc++ "Use libc++ as C++ standard library." ON)
- endif()
- option(use_libclang "Add support for libclang parsing." OFF)
diff --git a/app-doc/doxygen/files/doxygen-1.9.8-unbundle-sqlite.patch b/app-doc/doxygen/files/doxygen-1.9.8-unbundle-sqlite.patch
deleted file mode 100644
index 04d1d69b7b86..000000000000
--- a/app-doc/doxygen/files/doxygen-1.9.8-unbundle-sqlite.patch
+++ /dev/null
@@ -1,119 +0,0 @@
-https://github.com/doxygen/doxygen/issues/10263
-https://github.com/doxygen/doxygen/commit/28609fecd41d885e54fa170e499a0e5b55def2c2
-
-From 28609fecd41d885e54fa170e499a0e5b55def2c2 Mon Sep 17 00:00:00 2001
-From: Dimitri van Heesch <doxygen@gmail.com>
-Date: Mon, 28 Aug 2023 20:19:16 +0200
-Subject: [PATCH] issue #10263 please add a use_sys_sqlite3 config option
-
----
- CMakeLists.txt | 6 +++++-
- cmake/FindSQLite3.cmake | 38 ++++++++++++++++++++++++++++++++++++++
- deps/CMakeLists.txt | 4 +++-
- src/CMakeLists.txt | 4 +++-
- 4 files changed, 49 insertions(+), 3 deletions(-)
- create mode 100644 cmake/FindSQLite3.cmake
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 4957c34c24d..31e53cc8440 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -25,7 +25,8 @@ if (CMAKE_CXX_COMPILER_ID STREQUAL "Clang")
- option(use_libc++ "Use libc++ as C++ standard library." ON)
- endif()
- option(use_libclang "Add support for libclang parsing." OFF)
--option(use_sys_spdlog "Use system spdlog instead of bundled." OFF)
-+option(use_sys_spdlog "Use system spdlog library instead of the one bundled." OFF)
-+option(use_sys_sqlite3 "Use system sqlite3 library instead of the one bundled." OFF)
- option(static_libclang "Link to a statically compiled version of LLVM/libclang." OFF)
- option(win_static "Link with /MT in stead of /MD on windows" OFF)
- option(enable_console "Enable that executables on Windows get the CONSOLE bit set for the doxywizard executable [development]" OFF)
-@@ -67,6 +68,9 @@ endif()
- if (use_sys_spdlog)
- find_package(spdlog CONFIG REQUIRED)
- endif()
-+if (use_sys_sqlite3)
-+ find_package(SQLite3 REQUIRED)
-+endif()
- if (build_wizard)
- if (force_qt STREQUAL "Qt6")
- if (CMAKE_SYSTEM MATCHES "Darwin")
-diff --git a/cmake/FindSQLite3.cmake b/cmake/FindSQLite3.cmake
-new file mode 100644
-index 00000000000..7c21de223a7
---- /dev/null
-+++ b/cmake/FindSQLite3.cmake
-@@ -0,0 +1,38 @@
-+# Copyright (C) 2007-2009 LuaDist.
-+# Created by Peter Kapec <kapecp@gmail.com>
-+# Redistribution and use of this file is allowed according to the terms of the MIT license.
-+# For details see the COPYRIGHT file distributed with LuaDist.
-+# Note:
-+# Searching headers and libraries is very simple and is NOT as powerful as scripts
-+# distributed with CMake, because LuaDist defines directories to search for.
-+# Everyone is encouraged to contact the author with improvements. Maybe this file
-+# becomes part of CMake distribution sometimes.
-+
-+# - Find sqlite3
-+# Find the native SQLite3 headers and libraries.
-+#
-+# SQLite3_INCLUDE_DIRS - where to find sqlite3.h, etc.
-+# SQLite3_LIBRARIES - List of libraries when using sqlite.
-+# SQLite3_FOUND - True if sqlite found.
-+
-+# Look for the header file.
-+FIND_PATH(SQLite3_INCLUDE_DIR NAMES sqlite3.h)
-+
-+# Look for the library.
-+FIND_LIBRARY(SQLite3_LIBRARY NAMES sqlite3)
-+
-+# Handle the QUIETLY and REQUIRED arguments and set SQLITE3_FOUND to TRUE if all listed variables are TRUE.
-+INCLUDE(FindPackageHandleStandardArgs)
-+FIND_PACKAGE_HANDLE_STANDARD_ARGS(SQLite3 DEFAULT_MSG SQLite3_LIBRARY SQLite3_INCLUDE_DIR)
-+
-+# Copy the results to the output variables.
-+IF(SQLite3_FOUND)
-+ SET(SQLite3_LIBRARIES ${SQLite3_LIBRARY})
-+ SET(SQLite3_INCLUDE_DIRS ${SQLite3_INCLUDE_DIR})
-+ELSE(SQLite3_FOUND)
-+ SET(SQLite3_LIBRARIES)
-+ SET(SQLite3_INCLUDE_DIRS)
-+ENDIF(SQLite3_FOUND)
-+
-+MARK_AS_ADVANCED(SQLite3_INCLUDE_DIRS SQLite3_LIBRARIES)
-+
-diff --git a/deps/CMakeLists.txt b/deps/CMakeLists.txt
-index a689b4a7018..eb716417f22 100644
---- a/deps/CMakeLists.txt
-+++ b/deps/CMakeLists.txt
-@@ -4,4 +4,6 @@ add_subdirectory(libmscgen)
- if (NOT use_sys_spdlog)
- add_subdirectory(spdlog)
- endif()
--add_subdirectory(sqlite3)
-+if (NOT use_sys_sqlite3)
-+ add_subdirectory(sqlite3)
-+endif()
-diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
-index 78a55c3f2bf..02c52240e5b 100644
---- a/src/CMakeLists.txt
-+++ b/src/CMakeLists.txt
-@@ -6,7 +6,6 @@ include_directories(
- ${PROJECT_SOURCE_DIR}/deps/libmd5
- ${PROJECT_SOURCE_DIR}/deps/liblodepng
- ${PROJECT_SOURCE_DIR}/deps/libmscgen
-- ${PROJECT_SOURCE_DIR}/deps/sqlite3
- ${PROJECT_SOURCE_DIR}/libversion
- ${PROJECT_SOURCE_DIR}/libxml
- ${PROJECT_SOURCE_DIR}/vhdlparser
-@@ -18,6 +17,9 @@ include_directories(
- if (NOT use_sys_spdlog)
- include_directories(${PROJECT_SOURCE_DIR}/deps/spdlog/include)
- endif()
-+if (NOT use_sys_sqlite)
-+ include_directories(${PROJECT_SOURCE_DIR}/deps/sqlite3)
-+endif()
-
-
- file(MAKE_DIRECTORY ${GENERATED_SRC})
-