summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2020-01-17 18:28:26 +0100
committerUlrich Müller <ulm@gentoo.org>2020-01-17 18:37:50 +0100
commit6931715cbc875018cad61ae31018bc3b2292a058 (patch)
treea3aaf83b27b7e876256ce820f47813e46c4a148e /app-doc/elisp-manual/elisp-manual-26.3.ebuild
parentprofiles: Drop mask for removed app-editors/emacs-vcs. (diff)
downloadgentoo-6931715cbc875018cad61ae31018bc3b2292a058.tar.gz
gentoo-6931715cbc875018cad61ae31018bc3b2292a058.tar.bz2
gentoo-6931715cbc875018cad61ae31018bc3b2292a058.zip
app-doc/elisp-manual: Version bump to 26.3.
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'app-doc/elisp-manual/elisp-manual-26.3.ebuild')
-rw-r--r--app-doc/elisp-manual/elisp-manual-26.3.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/app-doc/elisp-manual/elisp-manual-26.3.ebuild b/app-doc/elisp-manual/elisp-manual-26.3.ebuild
new file mode 100644
index 000000000000..d2a4ef6799ba
--- /dev/null
+++ b/app-doc/elisp-manual/elisp-manual-26.3.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="The GNU Emacs Lisp Reference Manual"
+HOMEPAGE="https://www.gnu.org/software/emacs/manual/"
+# taken from doc/lispref/ (and some files from doc/emacs/) of emacs-${PV}
+SRC_URI="https://dev.gentoo.org/~ulm/emacs/${P}.tar.xz"
+
+LICENSE="FDL-1.3+"
+SLOT="26"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+DEPEND="sys-apps/texinfo"
+
+S="${WORKDIR}/lispref"
+PATCHES=("${FILESDIR}/${P}-direntry.patch")
+
+src_compile() {
+ makeinfo -I "${WORKDIR}"/emacs elisp.texi || die
+}
+
+src_install() {
+ doinfo elisp${SLOT}.info*
+ dodoc README
+}