summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorsoredake <fdsfgs@krutt.org>2016-10-27 15:34:46 +0300
committerPatrice Clement <monsieurp@gentoo.org>2016-10-31 17:28:48 +0100
commit20b8d7f21a2f3de30013699bd88be4bc48911121 (patch)
treebcdc856df808b41d597ccd296b602fc2dd3534d0 /app-doc/zeal/zeal-0.3.1.ebuild
parentprofiles: Update Plasma profile package use (diff)
downloadgentoo-20b8d7f21a2f3de30013699bd88be4bc48911121.tar.gz
gentoo-20b8d7f21a2f3de30013699bd88be4bc48911121.tar.bz2
gentoo-20b8d7f21a2f3de30013699bd88be4bc48911121.zip
app-doc/zeal: improvements.
* EAPI bump. * version bump to 0.3.1. * keyword for the ~arm platform. Closes: https://github.com/gentoo/gentoo/pull/2678 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'app-doc/zeal/zeal-0.3.1.ebuild')
-rw-r--r--app-doc/zeal/zeal-0.3.1.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/app-doc/zeal/zeal-0.3.1.ebuild b/app-doc/zeal/zeal-0.3.1.ebuild
new file mode 100644
index 000000000000..93e2c87e4d46
--- /dev/null
+++ b/app-doc/zeal/zeal-0.3.1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit qmake-utils gnome2-utils fdo-mime
+
+DESCRIPTION="Offline documentation browser inspired by Dash"
+HOMEPAGE="https://zealdocs.org/"
+SRC_URI="https://github.com/zealdocs/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+S="${WORKDIR}/${P}/src"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+
+DEPEND="
+ app-arch/libarchive
+ dev-qt/qtconcurrent:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtsql:5[sqlite]
+ dev-qt/qtwebkit:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ >=x11-libs/xcb-util-keysyms-0.3.9
+"
+
+RDEPEND="
+ ${DEPEND}
+ x11-themes/hicolor-icon-theme
+"
+
+src_configure() {
+ eqmake5
+ PREFIX="${EPREFIX}/usr"
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" PREFIX="${EPREFIX}/usr" install
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+ fdo-mime_desktop_database_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+ fdo-mime_desktop_database_update
+}