summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2020-03-01 12:39:01 -0600
committerMatthias Maier <tamiko@gentoo.org>2020-03-01 12:39:01 -0600
commit42627f0dd0c2e196af79a5412424f02879adbbac (patch)
tree51ac12fb4aa882e9efd89f8b897a42659de3a767 /app-doc
parentapp-doc/doxygen: remove latex use flag (diff)
downloadgentoo-42627f0dd0c2e196af79a5412424f02879adbbac.tar.gz
gentoo-42627f0dd0c2e196af79a5412424f02879adbbac.tar.bz2
gentoo-42627f0dd0c2e196af79a5412424f02879adbbac.zip
app-doc/doxygen: update live ebuild
Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Matthias Maier <tamiko@gentoo.org>
Diffstat (limited to 'app-doc')
-rw-r--r--app-doc/doxygen/doxygen-9999.ebuild17
1 files changed, 9 insertions, 8 deletions
diff --git a/app-doc/doxygen/doxygen-9999.ebuild b/app-doc/doxygen/doxygen-9999.ebuild
index fbce5ffa6dd3..1f26a9351fed 100644
--- a/app-doc/doxygen/doxygen-9999.ebuild
+++ b/app-doc/doxygen/doxygen-9999.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-PYTHON_COMPAT=( python3_6 )
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
CMAKE_MAKEFILE_GENERATOR="emake"
@@ -22,7 +22,7 @@ HOMEPAGE="http://www.doxygen.org"
LICENSE="GPL-2"
SLOT="0"
-IUSE="clang debug doc dot doxysearch latex qt5 sqlite userland_GNU"
+IUSE="clang debug doc dot doxysearch qt5 sqlite userland_GNU"
RDEPEND="app-text/ghostscript-gpl
dev-lang/perl
@@ -33,14 +33,14 @@ RDEPEND="app-text/ghostscript-gpl
media-gfx/graphviz
media-libs/freetype
)
- doxysearch? ( dev-libs/xapian:= )
- latex? (
+ doc? (
dev-texlive/texlive-bibtexextra
dev-texlive/texlive-fontsextra
dev-texlive/texlive-fontutils
dev-texlive/texlive-latex
dev-texlive/texlive-latexextra
)
+ doxysearch? ( dev-libs/xapian:= )
qt5? (
dev-qt/qtgui:5
dev-qt/qtwidgets:5
@@ -49,8 +49,6 @@ RDEPEND="app-text/ghostscript-gpl
sqlite? ( dev-db/sqlite:3 )
"
-REQUIRED_USE="doc? ( latex )"
-
DEPEND="sys-devel/flex
sys-devel/bison
doc? ( ${PYTHON_DEPS} )
@@ -59,7 +57,10 @@ DEPEND="sys-devel/flex
# src_test() defaults to make -C testing but there is no such directory (bug #504448)
RESTRICT="test"
-PATCHES=( "${FILESDIR}/${PN}-1.8.12-link_with_pthread.patch" )
+PATCHES=(
+ "${FILESDIR}/${PN}-1.8.12-link_with_pthread.patch"
+ "${FILESDIR}/${PN}-1.8.17-ensure_static_support_libraries.patch"
+)
DOCS=( LANGUAGE.HOWTO README.md )
pkg_setup() {