summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorneeshy <neeshy@tfwno.gf>2020-03-22 01:04:16 -0400
committerJoonas Niilola <juippis@gentoo.org>2020-04-05 10:17:54 +0300
commitc58e83a791143d8e947e893fe72ded0593e2b7f4 (patch)
treedeb7686fd97099d9d09c646988e77d354cc63edf /app-doc
parentwww-misc/buku: Add version 4.3 (diff)
downloadgentoo-c58e83a791143d8e947e893fe72ded0593e2b7f4.tar.gz
gentoo-c58e83a791143d8e947e893fe72ded0593e2b7f4.tar.bz2
gentoo-c58e83a791143d8e947e893fe72ded0593e2b7f4.zip
app-doc/cppman: bump version to 0.4.9
Signed-off-by: Nima Sadeghi <neeshy@tfwno.gf> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-doc')
-rw-r--r--app-doc/cppman/Manifest1
-rw-r--r--app-doc/cppman/cppman-0.4.9.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/app-doc/cppman/Manifest b/app-doc/cppman/Manifest
index c4d838c7b56d..7e0b0cdd148e 100644
--- a/app-doc/cppman/Manifest
+++ b/app-doc/cppman/Manifest
@@ -1 +1,2 @@
DIST cppman-0.4.8.tar.gz 3185978 BLAKE2B 9f662874eb6b6540e02a2b371fa47e53e0893239fbfcc65421fa5c7c4bc5f88c4cfd2facf08deb13606f5cf7c895a1a07e119e1c15bbc98b95af5f8056c6a5e8 SHA512 f5b93774988dad592b31670d6c21718bd034e4e94858982e1756e8db89779d12001fd786ba629211b038b173b7b507382277a3db7fb35363dba28cd029e69a7d
+DIST cppman-0.4.9.tar.gz 3237707 BLAKE2B 23068f8896dd4f9fa3ab86e8e3ddb7de5190af4f59f3cf283537c6ce8c3df60c5deab4972be750464121eeb1ebbde93e30c313869d5fb92e1d784d1294b1d842 SHA512 49957e9c9dcf82a85558d47325912e689ed7786f745015215b32e6f86b97878af6edcb265655674191992ba16171fdbf2220ee43d8c90a0d5eb37f1fb584c3ce
diff --git a/app-doc/cppman/cppman-0.4.9.ebuild b/app-doc/cppman/cppman-0.4.9.ebuild
new file mode 100644
index 000000000000..a124e60ffdd5
--- /dev/null
+++ b/app-doc/cppman/cppman-0.4.9.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_REQ_USE="sqlite,threads(+)"
+
+DISTUTILS_SINGLE_IMPL=true
+
+inherit distutils-r1
+
+DESCRIPTION="C++ man pages for Linux, with source from cplusplus.com and cppreference.com"
+HOMEPAGE="https://github.com/aitjcize/cppman"
+LICENSE="GPL-3"
+
+SLOT="0"
+SRC_URI="https://github.com/aitjcize/cppman/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+KEYWORDS="~amd64 ~arm ~x86 ~x64-macos"
+
+RDEPEND="
+ sys-apps/groff
+ $(python_gen_cond_dep '
+ dev-python/beautifulsoup:4[${PYTHON_MULTI_USEDEP}]
+ dev-python/html5lib[${PYTHON_MULTI_USEDEP}]
+ ')
+"
+
+# `./setup install` already installs docs
+DOCS=()