summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2022-02-13 00:12:55 +0100
committerConrad Kostecki <conikost@gentoo.org>2022-02-13 22:06:40 +0100
commitd10074a4153285cdec8641ce43a0de747714c262 (patch)
tree8163dab26ad15b794183be1ed041bcc0abbe1aa7 /app-doc
parentapp-admin/mcollective: fix DeprecatedInsinto (diff)
downloadgentoo-d10074a4153285cdec8641ce43a0de747714c262.tar.gz
gentoo-d10074a4153285cdec8641ce43a0de747714c262.tar.bz2
gentoo-d10074a4153285cdec8641ce43a0de747714c262.zip
app-doc/linux-device-drivers: fix DeprecatedInsinto
Also bumped EAPI 6 -> 8. Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'app-doc')
-rw-r--r--app-doc/linux-device-drivers/linux-device-drivers-2-r1.ebuild29
-rw-r--r--app-doc/linux-device-drivers/linux-device-drivers-2.ebuild26
-rw-r--r--app-doc/linux-device-drivers/linux-device-drivers-3-r1.ebuild27
-rw-r--r--app-doc/linux-device-drivers/linux-device-drivers-3.ebuild29
4 files changed, 56 insertions, 55 deletions
diff --git a/app-doc/linux-device-drivers/linux-device-drivers-2-r1.ebuild b/app-doc/linux-device-drivers/linux-device-drivers-2-r1.ebuild
new file mode 100644
index 000000000000..02389ad129be
--- /dev/null
+++ b/app-doc/linux-device-drivers/linux-device-drivers-2-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+EGIT_COMMIT="9780596000080"
+MY_PN="ldd2-samples"
+MY_PV="1.0.1"
+
+DESCRIPTION="Howto write linux device drivers (updated for Linux 2.4)"
+HOMEPAGE="https://www.oreilly.com/catalog/linuxdrive2/"
+SRC_URI="
+ https://resources.oreilly.com/examples/${EGIT_COMMIT}/-/blob/master/${MY_PN}-${MY_PV}.tar.gz
+ https://www.xml.com/ldd/chapter/book/pdf/ldd_book_pdf.zip
+"
+S="${WORKDIR}"
+
+LICENSE="FDL-1.1"
+SLOT="2"
+KEYWORDS="amd64 arm hppa ~ia64 ppc ~s390 x86"
+
+BDEPEND="app-arch/unzip"
+
+src_install() {
+ dodoc *.pdf
+ docinto samples
+ dodoc -r ldd2-samples-*/.
+ docompress -x /usr/share/doc/${PF}
+}
diff --git a/app-doc/linux-device-drivers/linux-device-drivers-2.ebuild b/app-doc/linux-device-drivers/linux-device-drivers-2.ebuild
deleted file mode 100644
index b9f14bca98b9..000000000000
--- a/app-doc/linux-device-drivers/linux-device-drivers-2.ebuild
+++ /dev/null
@@ -1,26 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-DESCRIPTION="howto write linux device drivers (updated for Linux 2.4)"
-HOMEPAGE="http://www.oreilly.com/catalog/linuxdrive2/"
-SRC_URI="http://www.xml.com/ldd/chapter/book/pdf/ldd_book_pdf.zip
- ftp://ftp.oreilly.com/examples/linuxdrive2/ldd2-samples-1.0.1.tar.gz"
-
-LICENSE="FDL-1.1"
-SLOT="2"
-KEYWORDS="amd64 arm hppa ~ia64 ppc ~s390 x86"
-IUSE=""
-
-DEPEND="app-arch/unzip"
-RDEPEND=""
-
-S=${WORKDIR}
-
-src_install() {
- insinto /usr/share/doc/${PF}
- doins *.pdf
- insinto /usr/share/doc/${PF}/samples
- doins -r ldd2-samples-*/*
-}
diff --git a/app-doc/linux-device-drivers/linux-device-drivers-3-r1.ebuild b/app-doc/linux-device-drivers/linux-device-drivers-3-r1.ebuild
new file mode 100644
index 000000000000..e3bbbd96aeec
--- /dev/null
+++ b/app-doc/linux-device-drivers/linux-device-drivers-3-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+EGIT_COMMIT="9780596005900"
+
+DESCRIPTION="Howto write linux device drivers (updated for Linux 2.6)"
+HOMEPAGE="
+ https://www.oreilly.com/catalog/linuxdrive3/
+ https://lwn.net/Kernel/LDD3/
+"
+SRC_URI="
+ https://resources.oreilly.com/examples/${EGIT_COMMIT}/-/blob/master/examples.tar.gz -> LDD3-examples.tar.gz
+ https://lwn.net/images/pdf/LDD3/ldd3_pdf.tar.bz2
+"
+S="${WORKDIR}"
+
+LICENSE="CC-BY-SA-2.0"
+SLOT="3"
+KEYWORDS="amd64 arm hppa ~ia64 ppc ~riscv ~s390 x86"
+
+src_install() {
+ dodoc ldd3_pdf/*.pdf
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}
+}
diff --git a/app-doc/linux-device-drivers/linux-device-drivers-3.ebuild b/app-doc/linux-device-drivers/linux-device-drivers-3.ebuild
deleted file mode 100644
index 73d58ce3d6c9..000000000000
--- a/app-doc/linux-device-drivers/linux-device-drivers-3.ebuild
+++ /dev/null
@@ -1,29 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-DESCRIPTION="howto write linux device drivers (updated for Linux 2.6)"
-HOMEPAGE="http://www.oreilly.com/catalog/linuxdrive3/ http://lwn.net/Kernel/LDD3/"
-SRC_URI="http://lwn.net/images/pdf/LDD3/ldd3_pdf.tar.bz2
- mirror://gentoo/LDD3-examples.tar.gz"
-# original URL is this:
-# http://examples.oreilly.com/linuxdrive3/examples.tar.gz
-# but 'examples.tar.gz' is waaaaaay too generic
-
-LICENSE="CC-BY-SA-2.0"
-SLOT="3"
-KEYWORDS="amd64 arm hppa ~ia64 ppc ~riscv ~s390 x86"
-IUSE=""
-
-DEPEND=""
-RDEPEND=""
-
-S=${WORKDIR}
-
-src_install() {
- insinto /usr/share/doc/${PF}
- doins ldd3_pdf/*.pdf
- insinto /usr/share/doc/${PF}/examples
- doins -r examples/*
-}