summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Torokhov <torokhov-s-a@yandex.ru>2022-02-20 22:03:47 +0300
committerSam James <sam@gentoo.org>2022-02-27 00:52:50 +0000
commite1ef183ac6db5d4316ee720ab4ba397a8d6fa240 (patch)
tree590d4fa946d527e6e04782f1a103a8a04fde8266 /app-doc
parentmedia-libs/glyr: update EAPI 6 -> 8 (diff)
downloadgentoo-e1ef183ac6db5d4316ee720ab4ba397a8d6fa240.tar.gz
gentoo-e1ef183ac6db5d4316ee720ab4ba397a8d6fa240.tar.bz2
gentoo-e1ef183ac6db5d4316ee720ab4ba397a8d6fa240.zip
app-doc/gimp-help: add python-3.10 compatibility
Signed-off-by: Sergey Torokhov <torokhov-s-a@yandex.ru> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-doc')
-rw-r--r--app-doc/gimp-help/gimp-help-2.10.0-r2.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/app-doc/gimp-help/gimp-help-2.10.0-r2.ebuild b/app-doc/gimp-help/gimp-help-2.10.0-r2.ebuild
new file mode 100644
index 000000000000..719b556896f2
--- /dev/null
+++ b/app-doc/gimp-help/gimp-help-2.10.0-r2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit python-any-r1
+
+DESCRIPTION="GNU Image Manipulation Program help files"
+HOMEPAGE="https://docs.gimp.org/"
+SRC_URI="mirror://gimp/help/${P}.tar.bz2"
+
+LICENSE="FDL-1.2"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE=""
+
+BDEPEND="
+ ${PYTHON_DEPS}
+ sys-devel/gettext
+ $(python_gen_any_dep 'dev-libs/libxml2[python,${PYTHON_USEDEP}]')
+ dev-libs/libxslt
+"
+
+# Adds python3 build support, bug 725940
+# patch is from https://gitlab.gnome.org/GNOME/gimp-help/-/issues/201
+PATCHES=( "${FILESDIR}/${P}-python3.patch" )
+
+python_check_deps() {
+ has_version "dev-libs/libxml2[${PYTHON_USEDEP}]"
+}
+
+src_configure() {
+ econf --without-gimp
+}