summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-06-18 23:03:42 +0200
committerDavid Seifert <soap@gentoo.org>2021-06-18 23:03:42 +0200
commit41ecb8feb7995ff28e664d990fcddf523ccf40a2 (patch)
tree97626220dc55e916588df387ba377f296899cdf6 /app-editors/ee/ee-1.5.2.ebuild
parentapp-crypt/mit-krb5-appl: add pkgconfig or pkgconfig-referenced libs deps (diff)
downloadgentoo-41ecb8feb7995ff28e664d990fcddf523ccf40a2.tar.gz
gentoo-41ecb8feb7995ff28e664d990fcddf523ccf40a2.tar.bz2
gentoo-41ecb8feb7995ff28e664d990fcddf523ccf40a2.zip
app-editors/ee: add pkgconfig or pkgconfig-referenced libs deps
Add dependencies for either virtual/pkgconfig, move it into BDEPEND where applicable, or add dependencies for libraries we're trying to find with pkgconfig. Package-Manager: Portage-3.0.18-prefix, Repoman-3.0.3 Signed-off-by: Sam James <sam@gentoo.org> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'app-editors/ee/ee-1.5.2.ebuild')
-rw-r--r--app-editors/ee/ee-1.5.2.ebuild55
1 files changed, 0 insertions, 55 deletions
diff --git a/app-editors/ee/ee-1.5.2.ebuild b/app-editors/ee/ee-1.5.2.ebuild
deleted file mode 100644
index 0cf7383a4c7e..000000000000
--- a/app-editors/ee/ee-1.5.2.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="7"
-
-inherit toolchain-funcs
-
-DESCRIPTION="An easy to use text editor. A subset of aee"
-#HOMEPAGE="http://mahon.cwx.net/ http://www.users.uswest.net/~hmahon/"
-HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage"
-SRC_URI="mirror://gentoo/${P}.src.tgz"
-
-LICENSE="BSD-2"
-SLOT="0"
-KEYWORDS="~alpha amd64 ~ia64 ~mips ppc ppc64 ~sparc x86 ~amd64-linux ~x86-linux ~ppc-macos"
-IUSE=""
-
-RDEPEND="!app-editors/ersatz-emacs"
-BDEPEND="virtual/pkgconfig"
-S="${WORKDIR}/easyedit-${PV}"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-init-location.patch
- "${FILESDIR}"/${PN}-signal.patch
- "${FILESDIR}"/${PN}-Wformat-security.patch
- "${FILESDIR}"/${PN}-gcc-10.patch
-)
-DOCS=( Changes README.${PN} ${PN}.i18n.guide ${PN}.msg )
-
-src_prepare() {
- sed -i \
- -e "s/make -/\$(MAKE) -/g" \
- -e "/^buildee/s/$/ localmake/" \
- Makefile
-
- sed -i \
- -e "s/\tcc /\t\\\\\$(CC) /" \
- -e "/CFLAGS =/s/\" >/ \\\\\$(LDFLAGS)\" >/" \
- -e "/other_cflag/s/ *-s//" \
- -e "s/-lcurses/$($(tc-getPKG_CONFIG) --libs ncurses)/" \
- create.make
-
- default
-}
-
-src_compile() {
- emake CC="$(tc-getCC)"
-}
-
-src_install() {
- dobin ${PN}
- doman ${PN}.1
- einstalldocs
- keepdir /usr/share/${PN}
-}