summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-editors/elvis
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-editors/elvis')
-rw-r--r--app-editors/elvis/Manifest1
-rw-r--r--app-editors/elvis/elvis-2.2.0-r4.ebuild96
-rw-r--r--app-editors/elvis/files/elvis-2.2.0-glibc-2.10.patch48
-rw-r--r--app-editors/elvis/files/elvis-2.2.0-interix.patch11
-rw-r--r--app-editors/elvis/files/ft2.3-symbol-collision-fix.patch73
-rw-r--r--app-editors/elvis/metadata.xml5
6 files changed, 234 insertions, 0 deletions
diff --git a/app-editors/elvis/Manifest b/app-editors/elvis/Manifest
new file mode 100644
index 000000000000..b9f855fd559e
--- /dev/null
+++ b/app-editors/elvis/Manifest
@@ -0,0 +1 @@
+DIST elvis-2.2_0.tar.gz 1439293 SHA256 9a8466b2293798441056bc279736af3a616baaba2f11940396cc60ff71924ea0 SHA512 847cc9ac0af170798abd4725f7dc2ec74d4931fb761b58836d4016d36da5657176bd8cdcdae02bc08438b18e8ce2433eb3340ec2503630fd2992e83ba06adf42 WHIRLPOOL be087bc38507900852dbe1f9b59a14c3e135d14bc695f2ec23c6c70284c6f9b7d35b7d25a0dd2b36f32392537421aeb6804df477cfc98a206f101ffee5f2be8f
diff --git a/app-editors/elvis/elvis-2.2.0-r4.ebuild b/app-editors/elvis/elvis-2.2.0-r4.ebuild
new file mode 100644
index 000000000000..3136054524dc
--- /dev/null
+++ b/app-editors/elvis/elvis-2.2.0-r4.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils versionator toolchain-funcs
+
+MY_PV=$(replace_version_separator 2 '_')
+
+DESCRIPTION="A vi/ex clone"
+HOMEPAGE="ftp://ftp.cs.pdx.edu/pub/elvis/"
+SRC_URI="ftp://ftp.cs.pdx.edu/pub/elvis/${PN}-${MY_PV}.tar.gz"
+
+LICENSE="Artistic"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 x86 ~x86-interix ~ppc-macos ~x86-macos ~m68k-mint ~sparc-solaris"
+IUSE="X"
+
+RDEPEND=">=sys-libs/ncurses-5.7-r7
+ X? ( >=x11-proto/xproto-7.0.4
+ >=x11-libs/libX11-1.0.0
+ >=x11-libs/libXt-1.0.0
+ >=x11-libs/libXpm-3.5.4.2
+ >=x11-libs/libXft-2.1.8.2 )
+ app-eselect/eselect-vi"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S=${WORKDIR}/${PN}-${MY_PV}
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/ft2.3-symbol-collision-fix.patch \
+ "${FILESDIR}"/${P}-glibc-2.10.patch \
+ "${FILESDIR}"/${P}-interix.patch
+}
+
+src_configure() {
+ ./configure \
+ --libs="$($(tc-getPKG_CONFIG) --libs ncurses)" \
+ --prefix="${EPREFIX}"/usr \
+ --bindir="${EPREFIX}"/usr/bin \
+ --datadir="${EPREFIX}"/usr/share/elvis \
+ --docdir="${EPREFIX}"/usr/share/doc/${PF} \
+ $(use_with X x) \
+ || die
+
+ # Some Makefile fixups (must happen after configure)
+ # Use our CFLAGS
+ sed -i -e "s:gcc -O2:$(tc-getCC) ${CFLAGS}:" Makefile || die "sed 1 failed"
+
+ # We'll install the man-pages ourselves
+ sed -i -e '/^ sh instman.sh/d' Makefile || die "sed 2 failed"
+
+ # Don't try to write to /etc
+ sed -i -e 's,/etc/elvis,${ED}/etc/elvis,g' Makefile || die "sed 3 failed"
+
+ # Use LDFLAGS
+ sed -i -e "s#\$(CC) \$(CFLAGS)#\$(CC) \$(CFLAGS) ${LDFLAGS}#" Makefile || \
+ die "sed 4 failed"
+}
+
+src_install() {
+ dodir /usr/bin
+ dodir /usr/share/man/man1
+ dodir /usr/share/elvis
+ dodir /usr/share/doc/${PF}
+ dodir /etc
+ emake install \
+ PREFIX="${ED}"/usr \
+ BINDIR="${ED}"/usr/bin \
+ DATADIR="${ED}"/usr/share/elvis \
+ DOCDIR="${ED}"/usr/share/doc/${PF}
+
+ # Install the man-pages
+ mv doc/elvis.man doc/elvis.1
+ mv doc/elvtags.man doc/elvtags.1
+ mv doc/ref.man doc/ref.1
+ doman doc/*.1
+
+ # Fixup some READMEs
+ sed -i -e "s,${ED},,g" "${ED}"/etc/elvis/README \
+ || die 'sed /etc/elvis/README failed'
+ sed -i -e "s,${ED},,g" "${ED}"/usr/share/elvis/README \
+ || die 'sed /usr/share/elvis/README failed'
+}
+
+pkg_postinst() {
+ einfo "Setting /usr/bin/vi symlink"
+ eselect vi set "${PN}"
+}
+
+pkg_postrm() {
+ einfo "Updating /usr/bin/vi symlink"
+ eselect vi update
+}
diff --git a/app-editors/elvis/files/elvis-2.2.0-glibc-2.10.patch b/app-editors/elvis/files/elvis-2.2.0-glibc-2.10.patch
new file mode 100644
index 000000000000..1a3d1affb303
--- /dev/null
+++ b/app-editors/elvis/files/elvis-2.2.0-glibc-2.10.patch
@@ -0,0 +1,48 @@
+diff -ur elvis-2.2_0.orig/ref.c elvis-2.2_0/ref.c
+--- elvis-2.2_0.orig/ref.c 2003-10-21 05:32:25.000000000 +0300
++++ elvis-2.2_0/ref.c 2009-08-05 21:28:30.000000000 +0300
+@@ -42,7 +42,7 @@
+
+ #if USE_PROTOTYPES
+ static void usage(char *argv0);
+-static char *getline(FILE *fp);
++static char *get_line(FILE *fp);
+ static void store(char *line, char **list);
+ static LINECLS classify(char *line, LINECLS prev);
+ static void lookup(TAG *tag);
+@@ -171,7 +171,7 @@
+ /* This function reads a single line, and replaces the terminating newline with
+ * a '\0' byte. The string will be in a static buffer. Returns NULL at EOF.
+ */
+-static char *getline(fp)
++static char *get_line(fp)
+ FILE *fp;
+ {
+ int ch;
+@@ -348,7 +348,7 @@
+ }
+
+ /* for each line... */
+- for (lnum = 1, lc = LC_COMPLETE; (line = getline(fp)) != NULL; lnum++)
++ for (lnum = 1, lc = LC_COMPLETE; (line = get_line(fp)) != NULL; lnum++)
+ {
+ /* is this the tag definition? */
+ if (taglnum > 0 ? taglnum == lnum : !strncmp(tagline, line, len))
+@@ -377,7 +377,7 @@
+ {
+ if (strchr(line, '(') != NULL)
+ {
+- while ((line = getline(fp)) != NULL
++ while ((line = get_line(fp)) != NULL
+ && *line
+ && ((*line != '#' && *line != '{')
+ || line[strlen(line) - 1] == '\\'))
+@@ -387,7 +387,7 @@
+ }
+ else if ((lc = classify(line, lc)) == LC_PARTIAL)
+ {
+- while ((line = getline(fp)) != NULL
++ while ((line = get_line(fp)) != NULL
+ && (lc = classify(line, lc)) == LC_PARTIAL)
+ {
+ puts(line);
diff --git a/app-editors/elvis/files/elvis-2.2.0-interix.patch b/app-editors/elvis/files/elvis-2.2.0-interix.patch
new file mode 100644
index 000000000000..e16024374716
--- /dev/null
+++ b/app-editors/elvis/files/elvis-2.2.0-interix.patch
@@ -0,0 +1,11 @@
+diff -ru -x '*.Po' -x '*.Plo' elvis-2.2_0.orig/osunix/osblock.c elvis-2.2_0/osunix/osblock.c
+--- elvis-2.2_0.orig/osunix/osblock.c 2008-04-03 12:00:26 +0200
++++ elvis-2.2_0/osunix/osblock.c 2008-04-03 12:01:53 +0200
+@@ -293,5 +293,7 @@
+ return;
+ #endif
+
++#ifndef __INTERIX
+ sync();
++#endif
+ }
diff --git a/app-editors/elvis/files/ft2.3-symbol-collision-fix.patch b/app-editors/elvis/files/ft2.3-symbol-collision-fix.patch
new file mode 100644
index 000000000000..aac099e56ef7
--- /dev/null
+++ b/app-editors/elvis/files/ft2.3-symbol-collision-fix.patch
@@ -0,0 +1,73 @@
+diff -ur elvis-2.2_0-orig/guix11/tags elvis-2.2_0/guix11/tags
+--- elvis-2.2_0-orig/guix11/tags 2003-10-20 19:32:26.000000000 -0700
++++ elvis-2.2_0/guix11/tags 2007-08-17 12:56:28.000000000 -0700
+@@ -31,7 +31,7 @@
+ DEFAULT_TOOLFG guix11.c 40;" d ln:40 file:
+ DEFAULT_XENCODING guix11.c 48;" d ln:48 file:
+ FT_DEFAULT xdialog.h 10;" ln:10 enum:X_FIELDTYPE
+-FT_FILE xdialog.h 10;" ln:10 enum:X_FIELDTYPE
++FT_FILEC xdialog.h 10;" ln:10 enum:X_FIELDTYPE
+ FT_LOCKED xdialog.h 10;" ln:10 enum:X_FIELDTYPE
+ FT_NUMBER xdialog.h 10;" ln:10 enum:X_FIELDTYPE
+ FT_ONEOF xdialog.h 10;" ln:10 enum:X_FIELDTYPE
+diff -ur elvis-2.2_0-orig/guix11/xdialog.c elvis-2.2_0/guix11/xdialog.c
+--- elvis-2.2_0-orig/guix11/xdialog.c 2003-10-20 19:32:26.000000000 -0700
++++ elvis-2.2_0/guix11/xdialog.c 2007-08-17 12:56:28.000000000 -0700
+@@ -387,7 +387,7 @@
+ case 'o': ft = FT_ONEOF, limit = scan; break;
+ case 'n': ft = FT_NUMBER, limit = scan; break;
+ case 's': ft = FT_STRING; break;
+- case 'f': ft = FT_FILE; break;
++ case 'f': ft = FT_FILEC; break;
+ case 'l': ft = FT_LOCKED; break;
+ }
+
+@@ -556,7 +556,7 @@
+ break;
+
+ case FT_STRING:
+- case FT_FILE:
++ case FT_FILEC:
+ button = addbutton(dia, "<", 'l', ELVCTRL('L'));
+ button->y = dia->y0 + dia->rowh * i;
+ button->x = dia->x0 + 3;
+@@ -1111,7 +1111,7 @@
+ newvalue = keystring(dia, key);
+ break;
+
+- case FT_FILE:
++ case FT_FILEC:
+ #ifdef FEATURE_COMPLETE
+ if (key == '\t')
+ {
+@@ -1179,7 +1179,7 @@
+ switch (dia->field[row].ft)
+ {
+ case FT_STRING:
+- case FT_FILE:
++ case FT_FILEC:
+ case FT_NUMBER:
+ case FT_LOCKED:
+ drawtext(dia, row);
+@@ -1207,7 +1207,7 @@
+ break;
+
+ case FT_STRING:
+- case FT_FILE:
++ case FT_FILEC:
+ if (button->shape == 'l')
+ if (row == dia->current
+ ? dia->shift > 0
+diff -ur elvis-2.2_0-orig/guix11/xdialog.h elvis-2.2_0/guix11/xdialog.h
+--- elvis-2.2_0-orig/guix11/xdialog.h 2003-10-20 19:32:26.000000000 -0700
++++ elvis-2.2_0/guix11/xdialog.h 2007-08-17 12:56:28.000000000 -0700
+@@ -5,7 +5,7 @@
+ FT_ONEOF, /* one of a preset list; includes boolean */
+ FT_NUMBER, /* numeric field */
+ FT_STRING, /* string field */
+- FT_FILE, /* string field where <Tab> does filename completion */
++ FT_FILEC, /* string field where <Tab> does filename completion */
+ FT_LOCKED /* non-editable field */
+ } X_FIELDTYPE;
+ typedef struct
+
diff --git a/app-editors/elvis/metadata.xml b/app-editors/elvis/metadata.xml
new file mode 100644
index 000000000000..5fcb67350f69
--- /dev/null
+++ b/app-editors/elvis/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>vim</herd>
+</pkgmetadata>