summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJimi Huotari <chiitoo@gentoo.org>2020-04-20 22:52:38 +0300
committerAndreas Sturmlechner <asturm@gentoo.org>2020-04-21 11:22:15 +0200
commit9f75c3a0c0983eb37c361d0c883be5550ab97cff (patch)
treeaf9f145159d4543a69a4058f52d5c6663203ba80 /app-editors/focuswriter/focuswriter-1.7.5.ebuild
parentdev-python/markdown2: Bump to 2.3.8 (diff)
downloadgentoo-9f75c3a0c0983eb37c361d0c883be5550ab97cff.tar.gz
gentoo-9f75c3a0c0983eb37c361d0c883be5550ab97cff.tar.bz2
gentoo-9f75c3a0c0983eb37c361d0c883be5550ab97cff.zip
app-editors/focuswriter: add version 1.7.5
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Jimi Huotari <chiitoo@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/15444 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'app-editors/focuswriter/focuswriter-1.7.5.ebuild')
-rw-r--r--app-editors/focuswriter/focuswriter-1.7.5.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/app-editors/focuswriter/focuswriter-1.7.5.ebuild b/app-editors/focuswriter/focuswriter-1.7.5.ebuild
new file mode 100644
index 000000000000..de11e6825890
--- /dev/null
+++ b/app-editors/focuswriter/focuswriter-1.7.5.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit qmake-utils xdg
+
+DESCRIPTION="Fullscreen and distraction-free word processor"
+HOMEPAGE="https://gottcode.org/focuswriter/"
+SRC_URI="https://gottcode.org/${PN}/${P}-src.tar.bz2"
+
+LICENSE="GPL-3 LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+BDEPEND="
+ dev-qt/linguist-tools:5
+ virtual/pkgconfig
+"
+RDEPEND="
+ app-text/hunspell:=
+ >=dev-qt/qtcore-5.11:5
+ >=dev-qt/qtgui-5.11:5
+ >=dev-qt/qtmultimedia-5.11:5
+ >=dev-qt/qtprintsupport-5.11:5
+ dev-qt/qtsingleapplication[qt5(+),X]
+ >=dev-qt/qtwidgets-5.11:5
+ sys-libs/zlib
+"
+DEPEND="${RDEPEND}
+ dev-qt/qtconcurrent:5
+"
+
+DOCS=( ChangeLog CREDITS README )
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.6.0-unbundle-qtsingleapplication.patch"
+ "${FILESDIR}/${PN}-1.7.5-qt-5.15-build.patch"
+)
+
+src_configure() {
+ eqmake5 PREFIX="${EPREFIX}"/usr
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install
+ einstalldocs
+}