summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2017-03-16 19:54:22 +0100
committerDavid Seifert <soap@gentoo.org>2017-03-16 20:10:52 +0100
commit17083e8e439151bed48e85b74790371a5e8911e3 (patch)
tree88af5177fc4c6c2e1febb950ed2c57f8a16cab16 /app-editors/gedit
parentsys-apps/man2html: arm ppc64 stable (bug 607198). (diff)
downloadgentoo-17083e8e439151bed48e85b74790371a5e8911e3.tar.gz
gentoo-17083e8e439151bed48e85b74790371a5e8911e3.tar.bz2
gentoo-17083e8e439151bed48e85b74790371a5e8911e3.zip
app-editors/gedit: Port to python-single-r1
Package-Manager: Portage-2.3.4, Repoman-2.3.2 Closes: https://github.com/gentoo/gentoo/pull/4175
Diffstat (limited to 'app-editors/gedit')
-rw-r--r--app-editors/gedit/gedit-3.20.2.ebuild11
-rw-r--r--app-editors/gedit/gedit-3.22.0.ebuild11
2 files changed, 6 insertions, 16 deletions
diff --git a/app-editors/gedit/gedit-3.20.2.ebuild b/app-editors/gedit/gedit-3.20.2.ebuild
index e19b56b49a1d..bc8a01f8cd9d 100644
--- a/app-editors/gedit/gedit-3.20.2.ebuild
+++ b/app-editors/gedit/gedit-3.20.2.ebuild
@@ -7,7 +7,7 @@ PYTHON_COMPAT=( python3_{4,5} )
VALA_MIN_API_VERSION="0.26"
VALA_USE_DEPEND="vapigen"
-inherit eutils gnome2 multilib python-r1 vala virtualx
+inherit eutils gnome2 multilib python-single-r1 vala virtualx
DESCRIPTION="A text editor for the GNOME desktop"
HOMEPAGE="https://wiki.gnome.org/Apps/Gedit"
@@ -16,12 +16,7 @@ LICENSE="GPL-2+ CC-BY-SA-3.0"
SLOT="0"
IUSE="+introspection +python spell vala"
-# python-single-r1 would request disabling PYTHON_TARGETS on libpeas
-# we need to fix that
-REQUIRED_USE="
- python? ( introspection )
- python? ( ^^ ( $(python_gen_useflags '*') ) )
-"
+REQUIRED_USE="python? ( introspection ${PYTHON_REQUIRED_USE} )"
KEYWORDS="~alpha amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux"
@@ -65,7 +60,7 @@ DEPEND="${COMMON_DEPEND}
# yelp-tools, gnome-common needed to eautoreconf
pkg_setup() {
- use python && [[ ${MERGE_TYPE} != binary ]] && python_setup
+ use python && [[ ${MERGE_TYPE} != binary ]] && python-single-r1_pkg_setup
}
src_prepare() {
diff --git a/app-editors/gedit/gedit-3.22.0.ebuild b/app-editors/gedit/gedit-3.22.0.ebuild
index e77e4f2624fa..207bc1e9f00b 100644
--- a/app-editors/gedit/gedit-3.22.0.ebuild
+++ b/app-editors/gedit/gedit-3.22.0.ebuild
@@ -7,7 +7,7 @@ PYTHON_COMPAT=( python3_{4,5} )
VALA_MIN_API_VERSION="0.26"
VALA_USE_DEPEND="vapigen"
-inherit eutils gnome2 multilib python-r1 vala virtualx
+inherit eutils gnome2 multilib python-single-r1 vala virtualx
DESCRIPTION="A text editor for the GNOME desktop"
HOMEPAGE="https://wiki.gnome.org/Apps/Gedit"
@@ -16,12 +16,7 @@ LICENSE="GPL-2+ CC-BY-SA-3.0"
SLOT="0"
IUSE="+introspection +python spell vala"
-# python-single-r1 would request disabling PYTHON_TARGETS on libpeas
-# we need to fix that
-REQUIRED_USE="
- python? ( introspection )
- python? ( ^^ ( $(python_gen_useflags '*') ) )
-"
+REQUIRED_USE="python? ( introspection ${PYTHON_REQUIRED_USE} )"
KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux"
@@ -61,7 +56,7 @@ DEPEND="${COMMON_DEPEND}
# yelp-tools, gnome-common needed to eautoreconf
pkg_setup() {
- use python && [[ ${MERGE_TYPE} != binary ]] && python_setup
+ use python && [[ ${MERGE_TYPE} != binary ]] && python-single-r1_pkg_setup
}
src_prepare() {