summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorСухарик <suhr@i2pmail.org>2016-02-22 00:23:53 +0300
committerPatrice Clement <monsieurp@gentoo.org>2016-02-24 20:45:57 +0000
commit641785ad7368aca79dbcacda2098927fab7dce9a (patch)
tree867030dcb9f1b5a9a471410f3527d93860ed3038 /app-editors/ghostwriter/ghostwriter-1.2.5.ebuild
parentdev-libs/libzip: Remove old (diff)
downloadgentoo-641785ad7368aca79dbcacda2098927fab7dce9a.tar.gz
gentoo-641785ad7368aca79dbcacda2098927fab7dce9a.tar.bz2
gentoo-641785ad7368aca79dbcacda2098927fab7dce9a.zip
app-editors/ghostwriter: new ebuild
Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'app-editors/ghostwriter/ghostwriter-1.2.5.ebuild')
-rw-r--r--app-editors/ghostwriter/ghostwriter-1.2.5.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/app-editors/ghostwriter/ghostwriter-1.2.5.ebuild b/app-editors/ghostwriter/ghostwriter-1.2.5.ebuild
new file mode 100644
index 000000000000..db294e42e211
--- /dev/null
+++ b/app-editors/ghostwriter/ghostwriter-1.2.5.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit qmake-utils
+
+DESCRIPTION="A cross-platform, aesthetic, distraction-free Markdown editor"
+HOMEPAGE="http://wereturtle.github.io/ghostwriter/"
+SRC_URI="https://github.com/wereturtle/ghostwriter/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="qt5"
+
+DEPEND="
+ qt5? (
+ dev-qt/qtprintsupport:5
+ dev-qt/qtwebkit:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtconcurrent:5
+ )
+ !qt5? ( dev-qt/qtwebkit:4 )
+"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ if use qt5
+ then eqmake5 "PREFIX=/usr"
+ else eqmake4 "PREFIX=/usr"
+ fi
+
+ emake
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install
+}