summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillermo Joandet <gjoandet@gmail.com>2023-07-29 10:22:09 -0300
committerMatt Turner <mattst88@gentoo.org>2023-08-08 11:03:15 -0400
commitf3e6df30f6c48fcdf87c35889bd8427e1dd189a0 (patch)
tree2752a5f24fd2f4b0b23f57a54451d20e16194a34 /app-editors/gnome-latex/gnome-latex-3.46.0.ebuild
parentgui-libs/tepl: Version bump to 6.8.0 (diff)
downloadgentoo-f3e6df30f6c48fcdf87c35889bd8427e1dd189a0.tar.gz
gentoo-f3e6df30f6c48fcdf87c35889bd8427e1dd189a0.tar.bz2
gentoo-f3e6df30f6c48fcdf87c35889bd8427e1dd189a0.zip
app-editors/gnome-latex: Version bump to 3.46.0
Signed-off-by: Guillermo Joandet <gjoandet@gmail.com> Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'app-editors/gnome-latex/gnome-latex-3.46.0.ebuild')
-rw-r--r--app-editors/gnome-latex/gnome-latex-3.46.0.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/app-editors/gnome-latex/gnome-latex-3.46.0.ebuild b/app-editors/gnome-latex/gnome-latex-3.46.0.ebuild
new file mode 100644
index 000000000000..7eef6891a7dd
--- /dev/null
+++ b/app-editors/gnome-latex/gnome-latex-3.46.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome2
+
+DESCRIPTION="Integrated LaTeX environment for GNOME"
+HOMEPAGE="https://gitlab.gnome.org/swilmet/gnome-latex"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+IUSE="+introspection +latexmk rubber"
+
+DEPEND="
+ >=dev-libs/glib-2.70:2
+ >=x11-libs/gtk+-3.22:3
+ >=app-text/gspell-1.8:0=
+ >=gui-libs/libgedit-amtk-5:=
+ >=gui-libs/tepl-6.8:=
+ >=dev-libs/libgee-0.10:0.8=
+ gnome-base/gsettings-desktop-schemas
+ x11-libs/gdk-pixbuf:2
+ x11-libs/pango
+ introspection? ( >=dev-libs/gobject-introspection-1.30.0:= )
+ gnome-base/dconf
+"
+RDEPEND="${DEPEND}
+ virtual/latex-base
+ x11-themes/hicolor-icon-theme
+ latexmk? ( dev-tex/latexmk )
+ rubber? ( dev-tex/rubber )
+"
+BDEPEND="
+ dev-util/gdbus-codegen
+ dev-util/glib-utils
+ >=dev-util/gtk-doc-am-1.14
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.6:0
+ virtual/pkgconfig
+"
+
+src_configure() {
+ gnome2_src_configure \
+ $(use_enable introspection) \
+ --enable-dconf_migration
+}