summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Bracht Laumann Jespersen <t@laumann.xyz>2022-07-28 13:38:41 +0200
committerMike Gilbert <floppym@gentoo.org>2022-07-29 10:23:37 -0400
commit3ef27af1c70f65c0fd350ff26a8adb3c7d750e11 (patch)
tree45eec9fc21e23bc1ce4dfecf3e8d4f170472a06b /app-editors/gvim/gvim-9999.ebuild
parentapp-editors/vim: update LUA_COMPAT and USE_RUBY (diff)
downloadgentoo-3ef27af1c70f65c0fd350ff26a8adb3c7d750e11.tar.gz
gentoo-3ef27af1c70f65c0fd350ff26a8adb3c7d750e11.tar.bz2
gentoo-3ef27af1c70f65c0fd350ff26a8adb3c7d750e11.zip
app-editors/gvim: update LUA_COMPAT and USE_RUBY
Lua 5.4 should be supported since v8.2.1212 (over 2 years ago), so extend LUA_COMPAT to include Lua versions 5.3 and 5.4. Ruby versions up to and including 3.1 should also be supported since v8.2.3922, so extend USE_RUBY to include Ruby 3.0 and 3.1. See: https://github.com/vim/vim/commit/5551b131daef3a621a28dcbbe118920f5b9fabe6 See: https://github.com/vim/vim/commit/8bb3fe4d4dcd27c02e903f6772fdc8fe2e9eba70 Thanks-to: Arfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org> Signed-off-by: Thomas Bracht Laumann Jespersen <t@laumann.xyz> Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'app-editors/gvim/gvim-9999.ebuild')
-rw-r--r--app-editors/gvim/gvim-9999.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/app-editors/gvim/gvim-9999.ebuild b/app-editors/gvim/gvim-9999.ebuild
index aaab6e09d27d..bc764c8a6675 100644
--- a/app-editors/gvim/gvim-9999.ebuild
+++ b/app-editors/gvim/gvim-9999.ebuild
@@ -6,10 +6,10 @@ EAPI=8
# Please bump with app-editors/vim-core and app-editors/vim
VIM_VERSION="9.0"
-LUA_COMPAT=( lua5-1 luajit )
+LUA_COMPAT=( lua5-{1..4} luajit )
PYTHON_COMPAT=( python3_{8..11} )
PYTHON_REQ_USE="threads(+)"
-USE_RUBY="ruby26 ruby27"
+USE_RUBY="ruby27 ruby30 ruby31"
inherit vim-doc flag-o-matic xdg-utils bash-completion-r1 prefix lua-single python-single-r1 ruby-single