summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2016-09-05 16:31:40 +0200
committerLars Wendler <polynomial-c@gentoo.org>2016-09-05 16:33:24 +0200
commitd3d7b6a3dfb8b5da150f290ce1e5b418e166aec5 (patch)
tree46d0447cf7bf6b9d1cbb4809f12df1f48f88618b /app-editors/joe/joe-4.3-r1.ebuild
parentmedia-video/kffmpegthumbnailer: Remove last-rited pkg (diff)
downloadgentoo-d3d7b6a3dfb8b5da150f290ce1e5b418e166aec5.tar.gz
gentoo-d3d7b6a3dfb8b5da150f290ce1e5b418e166aec5.tar.bz2
gentoo-d3d7b6a3dfb8b5da150f290ce1e5b418e166aec5.zip
app-editors/joe: Revbump to fix linking against sys-libs/ncurses[tinfo]
Also get rid of remaining QA issues as pointed out by Soap__ again. This hopefully fixes bug #579172 as well. Package-Manager: portage-2.3.0 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'app-editors/joe/joe-4.3-r1.ebuild')
-rw-r--r--app-editors/joe/joe-4.3-r1.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/app-editors/joe/joe-4.3-r1.ebuild b/app-editors/joe/joe-4.3-r1.ebuild
new file mode 100644
index 000000000000..446ac94c11d8
--- /dev/null
+++ b/app-editors/joe/joe-4.3-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="A free ASCII-Text Screen Editor for UNIX"
+HOMEPAGE="https://sourceforge.net/projects/joe-editor/"
+SRC_URI="mirror://sourceforge/joe-editor/${P}.tar.gz"
+
+LICENSE="GPL-1+ CC-BY-3.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris"
+IUSE="xterm"
+
+DEPEND=">=sys-libs/ncurses-5.2-r2:0="
+RDEPEND="${DEPEND}
+ xterm? ( >=x11-terms/xterm-239 )"
+
+DOCS=( README.md NEWS.md docs/hacking.md docs/man.md )
+
+PATCHES=( "${FILESDIR}/${PN}-4.3-tinfo.patch" )
+
+src_prepare() {
+ default
+ # Enable xterm mouse support in the rc files
+ if use xterm; then
+ cd "${S}"/rc || die
+ local i
+ for i in *rc*.in; do
+ sed -e 's/^ -\(mouse\|joexterm\)/-\1/' -i "${i}" || die
+ done
+ fi
+ eautoreconf
+}
+
+pkg_postinst() {
+ if use xterm; then
+ elog "To enable full xterm clipboard you need to set the allowWindowOps"
+ elog "resources to true. This is usually found in /etc/X11/app-defaults/XTerm"
+ elog "This is false by default due to potential security problems on some"
+ elog "architectures (see bug #91453)."
+ fi
+}