summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAmy Liffey <amynka@gentoo.org>2018-01-29 22:46:31 +0100
committerAmy Liffey <amynka@gentoo.org>2018-01-29 22:46:31 +0100
commit0e666ef5eba2a00e83ee193cc07850a11583fd3f (patch)
tree86f98cbd12f545061457850a2421f0492646fa3b /app-editors/joe
parentsys-fs/udev: disable several optional libraries (diff)
downloadgentoo-0e666ef5eba2a00e83ee193cc07850a11583fd3f.tar.gz
gentoo-0e666ef5eba2a00e83ee193cc07850a11583fd3f.tar.bz2
gentoo-0e666ef5eba2a00e83ee193cc07850a11583fd3f.zip
app-editors/joe: version bump 4.6
Closes: https://bugs.gentoo.org/644184 Package-Manager: Portage-2.3.13, Repoman-2.3.3
Diffstat (limited to 'app-editors/joe')
-rw-r--r--app-editors/joe/Manifest1
-rw-r--r--app-editors/joe/files/joe-4.6-db.patch11
-rw-r--r--app-editors/joe/joe-4.6.ebuild56
3 files changed, 68 insertions, 0 deletions
diff --git a/app-editors/joe/Manifest b/app-editors/joe/Manifest
index a774b916eb91..15f8bc779608 100644
--- a/app-editors/joe/Manifest
+++ b/app-editors/joe/Manifest
@@ -1,3 +1,4 @@
DIST joe-4.2.tar.gz 1341048 BLAKE2B 112163e67311051dad8714e19cdee1a11ff3bbe297341c89a4023f7d68fac7eecde57d1d522f72407b0a77c227c7af424ce20567c0c47dea6c14ac41f2f2301b SHA512 7c34f4467d89330ac195cfa76481d9ede4ee3764d0b1b24d091d1e6325bff451d2a9bc9f86a73404c9909587bcbe3e0c14511b739ec121edb7595ea1fcba028f
DIST joe-4.3.tar.gz 1270523 BLAKE2B 442e05dd29a0a8d4a26500c89a2cafee88bf2d1ed00a4cb539d940e2e849456e6c4c5bf347b4803ee02ab38311b225cc8034177a1e0b7a1967a2629fd283b7e2 SHA512 a711ce129518863856b8f581ac7acdd7661f5e571cb77c5411317e0db0344c9ba44e73ec2ca9a307e639170a7914d53352eebcd00a33c9270809551f12376e69
DIST joe-4.4.tar.gz 1350062 BLAKE2B eb58117e313ef4abc31026a2800f2b9258c12d0d865c768138ec42a97c1f7fedcd8e397f7aaf13f8bb3776f2571d5a85e27ea7f9a6fbd6710d935a2b80afcd1f SHA512 ef31443dda30569c5193cd1907e06f1caba349f746dedf3611b5527080e49a4026001d3d06629f3c9c712ae9265866efbdbba6f51d110c0e6ee95f39f0e3059d
+DIST joe-4.6.tar.gz 1895046 BLAKE2B fbf53d3b5b066cb32bb26b08d7d314a3bb89ac5ae22db498cdf3597bf8cb322bd9aa05543debd47ac7380a33982c388e13f38c60747503494c582393ae8eb13d SHA512 3dd64a994fb3d352a12bf027ef16d57d14ac2577fd63fb6b6e25cae46052befaa7c15dc029bff2f8c3275df90f0343bd46313601055d97277ea4540e109fbe82
diff --git a/app-editors/joe/files/joe-4.6-db.patch b/app-editors/joe/files/joe-4.6-db.patch
new file mode 100644
index 000000000000..6270e9045cd8
--- /dev/null
+++ b/app-editors/joe/files/joe-4.6-db.patch
@@ -0,0 +1,11 @@
+--- a/desktop/Makefile.am 2018-01-15 12:01:12.624449958 +0100
++++ b/desktop/Makefile.am 2018-01-15 12:01:38.964448343 +0100
+@@ -1,8 +1,2 @@
+ desktopdir = $(datarootdir)/applications
+ dist_desktop_DATA = joe.desktop jmacs.desktop jstar.desktop jpico.desktop
+-
+-update-databases:
+- -update-desktop-database $(desktopdir)
+-
+-install-data-hook: update-databases
+-uninstall-hook: update-databases
diff --git a/app-editors/joe/joe-4.6.ebuild b/app-editors/joe/joe-4.6.ebuild
new file mode 100644
index 000000000000..9c03dcbe1bc0
--- /dev/null
+++ b/app-editors/joe/joe-4.6.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools gnome2-utils
+
+DESCRIPTION="A free ASCII-Text Screen Editor for UNIX"
+HOMEPAGE="https://sourceforge.net/projects/joe-editor/"
+SRC_URI="mirror://sourceforge/joe-editor/${P}.tar.gz"
+
+LICENSE="GPL-1+ CC-BY-3.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris"
+IUSE="xterm"
+
+DEPEND=">=sys-libs/ncurses-5.2-r2:0="
+RDEPEND="${DEPEND}
+ xterm? ( >=x11-terms/xterm-239 )"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-4.3-tinfo.patch"
+ "${FILESDIR}/${P}-db.patch"
+)
+
+DOCS=( README.md NEWS.md docs/hacking.md docs/man.md )
+
+src_prepare() {
+ default
+ # Enable xterm mouse support in the rc files
+ if use xterm; then
+ pushd "${S}"/rc &>/dev/null || die
+ local i
+ for i in *rc*.in; do
+ sed -e 's/^ -\(mouse\|joexterm\)/-\1/' -i "${i}" || die
+ done
+ popd &>/dev/null
+ fi
+ eautoreconf
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ gnome2_icon_cache_update
+ if use xterm; then
+ elog "To enable full xterm clipboard you need to set the allowWindowOps"
+ elog "resources to true. This is usually found in /etc/X11/app-defaults/XTerm"
+ elog "This is false by default due to potential security problems on some"
+ elog "architectures (see bug #91453)."
+ fi
+}
+
+pkg_postrm(){
+ xdg_desktop_database_update
+ gnome2_icon_cache_update
+}